summaryrefslogtreecommitdiffstats
path: root/target/linux/archs38
diff options
context:
space:
mode:
authorAlexey Brodkin <Alexey.Brodkin@synopsys.com>2016-08-16 14:49:17 +0300
committerJohn Crispin <john@phrozen.org>2016-08-16 12:19:01 +0200
commit5f55df433d811318a66160348224dbc7dd79a706 (patch)
tree726ce8c7a3a88742f03c0fdb472160b4805e22ed /target/linux/archs38
parenta3cde14f5a9ef0bca820341cbbd6d5cfb80451fc (diff)
downloadmaster-31e0f0ae-5f55df433d811318a66160348224dbc7dd79a706.tar.gz
master-31e0f0ae-5f55df433d811318a66160348224dbc7dd79a706.tar.bz2
master-31e0f0ae-5f55df433d811318a66160348224dbc7dd79a706.zip
archs38: Reduce generalization
As support of ARC HS38 in OpenWRT/Lede matures we don't need debug-only output binaries any longer, so purging vmlinux for AXS10x boards. As for uImage for nSIM it makes completely no sense because there's no way to run U-Boot on nSIM. So we remove add_archs38_XXX scripts making code more compact and cleaner. Signed-off-by: Alexey Brodkin <abrodkin@synopsys.com>
Diffstat (limited to 'target/linux/archs38')
-rw-r--r--target/linux/archs38/image/Makefile34
1 files changed, 11 insertions, 23 deletions
diff --git a/target/linux/archs38/image/Makefile b/target/linux/archs38/image/Makefile
index bda7f3f539..f5dce288bd 100644
--- a/target/linux/archs38/image/Makefile
+++ b/target/linux/archs38/image/Makefile
@@ -34,35 +34,23 @@ define Device/vmlinux
endef
define Device/uImage
- KERNEL_SUFFIX := .bin
+ KERNEL_SUFFIX := -uImage
KERNEL_INITRAMFS := kernel-bin | patch-dtb | calculate-ep | uImage none
KERNEL_LOADADDR := 0x80000000
endef
-define add_archs38_uImage
- define Device/$(1)-uImage
- $(call Device/uImage)
- DEVICE_PROFILE := $(1)
- DEVICE_DTS := $(1)
- endef
- TARGET_DEVICES += $(1)-uImage
+define Device/axs103
+ $(call Device/uImage)
+ DEVICE_PROFILE := axs103
+ DEVICE_DTS := axs103_idu
endef
+TARGET_DEVICES += axs103
-define add_archs38_vmlinux
- define Device/$(1)-vmlinux
- $(call Device/vmlinux)
- DEVICE_PROFILE := $(1)
- DEVICE_DTS := $(1)
- endef
- TARGET_DEVICES += $(1)-vmlinux
+define Device/nsim_hs
+ $(call Device/vmlinux)
+ DEVICE_PROFILE := nsim_hs
+ DEVICE_DTS := nsim_hs_idu
endef
-
-# DesignWare AXS103
-$(eval $(call add_archs38_vmlinux,axs103_idu))
-$(eval $(call add_archs38_uImage,axs103_idu))
-
-# nSIM with ARCHS38
-$(eval $(call add_archs38_vmlinux,nsim_hs_idu))
-$(eval $(call add_archs38_uImage,nsim_hs_idu))
+TARGET_DEVICES += nsim_hs
$(eval $(call BuildImage))