summaryrefslogtreecommitdiffstats
path: root/target/linux/archs38/generic
diff options
context:
space:
mode:
authorAlexey Brodkin <Alexey.Brodkin@synopsys.com>2016-08-19 13:58:36 +0300
committerJohn Crispin <john@phrozen.org>2016-08-20 05:33:47 +0200
commit334fdea08d71079d6e0f5bc8dc79790c0402ae2a (patch)
treedb91746f7c60a25dde9f3dc78244c53be7b88477 /target/linux/archs38/generic
parent070edfd92f8f83a93312a7df5f59048d74286584 (diff)
downloadmaster-31e0f0ae-334fdea08d71079d6e0f5bc8dc79790c0402ae2a.tar.gz
master-31e0f0ae-334fdea08d71079d6e0f5bc8dc79790c0402ae2a.tar.bz2
master-31e0f0ae-334fdea08d71079d6e0f5bc8dc79790c0402ae2a.zip
archs38: Merge sd and ramfs subtargets in generic again
As it turned out we may actually build both initramfs and SD-based images in one run with just a small tweak in existing image/Makefile and so we do here. We're back with one "generic" target for all ARC HS38-based bords. Kudos to John for his patience and very helpful tips! Signed-off-by: John Crispin <john@phrozen.org> Signed-off-by: Alexey Brodkin <abrodkin@synopsys.com> Cc: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'target/linux/archs38/generic')
-rw-r--r--target/linux/archs38/generic/profiles/00-default.mk16
-rw-r--r--target/linux/archs38/generic/target.mk8
2 files changed, 24 insertions, 0 deletions
diff --git a/target/linux/archs38/generic/profiles/00-default.mk b/target/linux/archs38/generic/profiles/00-default.mk
new file mode 100644
index 0000000000..fd8143a166
--- /dev/null
+++ b/target/linux/archs38/generic/profiles/00-default.mk
@@ -0,0 +1,16 @@
+#
+# Copyright (C) 2016 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Default
+ NAME:=Default Profile (all drivers)
+ PACKAGES:= kmod-usb-core kmod-usb-ohci kmod-ath9k-htc wpad-mini
+endef
+
+define Profile/Default/Description
+ Default package set compatible with most boards.
+endef
+$(eval $(call Profile,Default))
diff --git a/target/linux/archs38/generic/target.mk b/target/linux/archs38/generic/target.mk
new file mode 100644
index 0000000000..7642c6b261
--- /dev/null
+++ b/target/linux/archs38/generic/target.mk
@@ -0,0 +1,8 @@
+BOARDNAME:=Generic
+FEATURES += ext4 usb ramdisk
+
+define Target/Description
+ Build firmware images for ARC HS38 based boards.
+endef
+
+