summaryrefslogtreecommitdiffstats
path: root/target/linux/archs38/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2016-02-18 08:22:32 +0000
committerJohn Crispin <john@openwrt.org>2016-02-18 08:22:32 +0000
commit73015c4cb3787cccadc72b53fdb84b2d45c90136 (patch)
treecea0bb920bf3d0e71a37a09ef861eccc353fdf69 /target/linux/archs38/Makefile
parent7b821a5ae882cb0c70fd9d09ec9d5952985951dc (diff)
downloadmaster-31e0f0ae-73015c4cb3787cccadc72b53fdb84b2d45c90136.tar.gz
master-31e0f0ae-73015c4cb3787cccadc72b53fdb84b2d45c90136.tar.bz2
master-31e0f0ae-73015c4cb3787cccadc72b53fdb84b2d45c90136.zip
linux: add support of Synopsys ARCHS38-based boards
This patch introduces support of new boards with ARC HS38 cores. ARC HS38 is a new generation of ARC cores which utilize ARCv2 ISA. As with ARC770 we're addind support for 2 boards for now: [1] Synopsys SDP board (AXS103) This is the same base-board as in AXS101 but with FPGA-based CPU-tile where ARCHs38 core is implemented. [2] nSIM Again this is the same simulation engine but configured for new instruction set and features of new CPU. Signed-off-by: Alexey Brodkin <abrodkin@synopsys.com> Cc: Felix Fietkau <nbd@openwrt.org> Cc: Jo-Philipp Wich <jow@openwrt.org> Cc: Jonas Gorski <jogo@openwrt.org> SVN-Revision: 48740
Diffstat (limited to 'target/linux/archs38/Makefile')
-rw-r--r--target/linux/archs38/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/target/linux/archs38/Makefile b/target/linux/archs38/Makefile
new file mode 100644
index 0000000000..166d3d5540
--- /dev/null
+++ b/target/linux/archs38/Makefile
@@ -0,0 +1,26 @@
+#
+# Copyright (C) 2016 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=arc
+CPU_TYPE:=archs
+BOARD:=archs38
+BOARDNAME:=Synopsys DesignWare ARC HS38
+MAINTAINER:=Alexey Brodkin <abrodkin@synopsys.com>
+SUBTARGETS:=generic
+
+KERNEL_PATCHVER:=4.4
+
+DEVICE_TYPE:=developerboard
+
+include $(INCLUDE_DIR)/target.mk
+
+define Target/Description
+ Synopsys DesignWare boards
+endef
+
+$(eval $(call BuildTarget))