summaryrefslogtreecommitdiffstats
path: root/target/linux/arc770/image
diff options
context:
space:
mode:
authorAlexey Brodkin <Alexey.Brodkin@synopsys.com>2016-08-16 14:49:16 +0300
committerJohn Crispin <john@phrozen.org>2016-08-16 12:18:28 +0200
commita3cde14f5a9ef0bca820341cbbd6d5cfb80451fc (patch)
tree44a6574cc3da210b7ab4fb4b9744c90053df0353 /target/linux/arc770/image
parentc41506625a87dae1596c0b74fe74dec14005fd82 (diff)
downloadmaster-31e0f0ae-a3cde14f5a9ef0bca820341cbbd6d5cfb80451fc.tar.gz
master-31e0f0ae-a3cde14f5a9ef0bca820341cbbd6d5cfb80451fc.tar.bz2
master-31e0f0ae-a3cde14f5a9ef0bca820341cbbd6d5cfb80451fc.zip
arc: use patched .dts from sources
Instead of using off-the-tree .dts files for ARC boards we're switching to use in-tree ones. And for that to work properly we apply upstream patch that adds currently missing "model" property. Upstream patch and discussion could be found here: http://lists.infradead.org/pipermail/linux-snps-arc/2016-August/001394.html Signed-off-by: Alexey Brodkin <abrodkin@synopsys.com> Cc: Jonas Gorski <jonas.gorski@gmail.com> Cc: John Crispin <john@phrozen.org>
Diffstat (limited to 'target/linux/arc770/image')
-rw-r--r--target/linux/arc770/image/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/arc770/image/Makefile b/target/linux/arc770/image/Makefile
index 1e44d6abd5..ca204a4a55 100644
--- a/target/linux/arc770/image/Makefile
+++ b/target/linux/arc770/image/Makefile
@@ -15,7 +15,7 @@ define Build/calculate-ep
endef
define Build/patch-dtb
- $(call Image/BuildDTB,../dts/$(DEVICE_DTS).dts,$@.dtb)
+ $(call Image/BuildDTB,$(DTS_DIR)/$(DEVICE_DTS).dts,$@.dtb)
$(STAGING_DIR_HOST)/bin/patch-dtb $@ $@.dtb
endef