summaryrefslogtreecommitdiffstats
path: root/target/linux/arc770/generic
diff options
context:
space:
mode:
authorAlexey Brodkin <Alexey.Brodkin@synopsys.com>2016-08-24 17:48:12 +0300
committerFelix Fietkau <nbd@nbd.name>2016-08-28 13:51:42 +0200
commit30d75720faa8d9e92454705e15d5f9ebcb9d0c6a (patch)
tree4e07adbb88c970eb722fd2bf286cf126263e739b /target/linux/arc770/generic
parentca519d4f8d757fdeab28515b34e51820ad0764f8 (diff)
downloadmaster-31e0f0ae-30d75720faa8d9e92454705e15d5f9ebcb9d0c6a.tar.gz
master-31e0f0ae-30d75720faa8d9e92454705e15d5f9ebcb9d0c6a.tar.bz2
master-31e0f0ae-30d75720faa8d9e92454705e15d5f9ebcb9d0c6a.zip
arc770: Introduce images for SD-cards
Historically on ARC we started from initramfs-based images because: a) It was much easier to debug especially when toolchain and other components were changing quite dynamically b) It was our usual approach for embedded Linux But now with ARC port of Lede/OpenWRT getting more stable and mature we're ready for more real-life scenarios with FS permanently stored on SD-card. This essentially benefits from ability to setup devices that survive reboots with all settings and extra packages kept in place. Still we keep an ability to build images with initramfs. This allows us to use storage-less simulators for testing still. Signed-off-by: Alexey Brodkin <abrodkin@synopsys.com> Cc: John Crispin <john@phrozen.org> Cc: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'target/linux/arc770/generic')
-rw-r--r--target/linux/arc770/generic/profiles/01-minimal.mk15
-rw-r--r--target/linux/arc770/generic/profiles/02-axs101.mk16
-rw-r--r--target/linux/arc770/generic/profiles/03-nsim_700.mk15
-rw-r--r--target/linux/arc770/generic/target.mk2
4 files changed, 1 insertions, 47 deletions
diff --git a/target/linux/arc770/generic/profiles/01-minimal.mk b/target/linux/arc770/generic/profiles/01-minimal.mk
deleted file mode 100644
index c8968daecd..0000000000
--- a/target/linux/arc770/generic/profiles/01-minimal.mk
+++ /dev/null
@@ -1,15 +0,0 @@
-#
-# Copyright (C) 2015 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/Minimal
- NAME:=Minimal Profile (no drivers)
-endef
-
-define Profile/Minimal/Description
- Minimal package set compatible with most boards.
-endef
-$(eval $(call Profile,Minimal))
diff --git a/target/linux/arc770/generic/profiles/02-axs101.mk b/target/linux/arc770/generic/profiles/02-axs101.mk
deleted file mode 100644
index 3fb652612a..0000000000
--- a/target/linux/arc770/generic/profiles/02-axs101.mk
+++ /dev/null
@@ -1,16 +0,0 @@
-#
-# Copyright (C) 2015 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/axs101
- NAME:=Synopsys DesignWare AXS101
- PACKAGES:= kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-ath9k-htc wpad-mini
-endef
-
-define Profile/axs101/Description
- Package set compatible with hardware using Synopsys DesignWare AXS101 boards.
-endef
-$(eval $(call Profile,axs101))
diff --git a/target/linux/arc770/generic/profiles/03-nsim_700.mk b/target/linux/arc770/generic/profiles/03-nsim_700.mk
deleted file mode 100644
index 843a3424b5..0000000000
--- a/target/linux/arc770/generic/profiles/03-nsim_700.mk
+++ /dev/null
@@ -1,15 +0,0 @@
-#
-# Copyright (C) 2015 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/nsim_700
- NAME:=Synopsys nSIM
-endef
-
-define Profile/nsim_700/Description
- Package set compatible with hardware using Synopsys nSIM 700 boards.
-endef
-$(eval $(call Profile,nsim_700))
diff --git a/target/linux/arc770/generic/target.mk b/target/linux/arc770/generic/target.mk
index eba5c3c7e8..15f598ee16 100644
--- a/target/linux/arc770/generic/target.mk
+++ b/target/linux/arc770/generic/target.mk
@@ -1,5 +1,5 @@
BOARDNAME:=Generic
-FEATURES += ramdisk usb
+FEATURES += ramdisk usb ext4
define Target/Description
Build firmware images for generic ARC 770D based boards.