summaryrefslogtreecommitdiffstats
path: root/target/linux/ar7
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2015-05-21 19:32:46 +0000
committerJonas Gorski <jogo@openwrt.org>2015-05-21 19:32:46 +0000
commit76d079204df113afa9e382a43abb5e1a2135150d (patch)
tree8e472ab203e8d6a47dc2e285b3becbfca35d04c6 /target/linux/ar7
parent072937888e133f5e97fd05a7496eaf7eeae04079 (diff)
downloadmaster-31e0f0ae-76d079204df113afa9e382a43abb5e1a2135150d.tar.gz
master-31e0f0ae-76d079204df113afa9e382a43abb5e1a2135150d.tar.bz2
master-31e0f0ae-76d079204df113afa9e382a43abb5e1a2135150d.zip
kernel: update 3.18 to 3.18.14
Changelogs: * https://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.18.12 * https://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.18.13 * https://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.18.14 Build tested on brcm63xx and ipq806x, runtested on brcm63xx. Signed-off-by: Jonas Gorski <jogo@openwrt.org> SVN-Revision: 45711
Diffstat (limited to 'target/linux/ar7')
-rw-r--r--target/linux/ar7/patches-3.18/110-flash.patch2
-rw-r--r--target/linux/ar7/patches-3.18/160-vlynq_try_remote_first.patch6
-rw-r--r--target/linux/ar7/patches-3.18/300-add-ac49x-platform.patch4
-rw-r--r--target/linux/ar7/patches-3.18/320-ac49x-mtd-partitions.patch4
-rw-r--r--target/linux/ar7/patches-3.18/500-serial_kludge.patch8
-rw-r--r--target/linux/ar7/patches-3.18/920-ar7part.patch4
-rw-r--r--target/linux/ar7/patches-3.18/950-cpmac_titan.patch12
7 files changed, 20 insertions, 20 deletions
diff --git a/target/linux/ar7/patches-3.18/110-flash.patch b/target/linux/ar7/patches-3.18/110-flash.patch
index e12eec5f7d..e4aeffd3e2 100644
--- a/target/linux/ar7/patches-3.18/110-flash.patch
+++ b/target/linux/ar7/patches-3.18/110-flash.patch
@@ -1,6 +1,6 @@
--- a/drivers/mtd/Makefile
+++ b/drivers/mtd/Makefile
-@@ -16,7 +16,7 @@ obj-$(CONFIG_MTD_OF_PARTS) += ofpart.o
+@@ -12,7 +12,7 @@ obj-$(CONFIG_MTD_OF_PARTS) += ofpart.o
obj-$(CONFIG_MTD_REDBOOT_PARTS) += redboot.o
obj-$(CONFIG_MTD_CMDLINE_PARTS) += cmdlinepart.o
obj-$(CONFIG_MTD_AFS_PARTS) += afs.o
diff --git a/target/linux/ar7/patches-3.18/160-vlynq_try_remote_first.patch b/target/linux/ar7/patches-3.18/160-vlynq_try_remote_first.patch
index 841eb2307b..1d1310d82e 100644
--- a/target/linux/ar7/patches-3.18/160-vlynq_try_remote_first.patch
+++ b/target/linux/ar7/patches-3.18/160-vlynq_try_remote_first.patch
@@ -199,7 +199,7 @@
return 0;
}
-@@ -501,24 +547,16 @@ static int __vlynq_enable_device(struct
+@@ -501,24 +547,16 @@ static int __vlynq_enable_device(struct
return result;
switch (dev->divisor) {
@@ -229,7 +229,7 @@
break;
case vlynq_ldiv1:
case vlynq_ldiv2:
-@@ -528,15 +566,12 @@ static int __vlynq_enable_device(struct
+@@ -528,15 +566,12 @@ static int __vlynq_enable_device(struct
case vlynq_ldiv6:
case vlynq_ldiv7:
case vlynq_ldiv8:
@@ -251,7 +251,7 @@
return 0;
}
break;
-@@ -548,20 +583,17 @@ static int __vlynq_enable_device(struct
+@@ -548,20 +583,17 @@ static int __vlynq_enable_device(struct
case vlynq_rdiv6:
case vlynq_rdiv7:
case vlynq_rdiv8:
diff --git a/target/linux/ar7/patches-3.18/300-add-ac49x-platform.patch b/target/linux/ar7/patches-3.18/300-add-ac49x-platform.patch
index 92bd4f3b8c..ccdc84d309 100644
--- a/target/linux/ar7/patches-3.18/300-add-ac49x-platform.patch
+++ b/target/linux/ar7/patches-3.18/300-add-ac49x-platform.patch
@@ -37,7 +37,7 @@
#define AR7_IRQ_UART0 15
--- a/arch/mips/Kconfig
+++ b/arch/mips/Kconfig
-@@ -89,7 +89,7 @@ config AR7
+@@ -94,7 +94,7 @@ config AR7
select HAVE_CLK
help
Support for the Texas Instruments AR7 System-on-a-Chip
@@ -46,7 +46,7 @@
config ATH79
bool "Atheros AR71XX/AR724X/AR913X based boards"
-@@ -796,6 +796,7 @@ config NLM_XLP_BOARD
+@@ -835,6 +835,7 @@ config MIPS_PARAVIRT
endchoice
source "arch/mips/alchemy/Kconfig"
diff --git a/target/linux/ar7/patches-3.18/320-ac49x-mtd-partitions.patch b/target/linux/ar7/patches-3.18/320-ac49x-mtd-partitions.patch
index e6b08d669a..53ac07273a 100644
--- a/target/linux/ar7/patches-3.18/320-ac49x-mtd-partitions.patch
+++ b/target/linux/ar7/patches-3.18/320-ac49x-mtd-partitions.patch
@@ -1,6 +1,6 @@
--- a/drivers/mtd/Kconfig
+++ b/drivers/mtd/Kconfig
-@@ -169,6 +169,11 @@ config MTD_OF_PARTS
+@@ -164,6 +164,11 @@ config MTD_OF_PARTS
the partition map from the children of the flash node,
as described in Documentation/devicetree/booting-without-of.txt.
@@ -14,7 +14,7 @@
---help---
--- a/drivers/mtd/Makefile
+++ b/drivers/mtd/Makefile
-@@ -15,6 +15,7 @@ mtd-$(CONFIG_MTD_SPLIT_LZMA_FW) += mtdsp
+@@ -11,6 +11,7 @@ obj-$(CONFIG_MTD_SPLIT) += mtdsplit/
obj-$(CONFIG_MTD_OF_PARTS) += ofpart.o
obj-$(CONFIG_MTD_REDBOOT_PARTS) += redboot.o
obj-$(CONFIG_MTD_CMDLINE_PARTS) += cmdlinepart.o
diff --git a/target/linux/ar7/patches-3.18/500-serial_kludge.patch b/target/linux/ar7/patches-3.18/500-serial_kludge.patch
index e5d5a914a3..08bd6a6f2d 100644
--- a/target/linux/ar7/patches-3.18/500-serial_kludge.patch
+++ b/target/linux/ar7/patches-3.18/500-serial_kludge.patch
@@ -1,6 +1,6 @@
--- a/drivers/tty/serial/8250/8250_core.c
+++ b/drivers/tty/serial/8250/8250_core.c
-@@ -323,6 +323,13 @@ static const struct serial8250_config ua
+@@ -329,6 +329,13 @@ static const struct serial8250_config ua
.fcr = UART_FCR_ENABLE_FIFO | UART_FCR_R_TRIG_10,
.flags = UART_CAP_FIFO | UART_CAP_AFE,
},
@@ -14,9 +14,9 @@
};
/* Uart divisor latch read */
-@@ -2861,7 +2868,11 @@ static void serial8250_console_putchar(s
- struct uart_8250_port *up =
- container_of(port, struct uart_8250_port, port);
+@@ -3174,7 +3181,11 @@ static void serial8250_console_putchar(s
+ {
+ struct uart_8250_port *up = up_to_u8250p(port);
+#ifdef CONFIG_AR7
+ wait_for_xmitr(up, BOTH_EMPTY);
diff --git a/target/linux/ar7/patches-3.18/920-ar7part.patch b/target/linux/ar7/patches-3.18/920-ar7part.patch
index 84f68d82ab..9948858d05 100644
--- a/target/linux/ar7/patches-3.18/920-ar7part.patch
+++ b/target/linux/ar7/patches-3.18/920-ar7part.patch
@@ -33,7 +33,7 @@
size_t len;
unsigned int pre_size = master->erasesize, post_size = 0;
unsigned int root_offset = ROOT_OFFSET;
-@@ -55,6 +62,16 @@ static int create_mtd_partitions(struct
+@@ -55,6 +62,16 @@ static int create_mtd_partitions(struct
int retries = 10;
struct mtd_partition *ar7_parts;
@@ -50,7 +50,7 @@
ar7_parts = kzalloc(sizeof(*ar7_parts) * AR7_PARTS, GFP_KERNEL);
if (!ar7_parts)
return -ENOMEM;
-@@ -83,34 +100,39 @@ static int create_mtd_partitions(struct
+@@ -83,34 +100,39 @@ static int create_mtd_partitions(struct
pre_size = offset;
diff --git a/target/linux/ar7/patches-3.18/950-cpmac_titan.patch b/target/linux/ar7/patches-3.18/950-cpmac_titan.patch
index 1d76e9fd78..f1d432cc4c 100644
--- a/target/linux/ar7/patches-3.18/950-cpmac_titan.patch
+++ b/target/linux/ar7/patches-3.18/950-cpmac_titan.patch
@@ -1,7 +1,7 @@
--- a/drivers/net/ethernet/ti/cpmac.c
+++ b/drivers/net/ethernet/ti/cpmac.c
-@@ -1154,6 +1154,8 @@ static int cpmac_probe(struct platform_d
- goto fail;
+@@ -1146,6 +1146,8 @@ static int cpmac_probe(struct platform_d
+ goto out;
}
+ ar7_device_reset(pdata->reset_bit);
@@ -9,7 +9,7 @@
dev->irq = platform_get_irq_byname(pdev, "irq");
dev->netdev_ops = &cpmac_netdev_ops;
-@@ -1232,7 +1234,7 @@ int cpmac_init(void)
+@@ -1227,7 +1229,7 @@ int cpmac_init(void)
cpmac_mii->reset = cpmac_mdio_reset;
cpmac_mii->irq = mii_irqs;
@@ -17,8 +17,8 @@
+ cpmac_mii->priv = ioremap(ar7_is_titan() ? TITAN_REGS_MDIO : AR7_REGS_MDIO, 256);
if (!cpmac_mii->priv) {
- printk(KERN_ERR "Can't ioremap mdio registers\n");
-@@ -1243,10 +1245,16 @@ int cpmac_init(void)
+ pr_err("Can't ioremap mdio registers\n");
+@@ -1238,10 +1240,16 @@ int cpmac_init(void)
#warning FIXME: unhardcode gpio&reset bits
ar7_gpio_disable(26);
ar7_gpio_disable(27);
@@ -37,7 +37,7 @@
cpmac_mii->reset(cpmac_mii);
for (i = 0; i < 300; i++) {
-@@ -1263,7 +1271,11 @@ int cpmac_init(void)
+@@ -1258,7 +1266,11 @@ int cpmac_init(void)
mask = 0;
}