summaryrefslogtreecommitdiffstats
path: root/target/linux/ar7
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2008-11-24 21:52:10 +0000
committerFlorian Fainelli <florian@openwrt.org>2008-11-24 21:52:10 +0000
commita936c402fce86ae70d597e52bc0f7f1b1dd11306 (patch)
tree8785536b7a5c66ffe4f2b684a66669927b7ce747 /target/linux/ar7
parenta51533850785680198b3515dd28c0a581fdf3663 (diff)
downloadmaster-31e0f0ae-a936c402fce86ae70d597e52bc0f7f1b1dd11306.tar.gz
master-31e0f0ae-a936c402fce86ae70d597e52bc0f7f1b1dd11306.tar.bz2
master-31e0f0ae-a936c402fce86ae70d597e52bc0f7f1b1dd11306.zip
Fix this nasty patch which prevented others from applying
SVN-Revision: 13343
Diffstat (limited to 'target/linux/ar7')
-rw-r--r--target/linux/ar7/patches-2.6.26/110-flash.patch15
1 files changed, 2 insertions, 13 deletions
diff --git a/target/linux/ar7/patches-2.6.26/110-flash.patch b/target/linux/ar7/patches-2.6.26/110-flash.patch
index bda6e3727c..51b57f7986 100644
--- a/target/linux/ar7/patches-2.6.26/110-flash.patch
+++ b/target/linux/ar7/patches-2.6.26/110-flash.patch
@@ -13,25 +13,14 @@
comment "User Modules And Translation Layers"
config MTD_CHAR
---- a/drivers/mtd/Makefile
-+++ b/drivers/mtd/Makefile
-@@ -13,6 +13,7 @@ obj-$(CONFIG_MTD_CMDLINE_PARTS) += cmdli
- obj-$(CONFIG_MTD_AFS_PARTS) += afs.o
- obj-$(CONFIG_MTD_AR7_PARTS) += ar7part.o
- obj-$(CONFIG_MTD_OF_PARTS) += ofpart.o
-+obj-$(CONFIG_MTD_AR7_PARTS) += ar7part.o
-
- # 'Users' - code which presents functionality to userspace.
- obj-$(CONFIG_MTD_CHAR) += mtdchar.o
--- a/drivers/mtd/maps/physmap.c
+++ b/drivers/mtd/maps/physmap.c
-@@ -87,7 +87,8 @@ static int physmap_flash_remove(struct p
+@@ -87,7 +87,7 @@
static const char *rom_probe_types[] = { "cfi_probe", "jedec_probe", "map_rom", NULL };
#ifdef CONFIG_MTD_PARTITIONS
-static const char *part_probe_types[] = { "cmdlinepart", "RedBoot", NULL };
-+static const char *part_probe_types[] = {"cmdlinepart", "RedBoot",
-+ "ar7part", NULL };
++static const char *part_probe_types[] = { "cmdlinepart", "RedBoot", "ar7part", NULL };
#endif
static int physmap_flash_probe(struct platform_device *dev)