summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-07-13 13:50:03 +0200
committerFelix Fietkau <nbd@nbd.name>2016-07-13 13:59:24 +0200
commitd6b3b44d9798dfd6aba3758843acbf310b98a853 (patch)
tree4383d4d0894ac0e9865192a7bc1ecc76d486876c /target/linux/ar71xx
parent2ea76bdf04af4f2efefea6ca84e055086634e4be (diff)
downloadmaster-31e0f0ae-d6b3b44d9798dfd6aba3758843acbf310b98a853.tar.gz
master-31e0f0ae-d6b3b44d9798dfd6aba3758843acbf310b98a853.tar.bz2
master-31e0f0ae-d6b3b44d9798dfd6aba3758843acbf310b98a853.zip
ar71xx: fix a legacy image porting issue
Get rid of remaining IMAGE_PROFILE references and move template calls the right place Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'target/linux/ar71xx')
-rw-r--r--target/linux/ar71xx/image/Makefile2
-rw-r--r--target/linux/ar71xx/image/legacy.mk7
2 files changed, 1 insertions, 8 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index cf0c605076..a8c215b36d 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -10,8 +10,6 @@ JFFS2_BLOCKSIZE = 64k 128k 256k
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
-IMAGE_PROFILE:=$(if $(PROFILE),$(PROFILE),Default)
-
KERNEL_LOADADDR = 0x80060000
DEVICE_VARS += NETGEAR_KERNEL_MAGIC NETGEAR_BOARD_ID NETGEAR_HW_ID CMDLINE CONSOLE IMAGE_SIZE BOARDNAME LOADER_FLASH_OFFS LOADER_TYPE
diff --git a/target/linux/ar71xx/image/legacy.mk b/target/linux/ar71xx/image/legacy.mk
index 00c62e25fe..680dece15b 100644
--- a/target/linux/ar71xx/image/legacy.mk
+++ b/target/linux/ar71xx/image/legacy.mk
@@ -322,7 +322,6 @@ define Image/BuildKernel
$(call MkuImage,lzma,,$(KDIR)/vmlinux.bin.lzma,$(UIMAGE)-lzma.bin)
cp $(KDIR)/loader-generic.elf $(VMLINUX)-lzma.elf
-mkdir -p $(KDIR_TMP)
- $(call Image/Build/Profile/$(IMAGE_PROFILE),buildkernel)
endef
define Image/BuildKernel/Initramfs
@@ -1140,10 +1139,6 @@ define Image/Build/jffs2
dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/$(IMG_PREFIX)-root.$(1) bs=128k conv=sync
endef
-define Image/Build/Initramfs
- $(call Image/Build/Profile/$(IMAGE_PROFILE),initramfs)
-endef
-
define Image/Prepare
gzip -9n -c $(KDIR)/vmlinux > $(KDIR)/vmlinux.bin.gz
$(call CompressLzma,$(KDIR)/vmlinux,$(KDIR)/vmlinux.bin.lzma)
@@ -1153,7 +1148,6 @@ ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),)
$(call Image/BuildLoader,generic,elf,,,-initramfs)
endif
$(call Image/BuildLoader,generic,elf)
- $(call Image/Build/Profile/$(if $(CONFIG_IB),Default,$(IMAGE_PROFILE)),loader)
endef
define Image/Prepare/Profile
@@ -1162,6 +1156,7 @@ endef
define Image/Build/Profile
$(call Image/Build/Profile/$(1),buildkernel)
+ $(call Image/Build/Profile/$(1),initramfs)
$(call Image/Build/Profile/$(1),$(2))
endef