summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx
diff options
context:
space:
mode:
authorMathias Kresin <dev@kresin.me>2016-09-13 19:23:52 +0200
committerMathias Kresin <dev@kresin.me>2016-09-13 19:36:41 +0200
commit1cd0a4c688f02918cb96ff7f5f21cddc281d4f2c (patch)
tree3a344d44aeb50972f9399f8414e9d60cfff93920 /target/linux/ar71xx
parentb964196c68d6727d14bfae868ff428d240e011c9 (diff)
downloadmaster-31e0f0ae-1cd0a4c688f02918cb96ff7f5f21cddc281d4f2c.tar.gz
master-31e0f0ae-1cd0a4c688f02918cb96ff7f5f21cddc281d4f2c.tar.bz2
master-31e0f0ae-1cd0a4c688f02918cb96ff7f5f21cddc281d4f2c.zip
image: add KERNEL_SIZE to the default device vars
This reverts commit ec37a565878fd79d4127cbb843c17ce3b8dc97c0 and fixes the underlying issue.
Diffstat (limited to 'target/linux/ar71xx')
-rw-r--r--target/linux/ar71xx/image/generic.mk4
-rw-r--r--target/linux/ar71xx/image/ubnt.mk2
2 files changed, 3 insertions, 3 deletions
diff --git a/target/linux/ar71xx/image/generic.mk b/target/linux/ar71xx/image/generic.mk
index 10717cb7fa..bd92a8413d 100644
--- a/target/linux/ar71xx/image/generic.mk
+++ b/target/linux/ar71xx/image/generic.mk
@@ -410,7 +410,7 @@ define Device/NBG6616
CMDLINE += mem=128M
IMAGES := sysupgrade.bin
KERNEL := kernel-bin | patch-cmdline | lzma | uImage lzma | jffs2 boot/vmlinux.lzma.uImage
- IMAGE/sysupgrade.bin = append-kernel $$(KERNEL_SIZE) | append-rootfs | pad-rootfs | check-size $$$$(IMAGE_SIZE)
+ IMAGE/sysupgrade.bin = append-kernel $$$$(KERNEL_SIZE) | append-rootfs | pad-rootfs | check-size $$$$(IMAGE_SIZE)
# We cannot currently build a factory image. It is the sysupgrade image
# prefixed with a header (which is actually written into the MTD device).
# The header is 2kiB and is filled with 0xff. The format seems to be:
@@ -443,7 +443,7 @@ define Device/c-55
KERNEL_SIZE = 2048k
IMAGE_SIZE = 15872k
MTDPARTS = spi0.0:256k(u-boot)ro,128k(u-boot-env)ro,2048k(kernel),13824k(rootfs),13824k(opt)ro,2624k(failsafe)ro,64k(art)ro,15872k@0x60000(firmware)
- IMAGE/sysupgrade.bin = append-kernel $$(KERNEL_SIZE) | append-rootfs | pad-rootfs | check-size $$$$(IMAGE_SIZE)
+ IMAGE/sysupgrade.bin = append-kernel $$$$(KERNEL_SIZE) | append-rootfs | pad-rootfs | check-size $$$$(IMAGE_SIZE)
endef
TARGET_DEVICES += c-55
diff --git a/target/linux/ar71xx/image/ubnt.mk b/target/linux/ar71xx/image/ubnt.mk
index 99496f72a1..98c9ca0066 100644
--- a/target/linux/ar71xx/image/ubnt.mk
+++ b/target/linux/ar71xx/image/ubnt.mk
@@ -261,7 +261,7 @@ define Device/ubnt-uap-pro
DEVICE_PROFILE := UBNT UAPPRO
KERNEL := kernel-bin | patch-cmdline | lzma | uImage lzma | jffs2 kernel0
IMAGES := sysupgrade.bin factory.bin
- IMAGE/sysupgrade.bin = append-kernel $$(KERNEL_SIZE) | append-rootfs | pad-rootfs | check-size $$$$(IMAGE_SIZE)
+ IMAGE/sysupgrade.bin = append-kernel $$$$(KERNEL_SIZE) | append-rootfs | pad-rootfs | check-size $$$$(IMAGE_SIZE)
IMAGE/factory.bin = $$(IMAGE/sysupgrade.bin) | mkubntimage2
endef