summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2014-07-14 10:25:53 +0000
committerGabor Juhos <juhosg@openwrt.org>2014-07-14 10:25:53 +0000
commitfec25962824da27c3f02021bbd4db969639b8717 (patch)
tree8e824db4712019a14450b841638c4bb0697940ee /target/linux/ar71xx
parent50c554a475ac1bfbd6b310cf97e914c8b767f5a6 (diff)
downloadmaster-31e0f0ae-fec25962824da27c3f02021bbd4db969639b8717.tar.gz
master-31e0f0ae-fec25962824da27c3f02021bbd4db969639b8717.tar.bz2
master-31e0f0ae-fec25962824da27c3f02021bbd4db969639b8717.zip
ar71xx: add profile and build image for the EnGenius ESR900
Signed-off-by: Forest Crossman <cyrozap@gmail.com> Patchwork: http://patchwork.openwrt.org/patch/5715/ [juhosg: change subject] Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 41642
Diffstat (limited to 'target/linux/ar71xx')
-rw-r--r--target/linux/ar71xx/generic/profiles/engenius.mk13
-rw-r--r--target/linux/ar71xx/image/Makefile1
2 files changed, 14 insertions, 0 deletions
diff --git a/target/linux/ar71xx/generic/profiles/engenius.mk b/target/linux/ar71xx/generic/profiles/engenius.mk
index e59428cc8f..093dfa47e9 100644
--- a/target/linux/ar71xx/generic/profiles/engenius.mk
+++ b/target/linux/ar71xx/generic/profiles/engenius.mk
@@ -4,6 +4,19 @@
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
+
+define Profile/ESR900
+ NAME:=EnGenius ESR900
+ PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
+endef
+
+define Profile/ESR900/Description
+ Package set optimized for the EnGenius ESR900
+endef
+
+$(eval $(call Profile,ESR900))
+
+
define Profile/ESR1750
NAME:=EnGenius ESR1750
PACKAGES:=kmod-usb-core kmod-usb2 kmod-usb-storage kmod-ath10k wpad-mini
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index b82001fa7f..ab83f4f2be 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -264,6 +264,7 @@ cap4200ag_mtdlayout=mtdparts=spi0.0:256k(u-boot),64k(u-boot-env),320k(custom)ro,
db120_mtdlayout=mtdparts=spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,6336k(rootfs),1408k(kernel),64k(nvram),64k(art)ro,7744k@0x50000(firmware)
cameo_ap94_mtdlayout=mtdparts=spi0.0:256k(uboot)ro,64k(config)ro,6208k(firmware),64k(caldata)ro,1600k(unknown)ro,64k@0x7f0000(caldata_copy)
cameo_ap94_mtdlayout_fat=mtdparts=spi0.0:256k(uboot)ro,64k(config)ro,7808k(firmware),64k(caldata)ro,64k@0x660000(caldata_orig),6208k@0x50000(firmware_orig)
+esr900_mtdlayout=mtdparts=spi0.0:192k(u-boot)ro,64k(u-boot-env)ro,14656k(firmware),1024k(manufacture)ro,64k(backup)ro,320k(storage)ro,64k(caldata)ro
esr1750_mtdlayout=mtdparts=spi0.0:192k(u-boot)ro,64k(u-boot-env)ro,1408k(kernel),13248k(rootfs),1024k(manufacture)ro,64k(backup)ro,320k(storage)ro,64k(caldata)ro,14656k@0x40000(firmware)
ew-dorin_mtdlayout_4M=mtdparts=spi0.0:256k(u-boot)ro,64k(u-boot-env),3712k(firmware),64k(art)
ew-dorin_mtdlayout_16M=mtdparts=spi0.0:256k(u-boot)ro,64k(u-boot-env),16000k(firmware),64k(art)