summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2009-04-26 05:29:18 +0000
committerGabor Juhos <juhosg@openwrt.org>2009-04-26 05:29:18 +0000
commitf83c011d776b3b582af201c5a53240c6165da8cc (patch)
treea9a7bb7bcbc3d5f18467a018ddc5aa17c6cf846b /target/linux/ar71xx
parentd56fcbd853f7ac82712c4d0e2a670fd82f39da4f (diff)
downloadmaster-31e0f0ae-f83c011d776b3b582af201c5a53240c6165da8cc.tar.gz
master-31e0f0ae-f83c011d776b3b582af201c5a53240c6165da8cc.tar.bz2
master-31e0f0ae-f83c011d776b3b582af201c5a53240c6165da8cc.zip
refresh 2.6.28 patches
SVN-Revision: 15419
Diffstat (limited to 'target/linux/ar71xx')
-rw-r--r--target/linux/ar71xx/patches-2.6.28/003-ar71xx_usb_host.patch6
-rw-r--r--target/linux/ar71xx/patches-2.6.28/101-ksz8041_phy_driver.patch10
2 files changed, 9 insertions, 7 deletions
diff --git a/target/linux/ar71xx/patches-2.6.28/003-ar71xx_usb_host.patch b/target/linux/ar71xx/patches-2.6.28/003-ar71xx_usb_host.patch
index 43bd4a152b..53f811bc99 100644
--- a/target/linux/ar71xx/patches-2.6.28/003-ar71xx_usb_host.patch
+++ b/target/linux/ar71xx/patches-2.6.28/003-ar71xx_usb_host.patch
@@ -1,25 +1,27 @@
--- a/drivers/usb/host/Kconfig
+++ b/drivers/usb/host/Kconfig
-@@ -81,6 +81,12 @@ config USB_EHCI_BIG_ENDIAN_DESC
+@@ -81,6 +81,13 @@ config USB_EHCI_BIG_ENDIAN_DESC
depends on USB_EHCI_HCD && (440EPX || ARCH_IXP4XX)
default y
+config USB_EHCI_AR71XX
+ bool "USB EHCI support for AR71xx"
+ depends on USB_EHCI_HCD && ATHEROS_AR71XX
++ default y
+ help
+ Support for Atheros AR71xx built-in EHCI controller
+
config USB_EHCI_FSL
bool "Support for Freescale on-chip EHCI USB controller"
depends on USB_EHCI_HCD && FSL_SOC
-@@ -140,6 +146,12 @@ config USB_OHCI_HCD
+@@ -140,6 +147,13 @@ config USB_OHCI_HCD
To compile this driver as a module, choose M here: the
module will be called ohci-hcd.
+config USB_OHCI_AR71XX
+ bool "USB OHCI support for Atheros AR71xx"
+ depends on USB_OHCI_HCD && ATHEROS_AR71XX
++ default y
+ help
+ Support for Atheros AR71xx built-in OHCI controller
+
diff --git a/target/linux/ar71xx/patches-2.6.28/101-ksz8041_phy_driver.patch b/target/linux/ar71xx/patches-2.6.28/101-ksz8041_phy_driver.patch
index 1170b0c839..541ae0af3d 100644
--- a/target/linux/ar71xx/patches-2.6.28/101-ksz8041_phy_driver.patch
+++ b/target/linux/ar71xx/patches-2.6.28/101-ksz8041_phy_driver.patch
@@ -1,8 +1,8 @@
--- a/drivers/net/phy/Kconfig
+++ b/drivers/net/phy/Kconfig
-@@ -80,6 +80,11 @@ config ADM6996_PHY
- config MVSWITCH_PHY
- tristate "Driver for Marvell 88E6060 switches"
+@@ -84,6 +84,11 @@ config IP175C_PHY
+ tristate "Driver for IC+ IP175C/IP178C switches"
+ select SWCONFIG
+config MICREL_PHY
+ tristate "Drivers for Micrel/Kendin PHYs"
@@ -14,9 +14,9 @@
depends on PHYLIB=y
--- a/drivers/net/phy/Makefile
+++ b/drivers/net/phy/Makefile
-@@ -16,6 +16,7 @@ obj-$(CONFIG_ICPLUS_PHY) += icplus.o
- obj-$(CONFIG_ADM6996_PHY) += adm6996.o
+@@ -17,6 +17,7 @@ obj-$(CONFIG_ADM6996_PHY) += adm6996.o
obj-$(CONFIG_MVSWITCH_PHY) += mvswitch.o
+ obj-$(CONFIG_IP175C_PHY) += ip175c.o
obj-$(CONFIG_REALTEK_PHY) += realtek.o
+obj-$(CONFIG_MICREL_PHY) += micrel.o
obj-$(CONFIG_FIXED_PHY) += fixed.o