summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2014-02-23 10:59:40 +0000
committerGabor Juhos <juhosg@openwrt.org>2014-02-23 10:59:40 +0000
commitf677b1bc7e37642eb1c42d3068ff3c44eb5ed3cb (patch)
treea4971798ff33bb5e653297f14906628b84407790 /target/linux/ar71xx
parent6c8300df3d593abd911a3d6bb1a95eee4cfd06f8 (diff)
downloadmaster-31e0f0ae-f677b1bc7e37642eb1c42d3068ff3c44eb5ed3cb.tar.gz
master-31e0f0ae-f677b1bc7e37642eb1c42d3068ff3c44eb5ed3cb.tar.bz2
master-31e0f0ae-f677b1bc7e37642eb1c42d3068ff3c44eb5ed3cb.zip
kernel: update 3.10 to 3.10.32
Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 39707
Diffstat (limited to 'target/linux/ar71xx')
-rw-r--r--target/linux/ar71xx/Makefile2
-rw-r--r--target/linux/ar71xx/patches-3.10/310-lib-add-rle-decompression.patch2
-rw-r--r--target/linux/ar71xx/patches-3.10/490-usb-ehci-add-quirks-for-qca-socs.patch4
3 files changed, 4 insertions, 4 deletions
diff --git a/target/linux/ar71xx/Makefile b/target/linux/ar71xx/Makefile
index a7ee05f36d..d8a484e00a 100644
--- a/target/linux/ar71xx/Makefile
+++ b/target/linux/ar71xx/Makefile
@@ -13,7 +13,7 @@ FEATURES:=mips16
CPU_TYPE=34kc
SUBTARGETS:=generic nand mikrotik
-LINUX_VERSION:=3.10.28
+LINUX_VERSION:=3.10.32
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/ar71xx/patches-3.10/310-lib-add-rle-decompression.patch b/target/linux/ar71xx/patches-3.10/310-lib-add-rle-decompression.patch
index ebf486ec9f..46cdacdfde 100644
--- a/target/linux/ar71xx/patches-3.10/310-lib-add-rle-decompression.patch
+++ b/target/linux/ar71xx/patches-3.10/310-lib-add-rle-decompression.patch
@@ -12,7 +12,7 @@
# ZLIB_INFLATE; DECOMPRESS_GZIP is just a wrapper.)
--- a/lib/Makefile
+++ b/lib/Makefile
-@@ -89,6 +89,7 @@ obj-$(CONFIG_XZ_DEC) += xz/
+@@ -90,6 +90,7 @@ obj-$(CONFIG_XZ_DEC) += xz/
obj-$(CONFIG_RAID6_PQ) += raid6/
obj-$(CONFIG_LZMA_COMPRESS) += lzma/
obj-$(CONFIG_LZMA_DECOMPRESS) += lzma/
diff --git a/target/linux/ar71xx/patches-3.10/490-usb-ehci-add-quirks-for-qca-socs.patch b/target/linux/ar71xx/patches-3.10/490-usb-ehci-add-quirks-for-qca-socs.patch
index d22528bbbf..fcbf51b16f 100644
--- a/target/linux/ar71xx/patches-3.10/490-usb-ehci-add-quirks-for-qca-socs.patch
+++ b/target/linux/ar71xx/patches-3.10/490-usb-ehci-add-quirks-for-qca-socs.patch
@@ -40,9 +40,9 @@
retval = handshake (ehci, &ehci->regs->command,
--- a/drivers/usb/host/ehci.h
+++ b/drivers/usb/host/ehci.h
-@@ -201,6 +201,10 @@ struct ehci_hcd { /* one per controlle
- unsigned frame_index_bug:1; /* MosChip (AKA NetMos) */
+@@ -202,6 +202,10 @@ struct ehci_hcd { /* one per controlle
unsigned need_oc_pp_cycle:1; /* MPC834X port power */
+ unsigned imx28_write_fix:1; /* For Freescale i.MX28 */
unsigned ignore_oc:1;
+ unsigned qca_force_host_mode:1;
+ unsigned qca_force_16bit_ptw:1; /* force 16 bit UTMI */