summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-09-22 20:14:23 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-09-22 20:14:23 +0000
commitdd171f7d140f352264402fee2d8968a92ea05fca (patch)
tree0e76dbc55c62b6024b374621c33f7a2d934e356f /target/linux/ar71xx
parentd3c75d79cd7fef96ed943fdd2ddf9ffafec7b011 (diff)
downloadmaster-31e0f0ae-dd171f7d140f352264402fee2d8968a92ea05fca.tar.gz
master-31e0f0ae-dd171f7d140f352264402fee2d8968a92ea05fca.tar.bz2
master-31e0f0ae-dd171f7d140f352264402fee2d8968a92ea05fca.zip
ar71xx: image: add optional JFFS2 padding support to the CatFiles macro
Also remove the similar code from the Netgear profile and use the new feature instead. Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 38126
Diffstat (limited to 'target/linux/ar71xx')
-rw-r--r--target/linux/ar71xx/image/Makefile16
1 files changed, 9 insertions, 7 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 65ddabec15..a837f9a71c 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -114,6 +114,13 @@ define CatFiles
*) bs=`stat -c%s $(1)`;; \
esac; \
( dd if=$(1) bs=$$$${bs} conv=sync; cat $(3) ) > $(5); \
+ if [ -n "$(6)" ]; then \
+ case "$$$${fstype}" in \
+ squashfs*) \
+ padjffs2 $(5) $(6); \
+ ;; \
+ esac; \
+ fi; \
if [ `stat -c%s $(5)` -gt $(4) ]; then \
echo "Warning: $(5) is too big (> $(4) bytes)" >&2; \
rm -f $(5); \
@@ -128,7 +135,7 @@ define CatFiles
endef
Sysupgrade/KR=$(call CatFiles,$(2),$(3),$(KDIR)/root.$(1),$(4),$(call sysupname,$(1),$(5)))
-Sysupgrade/KRuImage=$(call CatFiles,$(KDIR_TMP)/vmlinux-$(2).uImage,$(3),$(KDIR)/root.$(1),$(4),$(call sysupname,$(1),$(2)))
+Sysupgrade/KRuImage=$(call CatFiles,$(KDIR_TMP)/vmlinux-$(2).uImage,$(3),$(KDIR)/root.$(1),$(4),$(call sysupname,$(1),$(2)),$(5))
Sysupgrade/RKuImage=$(call CatFiles,$(KDIR)/root.$(1),$(4),$(KDIR_TMP)/vmlinux-$(2).uImage,$(3),$(call sysupname,$(1),$(2)))
define Image/BuildLoader
@@ -714,13 +721,8 @@ endef
define Image/Build/Netgear
$(eval fwsize=$(call mtdpartsize,firmware,$(4)))
- $(call CatFiles,$(KDIR_TMP)/vmlinux-$(2).uImage.squashfs,0,$(KDIR)/root.$(1),$(fwsize),$(call sysupname,$(1),$(2)))
+ $(call CatFiles,$(KDIR_TMP)/vmlinux-$(2).uImage.squashfs,0,$(KDIR)/root.$(1),$(fwsize),$(call sysupname,$(1),$(2)),64)
if [ -e $(call sysupname,$(1),$(2)) ]; then \
- case "$(1)" in \
- *squashfs*) \
- padjffs2 $(call sysupname,$(1),$(2)) 64; \
- ;; \
- esac; \
for r in $(7) ; do \
[ -n "$$$$r" ] && dashr="-$$$$r" || dashr= ; \
$(STAGING_DIR_HOST)/bin/mkdniimg \