summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2014-01-18 19:44:40 +0000
committerImre Kaloz <kaloz@openwrt.org>2014-01-18 19:44:40 +0000
commitb6e1cbd8dd5b8fe3833547480abdbd57edb3238c (patch)
tree37dce64f91238036115d960b154508369038a0c3 /target/linux/ar71xx
parent471095f869b0e7b0485c5c98c34a047b8f8fcc38 (diff)
downloadmaster-31e0f0ae-b6e1cbd8dd5b8fe3833547480abdbd57edb3238c.tar.gz
master-31e0f0ae-b6e1cbd8dd5b8fe3833547480abdbd57edb3238c.tar.bz2
master-31e0f0ae-b6e1cbd8dd5b8fe3833547480abdbd57edb3238c.zip
generate images for the On Networks N150 (rebranded Netgear WNR612v2)
Signed-off-by: Imre Kaloz <kaloz@openwrt.org> SVN-Revision: 39320
Diffstat (limited to 'target/linux/ar71xx')
-rw-r--r--target/linux/ar71xx/generic/profiles/netgear.mk4
-rw-r--r--target/linux/ar71xx/image/Makefile4
2 files changed, 5 insertions, 3 deletions
diff --git a/target/linux/ar71xx/generic/profiles/netgear.mk b/target/linux/ar71xx/generic/profiles/netgear.mk
index 597c7aa3df..78717a0a83 100644
--- a/target/linux/ar71xx/generic/profiles/netgear.mk
+++ b/target/linux/ar71xx/generic/profiles/netgear.mk
@@ -40,11 +40,11 @@ $(eval $(call Profile,WNR2000V3))
define Profile/WNR612V2
- NAME:=NETGEAR WNR612V2
+ NAME:=NETGEAR WNR612V2 / On Networks N150
endef
define Profile/WNR612V2/Description
- Package set optimized for the NETGEAR WNR612V2
+ Package set optimized for the NETGEAR WNR612V2 / On Networks N150
endef
$(eval $(call Profile,WNR612V2))
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 412caddb7c..9be9bd025f 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -933,7 +933,8 @@ $(eval $(call SingleProfile,AthGzip,64k,WNDAP360,wndap360,WNDAP360,ttyS0,9600,$$
$(eval $(call SingleProfile,Netgear,64kraw,WNR2000V3,wnr2000v3,WNR2000V3,ttyS0,115200,$$(wnr2000v3_mtdlayout),0x32303033,WNR2000V3,"" NA,))
$(eval $(call SingleProfile,Netgear,64kraw,WNR2200,wnr2200,WNR2200,ttyS0,115200,$$(wnr2200_mtdlayout),0x32323030,WNR2200,"" NA,))
-$(eval $(call SingleProfile,Netgear,64kraw,WNR612V2,wnr612v2,WNR612V2,ttyS0,115200,$$(wnr2000v3_mtdlayout),0x32303631,WNR612V2,"",))
+$(eval $(call SingleProfile,Netgear,64kraw,REALWNR612V2,wnr612v2,WNR612V2,ttyS0,115200,$$(wnr2000v3_mtdlayout),0x32303631,WNR612V2,"",))
+$(eval $(call SingleProfile,Netgear,64kraw,N150R,n150r,WNR612V2,ttyS0,115200,$$(wnr2000v3_mtdlayout),0x32303631,N150R,"",))
$(eval $(call SingleProfile,Netgear,64kraw,WNDR3700V1,wndr3700,WNDR3700,ttyS0,115200,$$(wndr3700_mtdlayout),0x33373030,WNDR3700,"" NA,,7 864 320))
$(eval $(call SingleProfile,Netgear,64kraw,WNDR3700V2,wndr3700v2,WNDR3700,ttyS0,115200,$$(wndr3700v2_mtdlayout),0x33373031,WNDR3700v2,"",-H 29763654+16+64))
$(eval $(call SingleProfile,Netgear,64kraw,WNDR3800,wndr3800,WNDR3700,ttyS0,115200,$$(wndr3700v2_mtdlayout),0x33373031,WNDR3800,"",-H 29763654+16+128))
@@ -1072,6 +1073,7 @@ $(eval $(call MultiProfile,TLWR1043,TLWR1043V1 TLWR1043V2))
$(eval $(call MultiProfile,TLWDR4300,TLWDR3500V1 TLWDR3600V1 TLWDR4300V1 TLWDR4310V1 MW4530RV1))
$(eval $(call MultiProfile,UBNT,UBNTAIRROUTER UBNTRS UBNTRSPRO UBNTLSSR71 UBNTBULLETM UBNTROCKETM UBNTNANOM UBNTUNIFI UBNTUNIFIOUTDOOR UAPPRO))
$(eval $(call MultiProfile,WNDR3700,WNDR3700V1 WNDR3700V2 WNDR3800 WNDRMAC WNDRMACV2))
+$(eval $(call MultiProfile,WNR612V2,REALWNR612V2 N150R))
$(eval $(call MultiProfile,WP543,WP543_2M WP543_4M WP543_8M WP543_16M))
$(eval $(call MultiProfile,WPE72,WPE72_4M WPE72_8M WPE72_16M))