summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2014-04-12 20:00:37 +0000
committerGabor Juhos <juhosg@openwrt.org>2014-04-12 20:00:37 +0000
commita67578ce33504e32f9b0c302d885ec0e3fc17b19 (patch)
tree4c6f286ed65f16a83401d912aa33b0bf282b67fb /target/linux/ar71xx
parent4149ab5193d09ffdbaaaeb3c9f041ba212efb31c (diff)
downloadmaster-31e0f0ae-a67578ce33504e32f9b0c302d885ec0e3fc17b19.tar.gz
master-31e0f0ae-a67578ce33504e32f9b0c302d885ec0e3fc17b19.tar.bz2
master-31e0f0ae-a67578ce33504e32f9b0c302d885ec0e3fc17b19.zip
ar71xx/image: allow to use more arguments for some macros
Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 40480
Diffstat (limited to 'target/linux/ar71xx')
-rw-r--r--target/linux/ar71xx/image/Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index c21c470755..5d2b6700f2 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -49,11 +49,11 @@ SINGLE_PROFILES:=
# $(4) : board name.
# $(5)~$(7) : arguments for $(mkcmdline)
# board=$(1) console=$(2),$(3)
-# $(8)~$(12): extra arguments.
+# $(8)~$(14): extra arguments.
define SingleProfile
# $(1): action name, e.g. loader, buildkernel, squashfs, etc.
define Image/Build/Profile/$(3)
- $$(call Image/Build/Template/$(2)/$$(1),$(1),$(4),$$(call mkcmdline,$(5),$(6),$(7)),$(8),$(9),$(10),$(11),$(12))
+ $$(call Image/Build/Template/$(2)/$$(1),$(1),$(4),$$(call mkcmdline,$(5),$(6),$(7)),$(8),$(9),$(10),$(11),$(12),$(13),$(14))
endef
SINGLE_PROFILES += $(3)
endef
@@ -913,7 +913,7 @@ endef
define Jffs2Template
define Image/Build/Template/$(1)/jffs2-$(2)
- $$(call Image/Build/$$(1),jffs2-$(2),$$(2),$$(3),$$(4),$$(5),$$(6),$$(7),$$(8))
+ $$(call Image/Build/$$(1),jffs2-$(2),$$(2),$$(3),$$(4),$$(5),$$(6),$$(7),$$(8),$$(9),$$(10))
endef
endef
@@ -926,16 +926,16 @@ define BuildTemplate
# $(3) : kernel command line.
# $(4)~$(8): extra arguments.
define Image/Build/Template/$(1)/initramfs
- $$(call Image/Build/$$(1)/initramfs,initramfs,$$(2),$$(3),$$(4),$$(5),$$(6),$$(7),$$(8))
+ $$(call Image/Build/$$(1)/initramfs,initramfs,$$(2),$$(3),$$(4),$$(5),$$(6),$$(7),$$(8),$$(9),$$(10))
endef
define Image/Build/Template/$(1)/loader
- $$(call Image/Build/$$(1)/loader,$$(2),$$(3),$$(4),$$(5),$$(6),$$(7),$$(8))
+ $$(call Image/Build/$$(1)/loader,$$(2),$$(3),$$(4),$$(5),$$(6),$$(7),$$(8),$$(9),$$(10))
endef
define Image/Build/Template/$(1)/buildkernel
- $$(call Image/Build/$$(1)/buildkernel,,$$(2),$$(3),$$(4),$$(5),$$(6),$$(7),$$(8))
+ $$(call Image/Build/$$(1)/buildkernel,,$$(2),$$(3),$$(4),$$(5),$$(6),$$(7),$$(8),$$(9),$$(10))
endef
define Image/Build/Template/$(1)/squashfs
- $$(call Image/Build/$$(1),squashfs$(2),$$(2),$$(3),$$(4),$$(5),$$(6),$$(7),$$(8))
+ $$(call Image/Build/$$(1),squashfs$(2),$$(2),$$(3),$$(4),$$(5),$$(6),$$(7),$$(8),$$(9),$$(10))
endef
$(if $(3),$(foreach bs,$(3),$(eval $(call Jffs2Template,$(1),$(bs)))))
endef