summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-06-15 07:46:05 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-06-15 07:46:05 +0000
commit9e2ec0a55c0918e93625086670f7f51c4d635579 (patch)
tree3d348ed95f2987e50be4711a75493cefa98d4115 /target/linux/ar71xx
parentb5798e07a587a3c3ed769c8dc1755a7e973f8a99 (diff)
downloadmaster-31e0f0ae-9e2ec0a55c0918e93625086670f7f51c4d635579.tar.gz
master-31e0f0ae-9e2ec0a55c0918e93625086670f7f51c4d635579.tar.bz2
master-31e0f0ae-9e2ec0a55c0918e93625086670f7f51c4d635579.zip
ar71xx/image: move ubnt images to new BuildCode
Signed-off-by: Alexander Couzens <lynxis@fe80.eu> SVN-Revision: 45983
Diffstat (limited to 'target/linux/ar71xx')
-rw-r--r--target/linux/ar71xx/image/Makefile264
1 files changed, 175 insertions, 89 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 6662672d2d..21d0d66bff 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -671,6 +671,180 @@ define Device/oolite
endef
TARGET_DEVICES += oolite
+# UBNT_BOARD e.g. one of (XS2, XS5, RS, XM)
+# UBNT_TYPE e.g. one of (BZ, XM, XW)
+# UBNT_CHIP e.g. one of (ar7240, ar933x, ar934x)
+define Device/ubnt-xm
+ DEVICE_PROFILE := UBNT
+ IMAGE_SIZE := 7552k
+ MTDPARTS = spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,7552k(firmware),256k(cfg)ro,64k(EEPROM)ro
+ UBNT_TYPE := XM
+ UBNT_BOARD := XM
+ UBNT_CHIP := ar7240
+ IMAGES := sysupgrade.bin factory.bin
+ IMAGE/factory.bin = $$(IMAGE/sysupgrade.bin) | mkubntimage-split
+ IMAGE/sysupgrade.bin = append-kernel $$$$(BLOCKSIZE) | append-rootfs | pad-rootfs | check-size $$$$(IMAGE_SIZE)
+endef
+
+define Device/ubnt-xw
+ DEVICE_PROFILE := UBNT
+ IMAGE_SIZE := 7552k
+ MTDPARTS = spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,7552k(firmware),256k(cfg)ro,64k(EEPROM)ro
+ UBNT_TYPE := XW
+ UBNT_BOARD := XM
+ UBNT_CHIP := ar934x
+ IMAGES := sysupgrade.bin factory.bin
+ IMAGE/factory.bin = $$(IMAGE/sysupgrade.bin) | mkubntimage-split
+ IMAGE/sysupgrade.bin = append-kernel $$$$(BLOCKSIZE) | append-rootfs | pad-rootfs | check-size $$$$(IMAGE_SIZE)
+endef
+
+define Device/ubnt-bz
+ DEVICE_PROFILE := UBNT
+ IMAGE_SIZE := 7552k
+ MTDPARTS = spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,7552k(firmware),256k(cfg)ro,64k(EEPROM)ro
+ UBNT_TYPE := BZ
+ UBNT_BOARD := XM
+ UBNT_CHIP := ar934x
+ IMAGES := sysupgrade.bin factory.bin
+ IMAGE/factory.bin = $$(IMAGE/sysupgrade.bin) | mkubntimage-split
+ IMAGE/sysupgrade.bin = append-kernel $$$$(BLOCKSIZE) | append-rootfs | pad-rootfs | check-size $$$$(IMAGE_SIZE)
+endef
+
+define Device/rw2458n
+ $(Device/ubnt-xm)
+ BOARDNAME := RW2458N
+endef
+
+define Device/ubnt-airrouter
+ $(Device/ubnt-xm)
+ BOARDNAME := UBNT-AR
+endef
+
+define Device/ubnt-bullet-m
+ $(Device/ubnt-xm)
+ BOARDNAME := UBNT-BM
+endef
+
+define Device/ubnt-rocket-m
+ $(Device/ubnt-xm)
+ BOARDNAME := UBNT-RM
+endef
+
+define Device/ubnt-nano-m
+ $(Device/ubnt-xm)
+ BOARDNAME := UBNT-NM
+endef
+TARGET_DEVICES += rw2458n ubnt-airrouter ubnt-bullet-m ubnt-rocket-m ubnt-nano-m
+
+define Device/ubnt-unifi
+ $(Device/ubnt-bz)
+ BOARDNAME := UBNT-UF
+ DEVICE_PROFILE := UBNT UBNTUNIFI
+endef
+
+define Device/ubnt-unifi-outdoor
+ $(Device/ubnt-bz)
+ BOARDNAME := UBNT-U20
+ DEVICE_PROFILE := UBNT UBNTUNIFIOUTDOOR
+endef
+TARGET_DEVICES += ubnt-unifi ubnt-unifi-outdoor
+
+define Device/ubnt-nano-m-xw
+ $(Device/ubnt-xw)
+ BOARDNAME := UBNT-NM-XW
+endef
+
+define Device/ubnt-loco-m-xw
+ $(Device/ubnt-xw)
+ BOARDNAME := UBNT-LOCO-XW
+endef
+
+define Device/ubnt-rocket-m-xw
+ $(Device/ubnt-xw)
+ BOARDNAME := UBNT-RM-XW
+endef
+TARGET_DEVICES += ubnt-nano-m-xw ubnt-loco-m-xw ubnt-rocket-m-xw
+
+define Device/ubnt-air-gateway
+ $(Device/ubnt-xm)
+ BOARDNAME := UBNT-AGW
+ UBNT_BOARD := XM
+ UBNT_TYPE := AirGW
+ UBNT_CHIP := ar933x
+ CONSOLE = ttyATH0,115200
+endef
+TARGET_DEVICES += ubnt-air-gateway
+
+define Device/ubdev01
+ $(Device/ubnt-xm)
+ MTDPARTS := spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,7488k(firmware),64k(certs),256k(cfg)ro,64k(EEPROM)ro
+ BOARDNAME := UBNT-UF
+ UBNT_BOARD := XM
+ UBNT_TYPE := XM
+ UBNT_CHIP := ar7240
+endef
+
+TARGET_DEVICES += ubdev01
+
+define Device/ubnt-routerstation
+ IMAGE_SIZE := 16128k
+ IMAGES := sysupgrade.bin factory.bin
+ IMAGE/factory.bin = append-rootfs | pad-rootfs | mkubntimage
+ IMAGE/sysupgrade.bin = append-rootfs | pad-rootfs | combined-image | check-size $$$$(IMAGE_SIZE)
+ KERNEL := kernel-bin | patch-cmdline | lzma | pad-to $$(BLOCKSIZE)
+endef
+
+define Device/ubnt-rs
+$(Device/ubnt-routerstation)
+ BOARDNAME := UBNT-RS
+ DEVICE_PROFILE := Madwifi UBNT UBNTRS
+ UBNT_BOARD := RS
+ UBNT_TYPE := RSx
+ UBNT_CHIP := ar7100
+endef
+
+define Device/ubnt-rspro
+$(Device/ubnt-routerstation)
+ BOARDNAME := UBNT-RSPRO
+ DEVICE_PROFILE := Madwifi UBNT UBNTRSPRO
+ UBNT_BOARD := RSPRO
+ UBNT_TYPE := RSPRO
+ UBNT_CHIP := ar7100pro
+endef
+
+define Device/ubnt-ls-sr71
+$(Device/ubnt-routerstation)
+ BOARDNAME := UBNT-LS-SR71
+ DEVICE_PROFILE := Madwifi UBNT
+ UBNT_BOARD := LS-SR71
+ UBNT_TYPE := LS-SR71
+ UBNT_CHIP := ar7100
+endef
+
+TARGET_DEVICES += ubnt-rs ubnt-rspro ubnt-ls-sr71
+
+define Device/ubnt-uap-pro
+ IMAGE_SIZE := 15744k
+ MTDPARTS := spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,1536k(kernel),14208k(rootfs),256k(cfg)ro,64k(EEPROM)ro,15744k@0x50000(firmware)
+ UBNT_TYPE := BZ
+ UBNT_CHIP := ar934x
+ BOARD_NAME := UAP-PRO
+ DEVICE_PROFILE := UBNT UAPPRO
+ KERNEL := kernel-bin | patch-cmdline | lzma | uImage lzma | mkubntkernelimage
+ IMAGES := sysupgrade.bin factory.bin
+ IMAGE/sysupgrade.bin = append-kernel $$$$(BLOCKSIZE) | append-rootfs | pad-rootfs | check-size $$$$(IMAGE_SIZE)
+ IMAGE/factory.bin = append-kernel $$$$(BLOCKSIZE) | append-rootfs | pad-rootfs | check-size $$$$(IMAGE_SIZE) | mkubntimage2
+endef
+
+define Device/ubnt-unifi-outdoor-plus
+$(Device/ubnt-uap-pro)
+ UBNT_CHIP := ar7240
+ BOARD_NAME := UBNT-UOP
+ DEVICE_PROFILE := UBNT
+endef
+
+TARGET_DEVICES += ubnt-uap-pro ubnt-unifi-outdoor-plus
+
rootfs_type=$(patsubst jffs2-%,jffs2,$(patsubst squashfs-%,squashfs,$(1)))
# $(1): rootfs type.
@@ -1285,72 +1459,6 @@ define Image/Build/MyLoader
fi
endef
-
-Image/Build/UAPPRO/initramfs=$(call MkuImageLzma/initramfs,$(2),$(3) $(uap_pro_mtdlayout))
-
-define Image/Build/UAPPRO/buildkernel
- $(call MkuImageLzma,$(2),$(3) $(uap_pro_mtdlayout))
- -rm -rf $(KDIR_TMP)/$(2)
- mkdir -p $(KDIR_TMP)/$(2)/image
- cp $(KDIR_TMP)/vmlinux-$(2).uImage $(KDIR_TMP)/$(2)/image/kernel0
- $(STAGING_DIR_HOST)/bin/mkfs.jffs2 \
- --pad --big-endian --squash-uids -v -e 64KiB \
- -o $(KDIR_TMP)/$(2)-kernel.jffs2 \
- -d $(KDIR_TMP)/$(2)/image \
- 2>&1 1>/dev/null | awk '/^.+$$$$/'
- -rm -rf $(KDIR_TMP)/$(2)
- $(STAGING_DIR_HOST)/bin/padjffs2 $(KDIR_TMP)/$(2)-kernel.jffs2 -J 64
-endef
-
-define Image/Build/UAPPRO
- $(call CatFiles,$(KDIR_TMP)/$(2)-kernel.jffs2,1572864,$(KDIR)/root.$(1),14548992,$(call sysupname,$(1),$(2)))
- -$(STAGING_DIR_HOST)/bin/mkfwimage2 -f 0x9f000000 \
- -v $(5).$(6).v6.0.0-OpenWrt-$(REVISION) \
- -p jffs2:0x50000:0xf60000:0:0:$(call sysupname,$(1),$(2)) \
- -o $(call factoryname,$(1),$(2))
-endef
-
-# $(4) = board (XS2, XS5, RS, XM)
-# $(5) = series (BZ, XM, XW)
-# $(6) = chip (ar7240, ar934x)
-define Image/Build/UBNT2
- $(eval fwsize=$(call mtdpartsize,firmware,$(3)))
- $(call Sysupgrade/KRuImage,$(1),$(2),0,$$$$(($(fwsize)-4*64*1024)),64)
- if [ -e "$(call sysupname,$(1),$(2))" ]; then \
- dd if=$(call sysupname,$(1),$(2)) of=$(KDIR_TMP)/$(2)-mtdpart-kernel.bin bs=1024k count=1; \
- dd if=$(call sysupname,$(1),$(2)) of=$(KDIR_TMP)/$(2)-mtdpart-rootfs.bin bs=1024k skip=1; \
- $(STAGING_DIR_HOST)/bin/mkfwimage \
- -B $(4) -v $(5).$(6).v6.0.0-OpenWrt-$(REVISION) \
- -k $(KDIR_TMP)/$(2)-mtdpart-kernel.bin \
- -r $(KDIR_TMP)/$(2)-mtdpart-rootfs.bin \
- -o $(call factoryname,$(1),$(2)); \
- fi
-endef
-
-Image/Build/UBNTXM/initramfs=$(call MkuImageLzma/initramfs,$(2),$(3) $(ubntxm_mtdlayout))
-Image/Build/UBNTXM/buildkernel=$(call MkuImageLzma,$(2),$(3) $(ubntxm_mtdlayout))
-Image/Build/UBNTXM=$(call Image/Build/UBNT2,$(1),$(2),$(ubntxm_mtdlayout),$(4),$(5),$(6),$(7))
-
-Image/Build/UBDEV/buildkernel=$(call MkuImageLzma,$(2),$(3) $(ubdev_mtdlayout))
-Image/Build/UBDEV=$(call Image/Build/UBNT2,$(1),$(2),$(ubdev_mtdlayout),$(4),$(5),$(6),$(7))
-
-
-Image/Build/UBNT/buildkernel=$(call PatchKernelLzma,$(2),$(3))
-
-define Image/Build/UBNT
- dd if=$(KDIR_TMP)/vmlinux-$(2).bin.lzma of=$(KDIR_TMP)/vmlinux-$(2).lzma bs=64k conv=sync
- -$(STAGING_DIR_HOST)/bin/mkfwimage \
- -B $(4) -v $(5).$(6).OpenWrt.$(REVISION) \
- -k $(KDIR_TMP)/vmlinux-$(2).lzma \
- -r $(BIN_DIR)/$(IMG_PREFIX)-root.$(1) \
- -o $(call factoryname,$(1),$(2))
- -sh $(TOPDIR)/scripts/combined-image.sh \
- "$(KDIR_TMP)/vmlinux-$(2).lzma" \
- "$(BIN_DIR)/$(IMG_PREFIX)-root.$(1)" \
- $(call sysupname,$(1),$(2))
-endef
-
-
Image/Build/Planex/initramfs=$(call MkuImageGzip/initramfs,$(2),$(3) $(planex_mtdlayout))
Image/Build/Planex/loader=$(call Image/BuildLoaderAlone,$(1),gz,$(2) $(planex_mtdlayout),0x52000,0)
@@ -1964,27 +2072,6 @@ $(eval $(call SingleProfile,TPLINK-LZMA,64kraw,TLWR2543,tl-wr2543-v1,TL-WR2543N,
$(eval $(call SingleProfile,TPLINK-SAFELOADER,64kraw,CPE510,cpe210-220-510-520,CPE510,ttyS0,115200,$$(cpe510_mtdlayout),CPE510))
-$(eval $(call SingleProfile,UAPPRO,64k,UAPPRO,ubnt-uap-pro,UAP-PRO,ttyS0,115200,BZ,BZ,ar934x))
-$(eval $(call SingleProfile,UAPPRO,64k,UBNTUNIFIOUTDOORPLUS,ubnt-unifi-outdoor-plus,UBNT-UOP,ttyS0,115200,BZ,BZ,ar7240))
-
-$(eval $(call SingleProfile,UBDEV,64kraw,UBDEV01,ubdev01,UBNT-UF,ttyS0,115200,XM,XM,ar7240))
-
-$(eval $(call SingleProfile,UBNT,64k,UBNTRS,ubnt-rs,UBNT-RS,ttyS0,115200,RS,RSx,ar7100))
-$(eval $(call SingleProfile,UBNT,64k,UBNTRSPRO,ubnt-rspro,UBNT-RSPRO,ttyS0,115200,RSPRO,RSPRO,ar7100pro))
-$(eval $(call SingleProfile,UBNT,64k,UBNTLSSR71,ubnt-ls-sr71,UBNT-LS-SR71,ttyS0,115200,LS-SR71,LS-SR71,ar7100))
-
-$(eval $(call SingleProfile,UBNTXM,64kraw,RW2458N,rw2458n,RW2458N,ttyS0,115200,XM,XM,ar7240))
-$(eval $(call SingleProfile,UBNTXM,64kraw,UBNTAIRROUTER,ubnt-airrouter,UBNT-AR,ttyS0,115200,XM,XM,ar7240))
-$(eval $(call SingleProfile,UBNTXM,64kraw,UBNTBULLETM,ubnt-bullet-m,UBNT-BM,ttyS0,115200,XM,XM,ar7240))
-$(eval $(call SingleProfile,UBNTXM,64kraw,UBNTROCKETM,ubnt-rocket-m,UBNT-RM,ttyS0,115200,XM,XM,ar7240))
-$(eval $(call SingleProfile,UBNTXM,64kraw,UBNTROCKETMXW,ubnt-rocket-m-xw,UBNT-RM-XW,ttyS0,115200,XM,XW,ar934x))
-$(eval $(call SingleProfile,UBNTXM,64kraw,UBNTNANOM,ubnt-nano-m,UBNT-NM,ttyS0,115200,XM,XM,ar7240))
-$(eval $(call SingleProfile,UBNTXM,64kraw,UBNTUNIFI,ubnt-unifi,UBNT-UF,ttyS0,115200,XM,BZ,ar7240))
-$(eval $(call SingleProfile,UBNTXM,64kraw,UBNTUNIFIOUTDOOR,ubnt-unifi-outdoor,UBNT-U20,ttyS0,115200,XM,BZ,ar7240))
-$(eval $(call SingleProfile,UBNTXM,64kraw,UBNTNANOMXW,ubnt-nano-m-xw,UBNT-NM-XW,ttyS0,115200,XM,XW,ar934x))
-$(eval $(call SingleProfile,UBNTXM,64kraw,UBNTLOCOXW,ubnt-loco-m-xw,UBNT-LOCO-XW,ttyS0,115200,XM,XW,ar934x))
-$(eval $(call SingleProfile,UBNTXM,64kraw,UBNTAIRGW,ubnt-air-gateway,UBNT-AGW,ttyATH0,115200,XM,AirGW,ar933x))
-
$(eval $(call SingleProfile,WHRHPG300N,64kraw,WHRG301N,whr-g301n,WHR-G301N,ttyS0,115200,$$(whrhpg300n_mtdlayout),WHR-G301N))
$(eval $(call SingleProfile,WHRHPG300N,64kraw,WHRHPG300N,whr-hp-g300n,WHR-HP-G300N,ttyS0,115200,$$(whrhpg300n_mtdlayout),WHR-HP-G300N))
$(eval $(call SingleProfile,WHRHPG300N,64kraw,WHRHPGN,whr-hp-gn,WHR-HP-GN,ttyS0,115200,$$(whrhpg300n_mtdlayout),WHR-HP-GN))
@@ -2026,7 +2113,6 @@ $(eval $(call MultiProfile,TLWR941,TLWR941NV2 TLWR941NV3 TLWR941NV4))
$(eval $(call MultiProfile,TLWR1043,TLWR1043V1 TLWR1043V2))
$(eval $(call MultiProfile,TLWDR4300,TLWDR3500V1 TLWDR3600V1 TLWDR4300V1 TLWDR4300V1IL TLWDR4310V1 MW4530RV1))
$(eval $(call MultiProfile,TUBE2H,TUBE2H8M TUBE2H16M))
-$(eval $(call MultiProfile,UBNT,UBNTAIRROUTER UBNTRS UBNTRSPRO UBNTLSSR71 UBNTBULLETM UBNTROCKETM UBNTROCKETMXW UBNTNANOM UBNTNANOMXW UBNTLOCOXW UBNTUNIFI UBNTUNIFIOUTDOOR UBNTUNIFIOUTDOORPLUS UAPPRO UBNTAIRGW))
$(eval $(call MultiProfile,WNR612V2,REALWNR612V2 N150R))
$(eval $(call MultiProfile,WNR1000V2,REALWNR1000V2 WNR1000V2_VC))
$(eval $(call MultiProfile,WP543,WP543_2M WP543_4M WP543_8M WP543_16M))
@@ -2035,7 +2121,7 @@ $(eval $(call MultiProfile,WPJ344,WPJ344_16M))
$(eval $(call MultiProfile,WPJ558,WPJ558_16M))
$(eval $(call MultiProfile,Minimal,$(SINGLE_PROFILES)))
-$(eval $(call MultiProfile,Madwifi,EAP7660D UBNTRS UBNTRSPRO UBNTLSSR71 WP543))
+$(eval $(call MultiProfile,Madwifi,EAP7660D WP543))
endif # ifeq ($(SUBTARGET),generic)
ifeq ($(SUBTARGET),nand)