summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2010-04-26 18:27:47 +0000
committerGabor Juhos <juhosg@openwrt.org>2010-04-26 18:27:47 +0000
commit97b031b57fd28e154628f5a0031d85975853d637 (patch)
tree583aaff721f98f664746e76fe0e05a0d509baf4f /target/linux/ar71xx
parent893bfa55888423cef0e67194a1a496e23a2370bc (diff)
downloadmaster-31e0f0ae-97b031b57fd28e154628f5a0031d85975853d637.tar.gz
master-31e0f0ae-97b031b57fd28e154628f5a0031d85975853d637.tar.bz2
master-31e0f0ae-97b031b57fd28e154628f5a0031d85975853d637.zip
ar71xx: create separate 'factory' and 'sysupgrade' images for the WRT160NL
The 'factory' image requires the garbage at the end of the image. Flashing from the original web interface does not work without that. SVN-Revision: 21168
Diffstat (limited to 'target/linux/ar71xx')
-rw-r--r--target/linux/ar71xx/image/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index cd066f78ed..a5f02703c9 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -320,7 +320,10 @@ define Image/Build/CyberTAN
-x 32 -a 0x10000 -x -32 -f $(KDIR)/root.$(1)
-$(STAGING_DIR_HOST)/bin/addpattern -B $(2) -v v$(4) \
-i $(KDIR)/image.tmp \
- -o $(call imgname,$(1),$(2)).bin
+ -o $(call imgname,$(1),$(2))-sysupgrade.bin
+ -$(STAGING_DIR_HOST)/bin/addpattern -B $(2) -v v$(4) -g \
+ -i $(KDIR)/image.tmp \
+ -o $(call imgname,$(1),$(2))-factory.bin
rm $(KDIR)/image.tmp
endef