summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2011-07-04 12:10:03 +0000
committerGabor Juhos <juhosg@openwrt.org>2011-07-04 12:10:03 +0000
commit89f6b29feb3ca3fc20e016f0898c91a250638bf9 (patch)
tree0dab4d7d96b6b380eaea7d5c10f5e290280ad35d /target/linux/ar71xx
parent29653782a9814e56d2ab74947441222f28600585 (diff)
downloadmaster-31e0f0ae-89f6b29feb3ca3fc20e016f0898c91a250638bf9.tar.gz
master-31e0f0ae-89f6b29feb3ca3fc20e016f0898c91a250638bf9.tar.bz2
master-31e0f0ae-89f6b29feb3ca3fc20e016f0898c91a250638bf9.zip
ar71xx: fix building of squashfs images
SVN-Revision: 27446
Diffstat (limited to 'target/linux/ar71xx')
-rw-r--r--target/linux/ar71xx/image/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index b78441fabf..b70a091b5f 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -856,10 +856,12 @@ define Image/Build/Profile/Madwifi
endef
define Image/Build/squashfs
- cp $(KDIR)/root.squashfs $(BIN_DIR)/$(IMG_PREFIX)-root.squashfs-4k
- $(STAGING_DIR_HOST)/bin/padjffs2 $(BIN_DIR)/$(IMG_PREFIX)-root.squashfs-4k 4
- cp $(KDIR)/root.squashfs $(BIN_DIR)/$(IMG_PREFIX)-root.squashfs-64k
- $(STAGING_DIR_HOST)/bin/padjffs2 $(BIN_DIR)/$(IMG_PREFIX)-root.squashfs-64k 4 8 64
+ cp $(KDIR)/root.squashfs $(KDIR)/root.squashfs-4k
+ $(STAGING_DIR_HOST)/bin/padjffs2 $(KDIR)/root.squashfs-4k 4
+ cp $(KDIR)/root.squashfs-4k $(BIN_DIR)/$(IMG_PREFIX)-root.squashfs-4k
+ cp $(KDIR)/root.squashfs $(KDIR)/root.squashfs-64k
+ $(STAGING_DIR_HOST)/bin/padjffs2 $(KDIR)/root.squashfs-64k 4 8 64
+ cp $(KDIR)/root.squashfs-64k $(BIN_DIR)/$(IMG_PREFIX)-root.squashfs-64k
$(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
endef