summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2016-06-27 15:03:57 +0200
committerJo-Philipp Wich <jo@mein.io>2016-06-27 15:15:49 +0200
commit6ee66ae0759234230958ff4c6b3ba92b26e85965 (patch)
tree4e6616dbd21495a4a73bf3e9ba3c6280bf64fd3c /target/linux/ar71xx
parent2270fc5947a3cc3b7595ed22468425a4b10ebc30 (diff)
downloadmaster-31e0f0ae-6ee66ae0759234230958ff4c6b3ba92b26e85965.tar.gz
master-31e0f0ae-6ee66ae0759234230958ff4c6b3ba92b26e85965.tar.bz2
master-31e0f0ae-6ee66ae0759234230958ff4c6b3ba92b26e85965.zip
ar71xx: further legacy image build fixes
- Add missing macro to trigger the generation of 64k padded squashfs images - Revert Zcomax image generation to use the prepared 64k squashfs image Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'target/linux/ar71xx')
-rw-r--r--target/linux/ar71xx/image/legacy.mk7
1 files changed, 6 insertions, 1 deletions
diff --git a/target/linux/ar71xx/image/legacy.mk b/target/linux/ar71xx/image/legacy.mk
index 8446bcbb6f..c771f893ed 100644
--- a/target/linux/ar71xx/image/legacy.mk
+++ b/target/linux/ar71xx/image/legacy.mk
@@ -919,7 +919,7 @@ define Image/Build/Zcomax
$(STAGING_DIR_HOST)/bin/mkzcfw \
-B $(2) \
-k $(KDIR_TMP)/vmlinux-$(2).uImage \
- -r $(KDIR)/root.$(1) \
+ -r $(BIN_DIR)/$(IMG_PREFIX)-root.$(1) \
-o $(call imgname,$(1),$(2))-factory.img; \
fi
endef
@@ -1205,3 +1205,8 @@ define Image/Build/Profile
$(call Image/Build/Profile/$(1),buildkernel)
$(call Image/Build/Profile/$(1),$(2))
endef
+
+# $(1): filesystem type.
+define Image/Build
+ $(call Image/Build/$(call rootfs_type,$(1)),$(1))
+endef