summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2009-10-19 08:07:40 +0000
committerGabor Juhos <juhosg@openwrt.org>2009-10-19 08:07:40 +0000
commit4f1f99a63daf57e3106a675b554630e4cc396982 (patch)
treee44a836bb8553c41caeb66415c4afe960a7ded19 /target/linux/ar71xx
parent71ca5a93a404a349a73296b75deca60b02009ace (diff)
downloadmaster-31e0f0ae-4f1f99a63daf57e3106a675b554630e4cc396982.tar.gz
master-31e0f0ae-4f1f99a63daf57e3106a675b554630e4cc396982.tar.bz2
master-31e0f0ae-4f1f99a63daf57e3106a675b554630e4cc396982.zip
ar71xx: create firmware image for WP543 boards with 4/8/16MB of flash
SVN-Revision: 18075
Diffstat (limited to 'target/linux/ar71xx')
-rw-r--r--target/linux/ar71xx/image/Makefile18
1 files changed, 15 insertions, 3 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 816f27e63a..5a126c0af2 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -106,9 +106,21 @@ endef
define Image/Build/MyLoader
-$(STAGING_DIR_HOST)/bin/mkmylofw -B $(2) \
- -p0x30000:0xc0000:al:0x80060000:kernel:$(KDIR)/vmlinux.bin.lzma \
- -p0xf0000:0:::rootfs:$(KDIR)/root.$(1) \
- $(call imgname,$(1),$(2)).img
+ -p0x030000:0xd0000:al:0x80060000:kernel:$(KDIR)/vmlinux.bin.lzma \
+ -p0x100000:0:::rootfs:$(KDIR)/root.$(1) \
+ $(call imgname,$(1),$(2))-2M.img
+ -$(STAGING_DIR_HOST)/bin/mkmylofw -B $(2) -s 0x400000 \
+ -p0x030000:0xd0000:al:0x80060000:kernel:$(KDIR)/vmlinux.bin.lzma \
+ -p0x100000:0:::rootfs:$(KDIR)/root.$(1) \
+ $(call imgname,$(1),$(2))-4M.img
+ -$(STAGING_DIR_HOST)/bin/mkmylofw -B $(2) -s 0x800000 \
+ -p0x030000:0xd0000:al:0x80060000:kernel:$(KDIR)/vmlinux.bin.lzma \
+ -p0x100000:0:::rootfs:$(KDIR)/root.$(1) \
+ $(call imgname,$(1),$(2))-8M.img
+ -$(STAGING_DIR_HOST)/bin/mkmylofw -B $(2) -s 0x1000000 \
+ -p0x030000:0xd0000:al:0x80060000:kernel:$(KDIR)/vmlinux.bin.lzma \
+ -p0x100000:0:::rootfs:$(KDIR)/root.$(1) \
+ $(call imgname,$(1),$(2))-16M.img
endef
define Image/Build/UBNT