summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2008-11-25 19:19:55 +0000
committerGabor Juhos <juhosg@openwrt.org>2008-11-25 19:19:55 +0000
commit4690f9356c88207a5b91f4dbd0618e5eb14f62b1 (patch)
tree1df62f15e4c016b140f178782c69a024490164bf /target/linux/ar71xx
parent507b9818c0dadae940e68d711b643d6b732a2cea (diff)
downloadmaster-31e0f0ae-4690f9356c88207a5b91f4dbd0618e5eb14f62b1.tar.gz
master-31e0f0ae-4690f9356c88207a5b91f4dbd0618e5eb14f62b1.tar.bz2
master-31e0f0ae-4690f9356c88207a5b91f4dbd0618e5eb14f62b1.zip
add dummy code for the Atheros AP83 board
SVN-Revision: 13354
Diffstat (limited to 'target/linux/ar71xx')
-rw-r--r--target/linux/ar71xx/config-2.6.261
-rw-r--r--target/linux/ar71xx/config-2.6.271
-rw-r--r--target/linux/ar71xx/files/arch/mips/ar71xx/Kconfig4
-rw-r--r--target/linux/ar71xx/files/arch/mips/ar71xx/Makefile1
-rw-r--r--target/linux/ar71xx/files/arch/mips/ar71xx/mach-ap83.c24
-rw-r--r--target/linux/ar71xx/patches-2.6.26/001-ar71xx_core.patch3
-rw-r--r--target/linux/ar71xx/patches-2.6.27/001-ar71xx_core.patch3
7 files changed, 35 insertions, 2 deletions
diff --git a/target/linux/ar71xx/config-2.6.26 b/target/linux/ar71xx/config-2.6.26
index b59ba281bb..f360d28d3f 100644
--- a/target/linux/ar71xx/config-2.6.26
+++ b/target/linux/ar71xx/config-2.6.26
@@ -4,6 +4,7 @@ CONFIG_32BIT=y
CONFIG_ADM6996_PHY=y
CONFIG_AG71XX=y
# CONFIG_AR71XX_EARLY_SERIAL is not set
+CONFIG_AR71XX_MACH_AP83=y
CONFIG_AR71XX_MACH_AW_NR580=y
CONFIG_AR71XX_MACH_GENERIC=y
CONFIG_AR71XX_MACH_RB_4XX=y
diff --git a/target/linux/ar71xx/config-2.6.27 b/target/linux/ar71xx/config-2.6.27
index 8658bc99f9..605a4ebee2 100644
--- a/target/linux/ar71xx/config-2.6.27
+++ b/target/linux/ar71xx/config-2.6.27
@@ -4,6 +4,7 @@ CONFIG_32BIT=y
CONFIG_ADM6996_PHY=y
CONFIG_AG71XX=y
# CONFIG_AR71XX_EARLY_SERIAL is not set
+CONFIG_AR71XX_MACH_AP83=y
CONFIG_AR71XX_MACH_AW_NR580=y
CONFIG_AR71XX_MACH_GENERIC=y
CONFIG_AR71XX_MACH_RB_4XX=y
diff --git a/target/linux/ar71xx/files/arch/mips/ar71xx/Kconfig b/target/linux/ar71xx/files/arch/mips/ar71xx/Kconfig
index d8ae08577b..3b11057a6b 100644
--- a/target/linux/ar71xx/files/arch/mips/ar71xx/Kconfig
+++ b/target/linux/ar71xx/files/arch/mips/ar71xx/Kconfig
@@ -6,6 +6,10 @@ config AR71XX_EARLY_SERIAL
menu "Atheros AR71xx machine selection"
+config AR71XX_MACH_AP83
+ bool "Atheros AP83 board support"
+ default y
+
config AR71XX_MACH_AW_NR580
bool "AzureWave AW-NR580 board support"
default y
diff --git a/target/linux/ar71xx/files/arch/mips/ar71xx/Makefile b/target/linux/ar71xx/files/arch/mips/ar71xx/Makefile
index 175c43e911..dc682c8e57 100644
--- a/target/linux/ar71xx/files/arch/mips/ar71xx/Makefile
+++ b/target/linux/ar71xx/files/arch/mips/ar71xx/Makefile
@@ -10,6 +10,7 @@
obj-y := prom.o irq.o setup.o platform.o gpio.o ar71xx.o
+obj-$(CONFIG_AR71XX_MACH_AP83) += mach-ap83.o
obj-$(CONFIG_AR71XX_MACH_AW_NR580) += mach-aw-nr580.o
obj-$(CONFIG_AR71XX_MACH_GENERIC) += mach-generic.o
obj-$(CONFIG_AR71XX_MACH_RB_4XX) += mach-rb-4xx.o
diff --git a/target/linux/ar71xx/files/arch/mips/ar71xx/mach-ap83.c b/target/linux/ar71xx/files/arch/mips/ar71xx/mach-ap83.c
new file mode 100644
index 0000000000..02e420ade2
--- /dev/null
+++ b/target/linux/ar71xx/files/arch/mips/ar71xx/mach-ap83.c
@@ -0,0 +1,24 @@
+/*
+ * Atheros AP83 board support
+ *
+ * Copyright (C) 2008 Gabor Juhos <juhosg@openwrt.org>
+ * Copyright (C) 2008 Imre Kaloz <kaloz@openwrt.org>
+ *
+ * This program is free software; you can redistribute it and/or modify it
+ * under the terms of the GNU General Public License version 2 as published
+ * by the Free Software Foundation.
+ */
+
+#include <linux/platform_device.h>
+#include <linux/input.h>
+
+#include <asm/mips_machine.h>
+#include <asm/mach-ar71xx/ar71xx.h>
+#include <asm/mach-ar71xx/pci.h>
+#include <asm/mach-ar71xx/platform.h>
+
+static void __init ap83_setup(void)
+{
+}
+
+MIPS_MACHINE(MACH_AR71XX_AP83, "Atheros AP83", ap83_setup);
diff --git a/target/linux/ar71xx/patches-2.6.26/001-ar71xx_core.patch b/target/linux/ar71xx/patches-2.6.26/001-ar71xx_core.patch
index 0249c50080..c5871c8c57 100644
--- a/target/linux/ar71xx/patches-2.6.26/001-ar71xx_core.patch
+++ b/target/linux/ar71xx/patches-2.6.26/001-ar71xx_core.patch
@@ -16,7 +16,7 @@
--- a/include/asm-mips/bootinfo.h
+++ b/include/asm-mips/bootinfo.h
-@@ -79,6 +79,17 @@
+@@ -79,6 +79,18 @@
#define MACH_LASAT_200 1 /* Masquerade PRO/SP200 */
/*
@@ -29,6 +29,7 @@
+#define MACH_AR71XX_RB_450 4 /* MikroTik RouterBOARD 450 */
+#define MACH_AR71XX_RB_493 5 /* Mikrotik RouterBOARD 493/493AH */
+#define MACH_AR71XX_AW_NR580 6 /* AzureWave AW-NR580 */
++#define MACH_AR71XX_AP83 7 /* Atheros AP83 */
+
+/*
* Valid machtype for group NEC EMMA2RH
diff --git a/target/linux/ar71xx/patches-2.6.27/001-ar71xx_core.patch b/target/linux/ar71xx/patches-2.6.27/001-ar71xx_core.patch
index 548c06b12d..1b1368bbc7 100644
--- a/target/linux/ar71xx/patches-2.6.27/001-ar71xx_core.patch
+++ b/target/linux/ar71xx/patches-2.6.27/001-ar71xx_core.patch
@@ -16,7 +16,7 @@
--- a/include/asm-mips/bootinfo.h
+++ b/include/asm-mips/bootinfo.h
-@@ -57,6 +57,17 @@
+@@ -57,6 +57,18 @@
#define MACH_MIKROTIK_RB532 0 /* Mikrotik RouterBoard 532 */
#define MACH_MIKROTIK_RB532A 1 /* Mikrotik RouterBoard 532A */
@@ -30,6 +30,7 @@
+#define MACH_AR71XX_RB_450 4 /* MikroTik RouterBOARD 450 */
+#define MACH_AR71XX_RB_493 5 /* MikroTik RouterBOARD 493 */
+#define MACH_AR71XX_AW_NR580 6 /* AzureWave AW-NR580 */
++#define MACH_AR71XX_AP83 7 /* Atheros AP83 */
+
#define CL_SIZE COMMAND_LINE_SIZE