summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2013-07-14 14:05:31 +0000
committerFelix Fietkau <nbd@openwrt.org>2013-07-14 14:05:31 +0000
commit25d910a78fab40aa35477731d4245aa5cf9a8879 (patch)
tree417ee64be768fce644e0f01a64b317c553feff89 /target/linux/ar71xx
parent6bff4562123b54603b741b42267bc1e83b38077c (diff)
downloadmaster-31e0f0ae-25d910a78fab40aa35477731d4245aa5cf9a8879.tar.gz
master-31e0f0ae-25d910a78fab40aa35477731d4245aa5cf9a8879.tar.bz2
master-31e0f0ae-25d910a78fab40aa35477731d4245aa5cf9a8879.zip
ar71xx: use uimage split for WZR-HP-G300NH2
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 37295
Diffstat (limited to 'target/linux/ar71xx')
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/mach-wzr-hp-g300nh2.c12
-rw-r--r--target/linux/ar71xx/image/Makefile24
2 files changed, 3 insertions, 33 deletions
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/mach-wzr-hp-g300nh2.c b/target/linux/ar71xx/files/arch/mips/ath79/mach-wzr-hp-g300nh2.c
index 4087288dc6..733d996ea0 100644
--- a/target/linux/ar71xx/files/arch/mips/ath79/mach-wzr-hp-g300nh2.c
+++ b/target/linux/ar71xx/files/arch/mips/ath79/mach-wzr-hp-g300nh2.c
@@ -44,22 +44,14 @@ static struct mtd_partition wzrhpg300nh2_flash_partitions[] = {
.size = 0x0010000,
.mask_flags = MTD_WRITEABLE,
}, {
- .name = "kernel",
+ .name = "firmware",
.offset = 0x0060000,
- .size = 0x0100000,
- }, {
- .name = "rootfs",
- .offset = 0x0160000,
- .size = 0x1e90000,
+ .size = 0x1f90000,
}, {
.name = "user_property",
.offset = 0x1ff0000,
.size = 0x0010000,
.mask_flags = MTD_WRITEABLE,
- }, {
- .name = "firmware",
- .offset = 0x0060000,
- .size = 0x1f90000,
}
};
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index cd87779a52..8a6dc7470a 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -314,28 +314,6 @@ define Image/Build/WZRHP128K/initramfs
$(call MkuImageLzma/initramfs,$(2),$(3) $(4))
endef
-define Image/Build/WZRHPG30XNH
- $(call MkuImageLzma,$(2),$(3))
- $(call Sysupgrade/KRuImage,$(1),$(2),1048576,31850496)
- if [ -e "$(call sysupname,$(1),$(2))" ]; then \
- ( \
- echo -n -e "# Airstation Public Fmt1\x00\x00\x00\x00\x00\x00\x00\x00"; \
- dd if=$(call sysupname,$(1),$(2)); \
- ) > $(call imgname,$(1),$(2))-tftp.bin; \
- buffalo-enc -p $(4) -v 1.99 \
- -i $(call sysupname,$(1),$(2)) \
- -o $(KDIR_TMP)/$(2).enc; \
- buffalo-tag -b $(4) -p $(4) -a ath -v 1.99 -m 1.01 -l mlang8 \
- -w 3 -c 0x80041000 -d 0x801e8000 -f 1 -r M_ \
- -i $(KDIR_TMP)/$(2).enc \
- -o $(call factoryname,$(1),$(2)); \
- fi
-endef
-
-define Image/Build/WZRHPG30XNH/initramfs
- $(call MkuImageLzma/initramfs,$(2),$(3) $(4))
-endef
-
define Image/Build/WHRHPG300N
$(call MkuImageLzma,$(2),$(3) $(4))
$(call Sysupgrade/KRuImage,$(1),$(2),1048576,2818048)
@@ -1036,7 +1014,7 @@ $(eval $(call SingleProfile,WHRHPG300N,$(fs_64k),WLAEAG300N,wlae-ag300n,WLAE-AG3
$(eval $(call SingleProfile,WRT400N,$(fs_64k),WRT400N,wrt400n,WRT400N,ttyS0,115200))
$(eval $(call SingleProfile,WZRHP128K,$(fs_128k),WZRHPG300NH,wzr-hp-g300nh,WZR-HP-G300NH,ttyS0,115200,WZR-HP-G300NH))
-$(eval $(call SingleProfile,WZRHPG30XNH,$(fs_64k),WZRHPG300NH2,wzr-hp-g300nh2,WZR-HP-G300NH2,ttyS0,115200,WZR-HP-G300NH2))
+$(eval $(call SingleProfile,WZRHP64K,$(fs_64k),WZRHPG300NH2,wzr-hp-g300nh2,WZR-HP-G300NH2,ttyS0,115200,WZR-HP-G300NH2))
$(eval $(call SingleProfile,WZRHP64K,$(fs_64k),WZRHPAG300H,wzr-hp-ag300h,WZR-HP-AG300H,ttyS0,115200,WZR-HP-AG300H))
$(eval $(call SingleProfile,WZRHP64K,$(fs_64k),WZRHPG450H,wzr-hp-g450h,WZR-HP-G450H,ttyS0,115200,WZR-HP-AG450H))
$(eval $(call SingleProfile,WZRHP64K,$(fs_64k),WZR600DHP,wzr-600dhp,WZR-HP-AG300H,ttyS0,115200,WZR-600DHP))