summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-02-15 07:36:15 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-02-15 07:36:15 +0000
commit162b8e23a5b6ddc158bd382cbd8ae8b31cac9082 (patch)
tree4b2186899ad176f455af45b0b3feede02ab57ff4 /target/linux/ar71xx
parentf35c369710959b964e0d16d5c45dd497093df61e (diff)
downloadmaster-31e0f0ae-162b8e23a5b6ddc158bd382cbd8ae8b31cac9082.tar.gz
master-31e0f0ae-162b8e23a5b6ddc158bd382cbd8ae8b31cac9082.tar.bz2
master-31e0f0ae-162b8e23a5b6ddc158bd382cbd8ae8b31cac9082.zip
kernel: update linux 3.7 to 3.7.8
Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 35604
Diffstat (limited to 'target/linux/ar71xx')
-rw-r--r--target/linux/ar71xx/Makefile2
-rw-r--r--target/linux/ar71xx/patches-3.7/902-unaligned_access_hacks.patch2
2 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/ar71xx/Makefile b/target/linux/ar71xx/Makefile
index 1227df163f..aeed946ce9 100644
--- a/target/linux/ar71xx/Makefile
+++ b/target/linux/ar71xx/Makefile
@@ -13,7 +13,7 @@ FEATURES:=squashfs jffs2 targz
CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely
SUBTARGETS:=generic nand
-LINUX_VERSION:=3.7.7
+LINUX_VERSION:=3.7.8
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/ar71xx/patches-3.7/902-unaligned_access_hacks.patch b/target/linux/ar71xx/patches-3.7/902-unaligned_access_hacks.patch
index e7e1712b7e..70e03ac9ed 100644
--- a/target/linux/ar71xx/patches-3.7/902-unaligned_access_hacks.patch
+++ b/target/linux/ar71xx/patches-3.7/902-unaligned_access_hacks.patch
@@ -191,7 +191,7 @@
/*
--- a/net/ipv4/tcp_input.c
+++ b/net/ipv4/tcp_input.c
-@@ -3842,13 +3842,14 @@ static bool tcp_parse_aligned_timestamp(
+@@ -3847,13 +3847,14 @@ static bool tcp_parse_aligned_timestamp(
{
const __be32 *ptr = (const __be32 *)(th + 1);