summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2010-04-26 18:27:54 +0000
committerGabor Juhos <juhosg@openwrt.org>2010-04-26 18:27:54 +0000
commit12fab9cb9e63156eb8776dd52ac8dd0bc13f8d2c (patch)
treeede3ddc5bd619ad4c6bcdcb8d1b078f422b1ee97 /target/linux/ar71xx
parent8470d973ee4369dc20a7e19ad55b049070a5767a (diff)
downloadmaster-31e0f0ae-12fab9cb9e63156eb8776dd52ac8dd0bc13f8d2c.tar.gz
master-31e0f0ae-12fab9cb9e63156eb8776dd52ac8dd0bc13f8d2c.tar.bz2
master-31e0f0ae-12fab9cb9e63156eb8776dd52ac8dd0bc13f8d2c.zip
ar71xx: create smaller sysupgrade images for the WRT400N board
SVN-Revision: 21170
Diffstat (limited to 'target/linux/ar71xx')
-rw-r--r--target/linux/ar71xx/image/Makefile7
1 files changed, 3 insertions, 4 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index dfcc5f6f08..adb4002de3 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -81,10 +81,9 @@ define Image/Build/WRT400N
-d $(KDIR)/vmlinux-$(2).bin.lzma $(KDIR)/vmlinux-$(2).uImage; \
( \
dd if=$(KDIR)/vmlinux-$(2).uImage bs=1280k conv=sync; \
- dd if=$(KDIR)/root.$(1) bs=6336k conv=sync; \
- echo -n $(4); \
- ) > $(call imgname,$(1),$(2)).bin; \
- wrt400n $(KDIR)/vmlinux-$(2).uImage $(KDIR)/root.$(1) $(call imgname,$(1),$(2)).webui; \
+ dd if=$(KDIR)/root.$(1) \
+ ) > $(call imgname,$(1),$(2))-sysupgrade.bin; \
+ wrt400n $(KDIR)/vmlinux-$(2).uImage $(KDIR)/root.$(1) $(call imgname,$(1),$(2))-factory.bin; \
fi; fi
endef