summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-03-11 14:03:28 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-03-11 14:03:28 +0000
commit088dd4e879a1f95f2e721b33d9e5409cb2f4309e (patch)
treeda2672a049bd4445a99c35591d8808d91b69c29a /target/linux/ar71xx
parent067a065305aec6b8344095fe986eb2f7e900e63a (diff)
downloadmaster-31e0f0ae-088dd4e879a1f95f2e721b33d9e5409cb2f4309e.tar.gz
master-31e0f0ae-088dd4e879a1f95f2e721b33d9e5409cb2f4309e.tar.bz2
master-31e0f0ae-088dd4e879a1f95f2e721b33d9e5409cb2f4309e.zip
ar71xx: stop image building if a loader is missing
SVN-Revision: 30877
Diffstat (limited to 'target/linux/ar71xx')
-rw-r--r--target/linux/ar71xx/image/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index f7df1026a1..8fcaa08d1a 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -299,6 +299,7 @@ define Image/Build/Planex/loader
endef
define Image/Build/Planex
+ [ -e "$(KDIR)/loader-$(2).gz" ]
$(call MkuImage,gzip,,$(KDIR)/loader-$(2).gz,$(KDIR_TMP)/vmlinux-$(2).uImage)
$(call MkuImageOKLI,$(2))
( \
@@ -338,6 +339,7 @@ define Image/Build/TPLINKOLD/loader
endef
define Image/Build/TPLINKOLD
+ [ -e "$(KDIR)/loader-$(2).gz" ]
$(call MkuImageOKLI,$(2))
( \
dd if=$(KDIR)/loader-$(2).gz bs=7680 count=1 conv=sync; \
@@ -368,6 +370,7 @@ define Image/Build/TPLINK/loader
endef
define Image/Build/TPLINK
+ [ -e "$(KDIR)/loader-$(2).gz" ]
$(call MkuImageOKLI,$(2))
( \
dd if=$(KDIR)/loader-$(2).gz bs=7680 count=1 conv=sync; \