summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/profiles
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2010-05-07 16:20:32 +0000
committerFelix Fietkau <nbd@openwrt.org>2010-05-07 16:20:32 +0000
commit2598c32f063f410ee32fe967db85a02432992269 (patch)
treea49faf7fc0079043cc3621974bbdab59e5c18ba9 /target/linux/ar71xx/profiles
parent0f7864456a60f1ea4a5a2ce7aa4f99d68bd4a1d9 (diff)
downloadmaster-31e0f0ae-2598c32f063f410ee32fe967db85a02432992269.tar.gz
master-31e0f0ae-2598c32f063f410ee32fe967db85a02432992269.tar.bz2
master-31e0f0ae-2598c32f063f410ee32fe967db85a02432992269.zip
ar71xx: add a new subtarget for nand based devices - saves around 44k on the lzma compressed generic kernel image
SVN-Revision: 21396
Diffstat (limited to 'target/linux/ar71xx/profiles')
-rw-r--r--target/linux/ar71xx/profiles/00-default.mk16
-rw-r--r--target/linux/ar71xx/profiles/01-minimal.mk16
-rw-r--r--target/linux/ar71xx/profiles/02-madwifi.mk16
-rw-r--r--target/linux/ar71xx/profiles/atheros.mk63
-rw-r--r--target/linux/ar71xx/profiles/atlantis.mk17
-rw-r--r--target/linux/ar71xx/profiles/buffalo.mk17
-rw-r--r--target/linux/ar71xx/profiles/compex.mk17
-rw-r--r--target/linux/ar71xx/profiles/d-link.mk41
-rw-r--r--target/linux/ar71xx/profiles/linksys.mk27
-rw-r--r--target/linux/ar71xx/profiles/netgear.mk17
-rw-r--r--target/linux/ar71xx/profiles/planex.mk28
-rw-r--r--target/linux/ar71xx/profiles/tp-link.mk94
-rw-r--r--target/linux/ar71xx/profiles/trendnet.mk28
-rw-r--r--target/linux/ar71xx/profiles/ubnt.mk39
-rw-r--r--target/linux/ar71xx/profiles/zyxel.mk17
15 files changed, 0 insertions, 453 deletions
diff --git a/target/linux/ar71xx/profiles/00-default.mk b/target/linux/ar71xx/profiles/00-default.mk
deleted file mode 100644
index aa46f22c54..0000000000
--- a/target/linux/ar71xx/profiles/00-default.mk
+++ /dev/null
@@ -1,16 +0,0 @@
-#
-# Copyright (C) 2009 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/Default
- NAME:=Default Profile (all drivers)
- PACKAGES:=kmod-ath9k kmod-madwifi kmod-usb-core kmod-usb-ohci kmod-usb2 swconfig vsc7385-ucode-ap83 vsc7385-ucode-pb44 vsc7395-ucode-ap83 vsc7395-ucode-pb44 wpad-mini
-endef
-
-define Profile/Default/Description
- Default package set compatible with most boards.
-endef
-$(eval $(call Profile,Default))
diff --git a/target/linux/ar71xx/profiles/01-minimal.mk b/target/linux/ar71xx/profiles/01-minimal.mk
deleted file mode 100644
index 3651c88ab2..0000000000
--- a/target/linux/ar71xx/profiles/01-minimal.mk
+++ /dev/null
@@ -1,16 +0,0 @@
-#
-# Copyright (C) 2009 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/DefaultNoWifi
- NAME:=Default Profile (no WiFi)
- PACKAGES:=
-endef
-
-define Profile/DefaultNoWifi/Description
- Default package set compatible with most boards.
-endef
-$(eval $(call Profile,DefaultNoWifi))
diff --git a/target/linux/ar71xx/profiles/02-madwifi.mk b/target/linux/ar71xx/profiles/02-madwifi.mk
deleted file mode 100644
index 7c22c53db5..0000000000
--- a/target/linux/ar71xx/profiles/02-madwifi.mk
+++ /dev/null
@@ -1,16 +0,0 @@
-#
-# Copyright (C) 2009 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/Madwifi
- NAME:=Atheros WiFi (madwifi)
- PACKAGES:=kmod-madwifi wpad-mini
-endef
-
-define Profile/Madwifi/Description
- Package set compatible with hardware using Atheros WiFi cards.
-endef
-$(eval $(call Profile,Madwifi))
diff --git a/target/linux/ar71xx/profiles/atheros.mk b/target/linux/ar71xx/profiles/atheros.mk
deleted file mode 100644
index 4ce0e605c6..0000000000
--- a/target/linux/ar71xx/profiles/atheros.mk
+++ /dev/null
@@ -1,63 +0,0 @@
-#
-# Copyright (C) 2009-2010 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/AP81
- NAME:=Atheros AP81 reference board
- PACKAGES:=wpad-mini kmod-ath9k kmod-usb-core kmod-usb2
-endef
-
-define Profile/AP81/Description
- Package set optimized for the Atheros AP81 reference board.
-endef
-
-$(eval $(call Profile,AP81))
-
-define Profile/AP83
- NAME:=Atheros AP83 reference board
- PACKAGES:=wpad-mini kmod-ath9k kmod-usb-core kmod-usb2 \
- vsc7385-ucode-ap83 vsc7395-ucode-ap83
-endef
-
-define Profile/AP83/Description
- Package set optimized for the Atheros AP83 reference board.
-endef
-
-$(eval $(call Profile,AP83))
-
-define Profile/PB42
- NAME:=Atheros PB42 reference board
- PACKAGES:=wpad-mini kmod-ath9k kmod-usb-core kmod-usb-ohci kmod-usb2
-endef
-
-define Profile/PB42/Description
- Package set optimized for the Atheros PB42 reference board.
-endef
-
-$(eval $(call Profile,PB42))
-
-define Profile/PB44
- NAME:=Atheros PB44 reference board
- PACKAGES:=wpad-mini kmod-ath9k kmod-usb-core kmod-usb-ohci kmod-usb2 \
- vsc7385-ucode-pb44 vsc7395-ucode-pb44
-endef
-
-define Profile/PB44/Description
- Package set optimized for the Atheros PB44 reference board.
-endef
-
-$(eval $(call Profile,PB44))
-
-define Profile/PB92
- NAME:=Atheros PB92 reference board
- PACKAGES:=wpad-mini kmod-ath9k kmod-usb-core kmod-usb2
-endef
-
-define Profile/PB92/Description
- Package set optimized for the Atheros PB92 reference board.
-endef
-
-$(eval $(call Profile,PB92))
diff --git a/target/linux/ar71xx/profiles/atlantis.mk b/target/linux/ar71xx/profiles/atlantis.mk
deleted file mode 100644
index c63fd9c275..0000000000
--- a/target/linux/ar71xx/profiles/atlantis.mk
+++ /dev/null
@@ -1,17 +0,0 @@
-#
-# Copyright (C) 2009 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/A02RBW300N
- NAME:=Atlantis-Land A02-RB-W300N
- PACKAGES:=kmod-ath9k wpad-mini
-endef
-
-define Profile/A02RBW300N/Description
- Package set optimized for the Atlantis-Land A02-RB-W300N.
-endef
-
-$(eval $(call Profile,A02RBW300N))
diff --git a/target/linux/ar71xx/profiles/buffalo.mk b/target/linux/ar71xx/profiles/buffalo.mk
deleted file mode 100644
index 69819e586d..0000000000
--- a/target/linux/ar71xx/profiles/buffalo.mk
+++ /dev/null
@@ -1,17 +0,0 @@
-#
-# Copyright (C) 2009 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/WZRHPG300NH
- NAME:=Buffalo WZR-HP-G300NH
- PACKAGES:=kmod-ath9k wpad-mini kmod-usb-core kmod-usb2
-endef
-
-define Profile/WZRHPG300NH/Description
- Package set optimized for the Buffalo WZR-HP-G300NH
-endef
-
-$(eval $(call Profile,WZRHPG300NH))
diff --git a/target/linux/ar71xx/profiles/compex.mk b/target/linux/ar71xx/profiles/compex.mk
deleted file mode 100644
index 38d963a5c1..0000000000
--- a/target/linux/ar71xx/profiles/compex.mk
+++ /dev/null
@@ -1,17 +0,0 @@
-#
-# Copyright (C) 2009 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/WP543
- NAME:=Compex WP543/WPJ543
- PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2
-endef
-
-define Profile/WP543/Description
- Package set optimized for the Compex WP543/WPJ543 boards.
-endef
-
-$(eval $(call Profile,WP543))
diff --git a/target/linux/ar71xx/profiles/d-link.mk b/target/linux/ar71xx/profiles/d-link.mk
deleted file mode 100644
index bf99e099a9..0000000000
--- a/target/linux/ar71xx/profiles/d-link.mk
+++ /dev/null
@@ -1,41 +0,0 @@
-#
-# Copyright (C) 2009 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/DIR600A1
- NAME:=D-Link DIR-600 rev. A1
- PACKAGES:=kmod-ath9k wpad-mini
-endef
-
-define Profile/DIR600A1/Description
- Package set optimized for the D-Link DIR-600 rev. A1.
-endef
-
-$(eval $(call Profile,DIR600A1))
-
-
-define Profile/DIR615C1
- NAME:=D-Link DIR-615 rev. C1
- PACKAGES:=kmod-ath9k wpad-mini
-endef
-
-define Profile/DIR615C1/Description
- Package set optimized for the D-Link DIR-615 rev. C1.
-endef
-
-$(eval $(call Profile,DIR615C1))
-
-
-define Profile/DIR825B1
- NAME:=D-Link DIR-825 rev. B1
- PACKAGES:=kmod-ath9k wpad-mini kmod-usb-core kmod-usb2
-endef
-
-define Profile/DIR825B1/Description
- Package set optimized for the D-Link DIR-825 rev. B1.
-endef
-
-$(eval $(call Profile,DIR825B1))
diff --git a/target/linux/ar71xx/profiles/linksys.mk b/target/linux/ar71xx/profiles/linksys.mk
deleted file mode 100644
index f3253e728f..0000000000
--- a/target/linux/ar71xx/profiles/linksys.mk
+++ /dev/null
@@ -1,27 +0,0 @@
-#
-# Copyright (C) 2009 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/WRT160NL
- NAME:=Linksys WRT160NL
- PACKAGES:=kmod-ath9k wpad-mini kmod-usb-core kmod-usb2 swconfig
-endef
-
-define Profile/WRT160NL/Description
- Package set optimized for the Linksys WRT160NL.
-endef
-
-define Profile/WRT400N
- NAME:=Linksys WRT400N
- PACKAGES:=kmod-ath9k wpad-mini
-endef
-
-define Profile/WRT400N/Description
- Package set optimized for the Linksys WRT400N.
-endef
-
-$(eval $(call Profile,WRT160NL))
-$(eval $(call Profile,WRT400N))
diff --git a/target/linux/ar71xx/profiles/netgear.mk b/target/linux/ar71xx/profiles/netgear.mk
deleted file mode 100644
index 8545cad0c6..0000000000
--- a/target/linux/ar71xx/profiles/netgear.mk
+++ /dev/null
@@ -1,17 +0,0 @@
-#
-# Copyright (C) 2009 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/WNDR3700
- NAME:=NETGEAR WNDR3700
- PACKAGES:=kmod-ath9k wpad-mini kmod-usb-core kmod-usb2
-endef
-
-define Profile/WNDR3700/Description
- Package set optimized for the NETGEAR WNDR3700
-endef
-
-$(eval $(call Profile,WNDR3700))
diff --git a/target/linux/ar71xx/profiles/planex.mk b/target/linux/ar71xx/profiles/planex.mk
deleted file mode 100644
index 63e539c4e4..0000000000
--- a/target/linux/ar71xx/profiles/planex.mk
+++ /dev/null
@@ -1,28 +0,0 @@
-#
-# Copyright (C) 2009 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/MZKW04NU
- NAME:=Planex MZK-W04NU
- PACKAGES:=kmod-ath9k wpad-mini kmod-usb-core kmod-usb2
-endef
-
-define Profile/MZKW04NU/Description
- Package set optimized for the Planex MZK-W04NU.
-endef
-
-$(eval $(call Profile,MZKW04NU))
-
-define Profile/MZKW300NH
- NAME:=Planex MZK-W300NH
- PACKAGES:=kmod-ath9k wpad-mini
-endef
-
-define Profile/MZKW300NH/Description
- Package set optimized for the Planex MZK-W300NH.
-endef
-
-$(eval $(call Profile,MZKW300NH))
diff --git a/target/linux/ar71xx/profiles/tp-link.mk b/target/linux/ar71xx/profiles/tp-link.mk
deleted file mode 100644
index 7efb1a3766..0000000000
--- a/target/linux/ar71xx/profiles/tp-link.mk
+++ /dev/null
@@ -1,94 +0,0 @@
-#
-# Copyright (C) 2009 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/TLWR741NDV1
- NAME:=TP-LINK TL-WR741ND v1
- PACKAGES:=kmod-ath9k wpad-mini
-endef
-
-define Profile/TLWR741NDV1/Description
- Package set optimized for the TP-LINK TL-WR741ND v1.
-endef
-
-$(eval $(call Profile,TLWR741NDV1))
-
-define Profile/TLWR841NV15
- NAME:=TP-LINK TL-WR841N v1.5
- PACKAGES:=kmod-ath9k wpad-mini
-endef
-
-define Profile/TLWR841NV15/Description
- Package set optimized for the TP-LINK TL-WR841N v1.5.
-endef
-
-$(eval $(call Profile,TLWR841NV15))
-
-define Profile/TLWR841NDV3
- NAME:=TP-LINK TL-WR841ND v3
- PACKAGES:=kmod-ath9k wpad-mini
-endef
-
-define Profile/TLWR841NDV3/Description
- Package set optimized for the TP-LINK TL-WR841ND v3.
-endef
-
-$(eval $(call Profile,TLWR841NDV3))
-
-define Profile/TLWR841NDV5
- NAME:=TP-LINK TL-WR841ND v5
- PACKAGES:=kmod-ath9k wpad-mini
-endef
-
-define Profile/TLWR841NDV5/Description
- Package set optimized for the TP-LINK TL-WR841ND v5.
-endef
-
-$(eval $(call Profile,TLWR841NDV5))
-
-define Profile/TLWR941NDV2
- NAME:=TP-LINK TL-WR941ND v2
- PACKAGES:=kmod-ath9k wpad-mini
-endef
-
-define Profile/TLWR941NDV2/Description
- Package set optimized for the TP-LINK TL-WR941ND v2.
-endef
-
-$(eval $(call Profile,TLWR941NDV2))
-
-define Profile/TLWR941NDV3
- NAME:=TP-LINK TL-WR941ND v3
- PACKAGES:=kmod-ath9k wpad-mini
-endef
-
-define Profile/TLWR941NDV3/Description
- Package set optimized for the TP-LINK TL-WR941ND v3.
-endef
-
-$(eval $(call Profile,TLWR941NDV3))
-
-define Profile/TLWR941NDV4
- NAME:=TP-LINK TL-WR941ND v4
- PACKAGES:=kmod-ath9k wpad-mini
-endef
-
-define Profile/TLWR941NDV4/Description
- Package set optimized for the TP-LINK TL-WR941ND v4.
-endef
-
-$(eval $(call Profile,TLWR941NDV4))
-
-define Profile/TLWR1043NDV1
- NAME:=TP-LINK TL-WR1043ND v1
- PACKAGES:=kmod-ath9k wpad-mini kmod-usb-core kmod-usb2
-endef
-
-define Profile/TLWR1043NDV1/Description
- Package set optimized for the TP-LINK TL-WR1043ND v1.
-endef
-
-$(eval $(call Profile,TLWR1043NDV1))
diff --git a/target/linux/ar71xx/profiles/trendnet.mk b/target/linux/ar71xx/profiles/trendnet.mk
deleted file mode 100644
index 20a08f3842..0000000000
--- a/target/linux/ar71xx/profiles/trendnet.mk
+++ /dev/null
@@ -1,28 +0,0 @@
-#
-# Copyright (C) 2009 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/TEW632BRP
- NAME:=TRENDNet TEW-632BRP
- PACKAGES:=kmod-ath9k wpad-mini
-endef
-
-define Profile/TEW632BRP/Description
- Package set optimized for the TRENDNet TEW-632BRP.
-endef
-
-$(eval $(call Profile,TEW632BRP))
-
-define Profile/TEW652BRP
- NAME:=TRENDNet TEW-652BRP
- PACKAGES:=kmod-ath9k
-endef
-
-define Profile/TEW652BRP/Description
- Package set optimized for the TRENDNet TEW-652BRP.
-endef
-
-$(eval $(call Profile,TEW652BRP))
diff --git a/target/linux/ar71xx/profiles/ubnt.mk b/target/linux/ar71xx/profiles/ubnt.mk
deleted file mode 100644
index a7fd9a2619..0000000000
--- a/target/linux/ar71xx/profiles/ubnt.mk
+++ /dev/null
@@ -1,39 +0,0 @@
-#
-# Copyright (C) 2009 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/UBNTRS
- NAME:=Ubiquiti RouterStation
- PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2
-endef
-
-define Profile/UBNTRS/Description
- Package set optimized for the Ubiquiti RouterStation.
-endef
-
-$(eval $(call Profile,UBNTRS))
-
-define Profile/UBNTRSPRO
- NAME:=Ubiquiti RouterStation Pro
- PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2
-endef
-
-define Profile/UBNTRSPRO/Description
- Package set optimized for the Ubiquiti RouterStation Pro.
-endef
-
-$(eval $(call Profile,UBNTRSPRO))
-
-define Profile/UBNT
- NAME:=Ubiquiti Products
- PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2
-endef
-
-define Profile/UBNT/Description
- Build images for all Ubiquiti products (including LS-SR71, RouterStation and RouterStation Pro)
-endef
-
-$(eval $(call Profile,UBNT))
diff --git a/target/linux/ar71xx/profiles/zyxel.mk b/target/linux/ar71xx/profiles/zyxel.mk
deleted file mode 100644
index 73ae4e224c..0000000000
--- a/target/linux/ar71xx/profiles/zyxel.mk
+++ /dev/null
@@ -1,17 +0,0 @@
-#
-# Copyright (C) 2009 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/NBG_460N_550N_550NH
- NAME:=Zyxel NBG 460N/550N/550NH
- PACKAGES:=kmod-ath9k swconfig
-endef
-
-define Profile/NBG_460N_550N_550NH/Description
- Package set optimized for the Zyxel NBG 460N/550N/550NH Routers.
-endef
-
-$(eval $(call Profile,NBG_460N_550N_550NH))