summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches/101-ksz8041_phy_driver.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2008-07-21 17:08:14 +0000
committerGabor Juhos <juhosg@openwrt.org>2008-07-21 17:08:14 +0000
commitf529a3742043a23da4f715c3664d5a822b1f970c (patch)
treea4cdaee84e23765d98072df25883f365cbc0d66a /target/linux/ar71xx/patches/101-ksz8041_phy_driver.patch
parent3d9c4c9073deaf01d592d6940af21be81d92e88a (diff)
downloadmaster-31e0f0ae-f529a3742043a23da4f715c3664d5a822b1f970c.tar.gz
master-31e0f0ae-f529a3742043a23da4f715c3664d5a822b1f970c.tar.bz2
master-31e0f0ae-f529a3742043a23da4f715c3664d5a822b1f970c.zip
surprise :p
SVN-Revision: 11894
Diffstat (limited to 'target/linux/ar71xx/patches/101-ksz8041_phy_driver.patch')
-rw-r--r--target/linux/ar71xx/patches/101-ksz8041_phy_driver.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches/101-ksz8041_phy_driver.patch b/target/linux/ar71xx/patches/101-ksz8041_phy_driver.patch
new file mode 100644
index 0000000000..9b69eca7cc
--- /dev/null
+++ b/target/linux/ar71xx/patches/101-ksz8041_phy_driver.patch
@@ -0,0 +1,23 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -76,6 +76,11 @@
+ ---help---
+ Currently supports the Marvell 88E6060 switch.
+
++config MICREL_PHY
++ tristate "Drivers for Micrel/Kendin PHYs"
++ ---help---
++ Currently has a driver for the KSZ8041
++
+ config FIXED_PHY
+ bool "Driver for MDIO Bus/PHY emulation with fixed speed/link PHYs"
+ depends on PHYLIB=y
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -15,5 +15,6 @@
+ obj-$(CONFIG_ADM6996_PHY) += adm6996.o
+ obj-$(CONFIG_MVSWITCH_PHY) += mvswitch.o
+ obj-$(CONFIG_REALTEK_PHY) += realtek.o
++obj-$(CONFIG_MICREL_PHY) += micrel.o
+ obj-$(CONFIG_FIXED_PHY) += fixed.o
+ obj-$(CONFIG_MDIO_BITBANG) += mdio-bitbang.o