summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-4.4/818-MIPS-ath79-add-nu801-led-driver.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2016-01-30 13:19:53 +0000
committerFelix Fietkau <nbd@openwrt.org>2016-01-30 13:19:53 +0000
commit2530640f07cd2b3b14fe9ec03fa63a586452cc5f (patch)
treeda4d0e63a6771cbd044d3ba8d8dc97bd0615920f /target/linux/ar71xx/patches-4.4/818-MIPS-ath79-add-nu801-led-driver.patch
parente5b5cce442f6fdaccf86064657518a5d0404f78e (diff)
downloadmaster-31e0f0ae-2530640f07cd2b3b14fe9ec03fa63a586452cc5f.tar.gz
master-31e0f0ae-2530640f07cd2b3b14fe9ec03fa63a586452cc5f.tar.bz2
master-31e0f0ae-2530640f07cd2b3b14fe9ec03fa63a586452cc5f.zip
ar71xx: add support for linux 4.4
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 48563
Diffstat (limited to 'target/linux/ar71xx/patches-4.4/818-MIPS-ath79-add-nu801-led-driver.patch')
-rw-r--r--target/linux/ar71xx/patches-4.4/818-MIPS-ath79-add-nu801-led-driver.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-4.4/818-MIPS-ath79-add-nu801-led-driver.patch b/target/linux/ar71xx/patches-4.4/818-MIPS-ath79-add-nu801-led-driver.patch
new file mode 100644
index 0000000000..ec9f59e3fe
--- /dev/null
+++ b/target/linux/ar71xx/patches-4.4/818-MIPS-ath79-add-nu801-led-driver.patch
@@ -0,0 +1,26 @@
+--- a/drivers/leds/Kconfig
++++ b/drivers/leds/Kconfig
+@@ -568,6 +568,13 @@ config LEDS_SEAD3
+
+ comment "LED driver for blink(1) USB RGB LED is under Special HID drivers (HID_THINGM)"
+
++config LEDS_NU801
++ tristate "LED driver for NU801 RGB LED"
++ depends on LEDS_CLASS && ATH79_MACH_MR18
++ help
++ This option enables support for NU801 RGB LED driver chips
++ accessed via GPIO.
++
+ config LEDS_BLINKM
+ tristate "LED support for the BlinkM I2C RGB LED"
+ depends on LEDS_CLASS
+--- a/drivers/leds/Makefile
++++ b/drivers/leds/Makefile
+@@ -55,6 +55,7 @@ obj-$(CONFIG_LEDS_ADP5520) += leds-adp5
+ obj-$(CONFIG_LEDS_DELL_NETBOOKS) += dell-led.o
+ obj-$(CONFIG_LEDS_MC13783) += leds-mc13783.o
+ obj-$(CONFIG_LEDS_RB750) += leds-rb750.o
++obj-$(CONFIG_LEDS_NU801) += leds-nu801.o
+ obj-$(CONFIG_LEDS_NS2) += leds-ns2.o
+ obj-$(CONFIG_LEDS_NETXBIG) += leds-netxbig.o
+ obj-$(CONFIG_LEDS_ASIC3) += leds-asic3.o