summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-4.1
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-12-11 15:04:57 +0000
committerJohn Crispin <john@openwrt.org>2015-12-11 15:04:57 +0000
commit1dada3fc3c08b9f7fe12219af238d408409c5fa1 (patch)
treee5f2c90dec102835c14656298e780bd1548e345d /target/linux/ar71xx/patches-4.1
parenteb8ff566848fce7c9d2c16c3eb7c22559a9fae0e (diff)
downloadmaster-31e0f0ae-1dada3fc3c08b9f7fe12219af238d408409c5fa1.tar.gz
master-31e0f0ae-1dada3fc3c08b9f7fe12219af238d408409c5fa1.tar.bz2
master-31e0f0ae-1dada3fc3c08b9f7fe12219af238d408409c5fa1.zip
ar71xx: add LED driver NU801
The MR18 uses a 3-channel 16-bit PWM Constant Current Driver for its status LED. Signed-off-by: Chris R Blake <chrisrblake93@gmail.com> SVN-Revision: 47848
Diffstat (limited to 'target/linux/ar71xx/patches-4.1')
-rw-r--r--target/linux/ar71xx/patches-4.1/818-MIPS-ath79-add-nu801-led-driver.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-4.1/818-MIPS-ath79-add-nu801-led-driver.patch b/target/linux/ar71xx/patches-4.1/818-MIPS-ath79-add-nu801-led-driver.patch
new file mode 100644
index 0000000000..562388d104
--- /dev/null
+++ b/target/linux/ar71xx/patches-4.1/818-MIPS-ath79-add-nu801-led-driver.patch
@@ -0,0 +1,26 @@
+--- a/drivers/leds/Kconfig
++++ b/drivers/leds/Kconfig
+@@ -500,6 +500,13 @@ config LEDS_MENF21BMC
+
+ comment "LED driver for blink(1) USB RGB LED is under Special HID drivers (HID_THINGM)"
+
++config LEDS_NU801
++ tristate "LED driver for NU801 RGB LED"
++ depends on LEDS_CLASS && ATH79_MACH_MR18
++ help
++ This option enables support for NU801 RGB LED driver chips
++ accessed via GPIO.
++
+ config LEDS_BLINKM
+ tristate "LED support for the BlinkM I2C RGB LED"
+ depends on LEDS_CLASS
+--- a/drivers/leds/Makefile
++++ b/drivers/leds/Makefile
+@@ -51,6 +51,7 @@ obj-$(CONFIG_LEDS_ADP5520) += leds-adp5
+ obj-$(CONFIG_LEDS_DELL_NETBOOKS) += dell-led.o
+ obj-$(CONFIG_LEDS_MC13783) += leds-mc13783.o
+ obj-$(CONFIG_LEDS_RB750) += leds-rb750.o
++obj-$(CONFIG_LEDS_NU801) += leds-nu801.o
+ obj-$(CONFIG_LEDS_NS2) += leds-ns2.o
+ obj-$(CONFIG_LEDS_NETXBIG) += leds-netxbig.o
+ obj-$(CONFIG_LEDS_ASIC3) += leds-asic3.o