summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-3.8/620-MIPS-ath79-add-Archer-C7-support.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-05-30 16:23:07 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-05-30 16:23:07 +0000
commit91d7c3efc1977ef862d6ab7e3695ee30ddf5c5a2 (patch)
treebcca83b1e4fd0db449d6a23ece243ef6e7fdb0b1 /target/linux/ar71xx/patches-3.8/620-MIPS-ath79-add-Archer-C7-support.patch
parentf02765086dbb51df6dc24942cd2d5cc02db77af6 (diff)
downloadmaster-31e0f0ae-91d7c3efc1977ef862d6ab7e3695ee30ddf5c5a2.tar.gz
master-31e0f0ae-91d7c3efc1977ef862d6ab7e3695ee30ddf5c5a2.tar.bz2
master-31e0f0ae-91d7c3efc1977ef862d6ab7e3695ee30ddf5c5a2.zip
ar71xx: add kernel support for the TP-LINK Archer C7 board
Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 36788
Diffstat (limited to 'target/linux/ar71xx/patches-3.8/620-MIPS-ath79-add-Archer-C7-support.patch')
-rw-r--r--target/linux/ar71xx/patches-3.8/620-MIPS-ath79-add-Archer-C7-support.patch39
1 files changed, 39 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-3.8/620-MIPS-ath79-add-Archer-C7-support.patch b/target/linux/ar71xx/patches-3.8/620-MIPS-ath79-add-Archer-C7-support.patch
new file mode 100644
index 0000000000..5628e984c9
--- /dev/null
+++ b/target/linux/ar71xx/patches-3.8/620-MIPS-ath79-add-Archer-C7-support.patch
@@ -0,0 +1,39 @@
+--- a/arch/mips/ath79/Kconfig
++++ b/arch/mips/ath79/Kconfig
+@@ -495,6 +495,16 @@ config ATH79_MACH_EAP7660D
+ select ATH79_DEV_LEDS_GPIO
+ select ATH79_DEV_M25P80
+
++config ATH79_MACH_ARCHER_C7
++ bool "TP-LINK Archer C7 board support"
++ select SOC_QCA955X
++ select ATH79_DEV_ETH
++ select ATH79_DEV_GPIO_BUTTONS
++ select ATH79_DEV_LEDS_GPIO
++ select ATH79_DEV_SPI
++ select ATH79_DEV_USB
++ select ATH79_DEV_WMAC
++
+ config ATH79_MACH_TL_MR11U
+ bool "TP-LINK TL-MR11U/TL-MR3040 support"
+ select SOC_AR933X
+--- a/arch/mips/ath79/machtypes.h
++++ b/arch/mips/ath79/machtypes.h
+@@ -31,6 +31,7 @@ enum ath79_mach_type {
+ ATH79_MACH_AP81, /* Atheros AP81 reference board */
+ ATH79_MACH_AP83, /* Atheros AP83 */
+ ATH79_MACH_AP96, /* Atheros AP96 */
++ ATH79_MACH_ARCHER_C7, /* TP-LINK Archer C7 board */
+ ATH79_MACH_AW_NR580, /* AzureWave AW-NR580 */
+ ATH79_MACH_CAP4200AG, /* Senao CAP4200AG */
+ ATH79_MACH_DB120, /* Atheros DB120 reference board */
+--- a/arch/mips/ath79/Makefile
++++ b/arch/mips/ath79/Makefile
+@@ -49,6 +49,7 @@ obj-$(CONFIG_ATH79_MACH_AP136) += mach-
+ obj-$(CONFIG_ATH79_MACH_AP81) += mach-ap81.o
+ obj-$(CONFIG_ATH79_MACH_AP83) += mach-ap83.o
+ obj-$(CONFIG_ATH79_MACH_AP96) += mach-ap96.o
++obj-$(CONFIG_ATH79_MACH_ARCHER_C7) += mach-archer-c7.o
+ obj-$(CONFIG_ATH79_MACH_AW_NR580) += mach-aw-nr580.o
+ obj-$(CONFIG_ATH79_MACH_CAP4200AG) += mach-cap4200ag.o
+ obj-$(CONFIG_ATH79_MACH_DB120) += mach-db120.o