summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-3.8/433-spi-rb4xx-cpld-driver.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-02-21 17:47:15 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-02-21 17:47:15 +0000
commitcf2324fd6b6752ce511b612fc192ab9f0b6a32cb (patch)
tree4f94e8ab5c7b998cb84115489594f670957f3d4b /target/linux/ar71xx/patches-3.8/433-spi-rb4xx-cpld-driver.patch
parent9cc3a60b5a6988759532b63a6fb513484b8ec9f9 (diff)
downloadmaster-31e0f0ae-cf2324fd6b6752ce511b612fc192ab9f0b6a32cb.tar.gz
master-31e0f0ae-cf2324fd6b6752ce511b612fc192ab9f0b6a32cb.tar.bz2
master-31e0f0ae-cf2324fd6b6752ce511b612fc192ab9f0b6a32cb.zip
ar71xx: add support for 3.8
Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 35728
Diffstat (limited to 'target/linux/ar71xx/patches-3.8/433-spi-rb4xx-cpld-driver.patch')
-rw-r--r--target/linux/ar71xx/patches-3.8/433-spi-rb4xx-cpld-driver.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-3.8/433-spi-rb4xx-cpld-driver.patch b/target/linux/ar71xx/patches-3.8/433-spi-rb4xx-cpld-driver.patch
new file mode 100644
index 0000000000..8fb9fa59da
--- /dev/null
+++ b/target/linux/ar71xx/patches-3.8/433-spi-rb4xx-cpld-driver.patch
@@ -0,0 +1,26 @@
+--- a/drivers/spi/Kconfig
++++ b/drivers/spi/Kconfig
+@@ -509,6 +509,13 @@ config SPI_TLE62X0
+ sysfs interface, with each line presented as a kind of GPIO
+ exposing both switch control and diagnostic feedback.
+
++config SPI_RB4XX_CPLD
++ tristate "MikroTik RB4XX CPLD driver"
++ depends on ATH79_MACH_RB4XX
++ help
++ SPI driver for the Xilinx CPLD chip present on the
++ MikroTik RB4xx boards.
++
+ #
+ # Add new SPI protocol masters in alphabetical order above this line
+ #
+--- a/drivers/spi/Makefile
++++ b/drivers/spi/Makefile
+@@ -51,6 +51,7 @@ obj-$(CONFIG_SPI_PPC4xx) += spi-ppc4xx.
+ obj-$(CONFIG_SPI_PXA2XX) += spi-pxa2xx.o
+ obj-$(CONFIG_SPI_PXA2XX_PCI) += spi-pxa2xx-pci.o
+ obj-$(CONFIG_SPI_RB4XX) += spi-rb4xx.o
++obj-$(CONFIG_SPI_RB4XX_CPLD) += spi-rb4xx-cpld.o
+ obj-$(CONFIG_SPI_RSPI) += spi-rspi.o
+ obj-$(CONFIG_SPI_S3C24XX) += spi-s3c24xx-hw.o
+ spi-s3c24xx-hw-y := spi-s3c24xx.o