summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-3.8/413-mtd-ar934x-nand-driver.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-02-21 17:47:15 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-02-21 17:47:15 +0000
commitcf2324fd6b6752ce511b612fc192ab9f0b6a32cb (patch)
tree4f94e8ab5c7b998cb84115489594f670957f3d4b /target/linux/ar71xx/patches-3.8/413-mtd-ar934x-nand-driver.patch
parent9cc3a60b5a6988759532b63a6fb513484b8ec9f9 (diff)
downloadmaster-31e0f0ae-cf2324fd6b6752ce511b612fc192ab9f0b6a32cb.tar.gz
master-31e0f0ae-cf2324fd6b6752ce511b612fc192ab9f0b6a32cb.tar.bz2
master-31e0f0ae-cf2324fd6b6752ce511b612fc192ab9f0b6a32cb.zip
ar71xx: add support for 3.8
Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 35728
Diffstat (limited to 'target/linux/ar71xx/patches-3.8/413-mtd-ar934x-nand-driver.patch')
-rw-r--r--target/linux/ar71xx/patches-3.8/413-mtd-ar934x-nand-driver.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-3.8/413-mtd-ar934x-nand-driver.patch b/target/linux/ar71xx/patches-3.8/413-mtd-ar934x-nand-driver.patch
new file mode 100644
index 0000000000..f8362cbcba
--- /dev/null
+++ b/target/linux/ar71xx/patches-3.8/413-mtd-ar934x-nand-driver.patch
@@ -0,0 +1,21 @@
+--- a/drivers/mtd/nand/Kconfig
++++ b/drivers/mtd/nand/Kconfig
+@@ -583,4 +583,8 @@ config MTD_NAND_RB750
+ tristate "NAND flash driver for the RouterBoard 750"
+ depends on MTD_NAND && ATH79_MACH_RB750
+
++config MTD_NAND_AR934X
++ tristate "NAND flash driver for the Qualcomm Atheros AR934x/QCA955x SoCs"
++ depends on (SOC_AR934X || SOC_QCA955X)
++
+ endif # MTD_NAND
+--- a/drivers/mtd/nand/Makefile
++++ b/drivers/mtd/nand/Makefile
+@@ -13,6 +13,7 @@ obj-$(CONFIG_MTD_NAND_AMS_DELTA) += ams-
+ obj-$(CONFIG_MTD_NAND_DENALI) += denali.o
+ obj-$(CONFIG_MTD_NAND_DENALI_PCI) += denali_pci.o
+ obj-$(CONFIG_MTD_NAND_DENALI_DT) += denali_dt.o
++obj-$(CONFIG_MTD_NAND_AR934X) += ar934x_nfc.o
+ obj-$(CONFIG_MTD_NAND_AU1550) += au1550nd.o
+ obj-$(CONFIG_MTD_NAND_BF5XX) += bf5xx_nand.o
+ obj-$(CONFIG_MTD_NAND_PPCHAMELEONEVB) += ppchameleonevb.o