summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-3.7
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-02-17 10:08:35 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-02-17 10:08:35 +0000
commit7a709573d741364d0ace010b2794ee21edc4d0ab (patch)
tree5497c27def2884a4be0f5a825190b40ada63727b /target/linux/ar71xx/patches-3.7
parent1a8218d6e4f770c026149a836f93fe9f9e2b4a4f (diff)
downloadmaster-31e0f0ae-7a709573d741364d0ace010b2794ee21edc4d0ab.tar.gz
master-31e0f0ae-7a709573d741364d0ace010b2794ee21edc4d0ab.tar.bz2
master-31e0f0ae-7a709573d741364d0ace010b2794ee21edc4d0ab.zip
ar71xx: add kernel support for the Mikrotik RB951G board
This is platform definition for the RB951G device. It's mostly rework of RB2011UAS patchset with network taken from the RB751 patches. The main difference is the flash layout used by this device. [juhosg: - remove dead code from mach-rb951g - add "-2HnD" suffix to the machine name - use a separate 615-MIPS-ath79-RB951G-support.patch] Patchwork: http://patchwork.openwrt.org/patch/3257/ Signed-off-by: Kamil Trzcinski <ayufan@ayufan.eu> Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 35633
Diffstat (limited to 'target/linux/ar71xx/patches-3.7')
-rw-r--r--target/linux/ar71xx/patches-3.7/615-MIPS-ath79-RB951G-support.patch49
1 files changed, 49 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-3.7/615-MIPS-ath79-RB951G-support.patch b/target/linux/ar71xx/patches-3.7/615-MIPS-ath79-RB951G-support.patch
new file mode 100644
index 0000000000..e679717366
--- /dev/null
+++ b/target/linux/ar71xx/patches-3.7/615-MIPS-ath79-RB951G-support.patch
@@ -0,0 +1,49 @@
+--- a/arch/mips/ath79/machtypes.h
++++ b/arch/mips/ath79/machtypes.h
+@@ -70,6 +70,7 @@ enum ath79_mach_type {
+ ATH79_MACH_RB_750G_R3, /* MikroTik RouterBOARD 750GL */
+ ATH79_MACH_RB_751, /* MikroTik RouterBOARD 751 */
+ ATH79_MACH_RB_751G, /* Mikrotik RouterBOARD 751G */
++ ATH79_MACH_RB_951G, /* Mikrotik RouterBOARD 951G */
+ ATH79_MACH_RB_2011G, /* Mikrotik RouterBOARD 2011UAS-2HnD */
+ ATH79_MACH_RB_2011L, /* Mikrotik RouterBOARD 2011L */
+ ATH79_MACH_RW2458N, /* Redwave RW2458N */
+--- a/arch/mips/ath79/Kconfig
++++ b/arch/mips/ath79/Kconfig
+@@ -360,6 +360,16 @@ config ATH79_MACH_RB750
+ select ATH79_ROUTERBOOT
+ select RLE_DECOMPRESS
+
++config ATH79_MACH_RB95X
++ bool "MikroTik RouterBOARD 95X support"
++ select SOC_AR934x
++ select ATH79_DEV_ETH
++ select ATH79_DEV_NFC
++ select ATH79_DEV_WMAC
++ select ATH79_DEV_USB
++ select ATH79_ROUTERBOOT
++ select RLE_DECOMPRESS
++
+ config ATH79_MACH_RB2011
+ bool "MikroTik RouterBOARD 2011 support"
+ select SOC_AR934x
+--- a/arch/mips/ath79/Makefile
++++ b/arch/mips/ath79/Makefile
+@@ -71,6 +71,7 @@ obj-$(CONFIG_ATH79_MACH_PB44) += mach-p
+ obj-$(CONFIG_ATH79_MACH_PB92) += mach-pb92.o
+ obj-$(CONFIG_ATH79_MACH_RB4XX) += mach-rb4xx.o
+ obj-$(CONFIG_ATH79_MACH_RB750) += mach-rb750.o
++obj-$(CONFIG_ATH79_MACH_RB95X) += mach-rb95x.o
+ obj-$(CONFIG_ATH79_MACH_RB2011) += mach-rb2011.o
+ obj-$(CONFIG_ATH79_MACH_RW2458N) += mach-rw2458n.o
+ obj-$(CONFIG_ATH79_MACH_TEW_632BRP) += mach-tew-632brp.o
+--- a/arch/mips/ath79/prom.c
++++ b/arch/mips/ath79/prom.c
+@@ -182,6 +182,7 @@ void __init prom_init(void)
+ }
+
+ if (strstr(arcs_cmdline, "board=750Gr3") ||
++ strstr(arcs_cmdline, "board=951G") ||
+ strstr(arcs_cmdline, "board=2011L"))
+ ath79_prom_append_cmdline("console", "ttyS0,115200");
+ }