summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-3.7/613-MIPS-ath79-add-TL-WDR3500-support.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-02-01 15:50:29 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-02-01 15:50:29 +0000
commit5bd02ca895b989774c50def5cc92f1429f833479 (patch)
tree47be42741503a734607ab9559a2a03202c7ee83a /target/linux/ar71xx/patches-3.7/613-MIPS-ath79-add-TL-WDR3500-support.patch
parente2193a69c83506ceaddefb2fd3f175059e1b5bcc (diff)
downloadmaster-31e0f0ae-5bd02ca895b989774c50def5cc92f1429f833479.tar.gz
master-31e0f0ae-5bd02ca895b989774c50def5cc92f1429f833479.tar.bz2
master-31e0f0ae-5bd02ca895b989774c50def5cc92f1429f833479.zip
ar71xx: add kernel support for the TL-WDR3500 board
WDR3500 is similar to WDR3600 except it doesn't have gigabit ethernet, and has only 1 USB port. Pending issues: * Leds are not working at all (except power and wlan_5g) * LAN switch ethernet ports are reversed with respect to case label. [Label] -> soft device [LAN1] -> eth0.4 [LAN2] -> eth0.3 [LAN3] -> eth0.2 [LAN4] -> eth0.1 Based on http://patchwork.openwrt.org/patch/3208/ Thanks-to: Paul Fertser <fercerpav@gmail.com> Signed-off-by: Gui Iribarren <gui@altermundi.net> Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 35423
Diffstat (limited to 'target/linux/ar71xx/patches-3.7/613-MIPS-ath79-add-TL-WDR3500-support.patch')
-rw-r--r--target/linux/ar71xx/patches-3.7/613-MIPS-ath79-add-TL-WDR3500-support.patch40
1 files changed, 40 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-3.7/613-MIPS-ath79-add-TL-WDR3500-support.patch b/target/linux/ar71xx/patches-3.7/613-MIPS-ath79-add-TL-WDR3500-support.patch
new file mode 100644
index 0000000000..0a2c3bda51
--- /dev/null
+++ b/target/linux/ar71xx/patches-3.7/613-MIPS-ath79-add-TL-WDR3500-support.patch
@@ -0,0 +1,40 @@
+--- a/arch/mips/ath79/machtypes.h
++++ b/arch/mips/ath79/machtypes.h
+@@ -84,6 +84,7 @@ enum ath79_mach_type {
+ ATH79_MACH_TL_WA7510N_V1, /* TP-LINK TL-WA7510N v1*/
+ ATH79_MACH_TL_WA901ND, /* TP-LINK TL-WA901ND */
+ ATH79_MACH_TL_WA901ND_V2, /* TP-LINK TL-WA901ND v2 */
++ ATH79_MACH_TL_WDR3500, /* TP-LINK TL-WDR3500 */
+ ATH79_MACH_TL_WDR4300, /* TP-LINK TL-WDR4300 */
+ ATH79_MACH_TL_WR1041N_V2, /* TP-LINK TL-WR1041N v2 */
+ ATH79_MACH_TL_WR1043ND, /* TP-LINK TL-WR1043ND */
+--- a/arch/mips/ath79/Kconfig
++++ b/arch/mips/ath79/Kconfig
+@@ -514,6 +514,17 @@ config ATH79_MACH_TL_WA901ND_V2
+ select ATH79_DEV_M25P80
+ select ATH79_DEV_WMAC
+
++config ATH79_MACH_TL_WDR3500
++ bool "TP-LINK TL-WDR3500 board support"
++ select SOC_AR934X
++ select ATH79_DEV_AP9X_PCI if PCI
++ select ATH79_DEV_ETH
++ select ATH79_DEV_GPIO_BUTTONS
++ select ATH79_DEV_LEDS_GPIO
++ select ATH79_DEV_M25P80
++ select ATH79_DEV_USB
++ select ATH79_DEV_WMAC
++
+ config ATH79_MACH_TL_WDR4300
+ bool "TP-LINK TL-WDR3600/4300/4310 board support"
+ select SOC_AR934X
+--- a/arch/mips/ath79/Makefile
++++ b/arch/mips/ath79/Makefile
+@@ -81,6 +81,7 @@ obj-$(CONFIG_ATH79_MACH_TL_MR3020) += ma
+ obj-$(CONFIG_ATH79_MACH_TL_MR3X20) += mach-tl-mr3x20.o
+ obj-$(CONFIG_ATH79_MACH_TL_WA901ND) += mach-tl-wa901nd.o
+ obj-$(CONFIG_ATH79_MACH_TL_WA901ND_V2) += mach-tl-wa901nd-v2.o
++obj-$(CONFIG_ATH79_MACH_TL_WDR3500) += mach-tl-wdr3500.o
+ obj-$(CONFIG_ATH79_MACH_TL_WDR4300) += mach-tl-wdr4300.o
+ obj-$(CONFIG_ATH79_MACH_TL_WR741ND) += mach-tl-wr741nd.o
+ obj-$(CONFIG_ATH79_MACH_TL_WR741ND_V4) += mach-tl-wr741nd-v4.o