summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-3.7/440-leds-wndr3700-usb-led-driver.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-12-29 16:02:31 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-12-29 16:02:31 +0000
commit87271e9f28796debd156da0b2466bc286ccbac0f (patch)
treef155ac33958d33a2f945aa9835c1e68a0d1619f4 /target/linux/ar71xx/patches-3.7/440-leds-wndr3700-usb-led-driver.patch
parenta3a6e0f0396714106c8942c89a55179213d85726 (diff)
downloadmaster-31e0f0ae-87271e9f28796debd156da0b2466bc286ccbac0f.tar.gz
master-31e0f0ae-87271e9f28796debd156da0b2466bc286ccbac0f.tar.bz2
master-31e0f0ae-87271e9f28796debd156da0b2466bc286ccbac0f.zip
ar71xx: add support for 3.7
Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 34920
Diffstat (limited to 'target/linux/ar71xx/patches-3.7/440-leds-wndr3700-usb-led-driver.patch')
-rw-r--r--target/linux/ar71xx/patches-3.7/440-leds-wndr3700-usb-led-driver.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-3.7/440-leds-wndr3700-usb-led-driver.patch b/target/linux/ar71xx/patches-3.7/440-leds-wndr3700-usb-led-driver.patch
new file mode 100644
index 0000000000..07093de545
--- /dev/null
+++ b/target/linux/ar71xx/patches-3.7/440-leds-wndr3700-usb-led-driver.patch
@@ -0,0 +1,26 @@
+--- a/drivers/leds/Kconfig
++++ b/drivers/leds/Kconfig
+@@ -465,6 +465,13 @@ config LEDS_TRIGGERS
+ These triggers allow kernel events to drive the LEDs and can
+ be configured via sysfs. If unsure, say Y.
+
++config LEDS_WNDR3700_USB
++ tristate "NETGEAR WNDR3700 USB LED driver"
++ depends on LEDS_CLASS && ATH79_MACH_WNDR3700
++ help
++ This option enables support for the USB LED found on the
++ NETGEAR WNDR3700 board.
++
+ comment "LED Triggers"
+
+ config LEDS_TRIGGER_TIMER
+--- a/drivers/leds/Makefile
++++ b/drivers/leds/Makefile
+@@ -38,6 +38,7 @@ obj-$(CONFIG_LEDS_DA9052) += leds-da905
+ obj-$(CONFIG_LEDS_WM831X_STATUS) += leds-wm831x-status.o
+ obj-$(CONFIG_LEDS_WM8350) += leds-wm8350.o
+ obj-$(CONFIG_LEDS_PWM) += leds-pwm.o
++obj-${CONFIG_LEDS_WNDR3700_USB} += leds-wndr3700-usb.o
+ obj-$(CONFIG_LEDS_REGULATOR) += leds-regulator.o
+ obj-$(CONFIG_LEDS_INTEL_SS4200) += leds-ss4200.o
+ obj-$(CONFIG_LEDS_LT3593) += leds-lt3593.o