summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-3.7/420-net-ar71xx_mac_driver.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-12-29 16:02:31 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-12-29 16:02:31 +0000
commit87271e9f28796debd156da0b2466bc286ccbac0f (patch)
treef155ac33958d33a2f945aa9835c1e68a0d1619f4 /target/linux/ar71xx/patches-3.7/420-net-ar71xx_mac_driver.patch
parenta3a6e0f0396714106c8942c89a55179213d85726 (diff)
downloadmaster-31e0f0ae-87271e9f28796debd156da0b2466bc286ccbac0f.tar.gz
master-31e0f0ae-87271e9f28796debd156da0b2466bc286ccbac0f.tar.bz2
master-31e0f0ae-87271e9f28796debd156da0b2466bc286ccbac0f.zip
ar71xx: add support for 3.7
Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 34920
Diffstat (limited to 'target/linux/ar71xx/patches-3.7/420-net-ar71xx_mac_driver.patch')
-rw-r--r--target/linux/ar71xx/patches-3.7/420-net-ar71xx_mac_driver.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-3.7/420-net-ar71xx_mac_driver.patch b/target/linux/ar71xx/patches-3.7/420-net-ar71xx_mac_driver.patch
new file mode 100644
index 0000000000..f117133169
--- /dev/null
+++ b/target/linux/ar71xx/patches-3.7/420-net-ar71xx_mac_driver.patch
@@ -0,0 +1,28 @@
+--- a/drivers/net/ethernet/atheros/Kconfig
++++ b/drivers/net/ethernet/atheros/Kconfig
+@@ -5,7 +5,7 @@
+ config NET_VENDOR_ATHEROS
+ bool "Atheros devices"
+ default y
+- depends on PCI
++ depends on (PCI || ATH79)
+ ---help---
+ If you have a network (Ethernet) card belonging to this class, say Y
+ and read the Ethernet-HOWTO, available from
+@@ -67,4 +67,6 @@ config ATL1C
+ To compile this driver as a module, choose M here. The module
+ will be called atl1c.
+
++source drivers/net/ethernet/atheros/ag71xx/Kconfig
++
+ endif # NET_VENDOR_ATHEROS
+--- a/drivers/net/ethernet/atheros/Makefile
++++ b/drivers/net/ethernet/atheros/Makefile
+@@ -2,6 +2,7 @@
+ # Makefile for the Atheros network device drivers.
+ #
+
++obj-$(CONFIG_AG71XX) += ag71xx/
+ obj-$(CONFIG_ATL1) += atlx/
+ obj-$(CONFIG_ATL2) += atlx/
+ obj-$(CONFIG_ATL1E) += atl1e/