summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-3.6/423-dsa-add-88e6063-driver.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-10-28 19:52:02 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-10-28 19:52:02 +0000
commite4db63fd64b1716715ac7289dc6f1fc48593d4af (patch)
treec5493128b26209a31354c173a6c020f4cbf37ef6 /target/linux/ar71xx/patches-3.6/423-dsa-add-88e6063-driver.patch
parent87186c5ed4681ba9830c072f4487e206147c973d (diff)
downloadmaster-31e0f0ae-e4db63fd64b1716715ac7289dc6f1fc48593d4af.tar.gz
master-31e0f0ae-e4db63fd64b1716715ac7289dc6f1fc48593d4af.tar.bz2
master-31e0f0ae-e4db63fd64b1716715ac7289dc6f1fc48593d4af.zip
ar71xx: add initial support for 3.6
The nand subtarget is not working yet. Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 33983
Diffstat (limited to 'target/linux/ar71xx/patches-3.6/423-dsa-add-88e6063-driver.patch')
-rw-r--r--target/linux/ar71xx/patches-3.6/423-dsa-add-88e6063-driver.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-3.6/423-dsa-add-88e6063-driver.patch b/target/linux/ar71xx/patches-3.6/423-dsa-add-88e6063-driver.patch
new file mode 100644
index 0000000000..bfb0b8e75c
--- /dev/null
+++ b/target/linux/ar71xx/patches-3.6/423-dsa-add-88e6063-driver.patch
@@ -0,0 +1,24 @@
+--- a/drivers/net/dsa/Kconfig
++++ b/drivers/net/dsa/Kconfig
+@@ -12,6 +12,13 @@ config NET_DSA_MV88E6060
+ This enables support for the Marvell 88E6060 ethernet switch
+ chip.
+
++config NET_DSA_MV88E6063
++ bool "Marvell 88E6063 ethernet switch chip support"
++ select NET_DSA_TAG_TRAILER
++ ---help---
++ This enables support for the Marvell 88E6063 ethernet switch
++ chip
++
+ config NET_DSA_MV88E6XXX_NEED_PPU
+ bool
+ default n
+--- a/drivers/net/dsa/Makefile
++++ b/drivers/net/dsa/Makefile
+@@ -1,4 +1,5 @@
+ obj-$(CONFIG_NET_DSA_MV88E6060) += mv88e6060.o
++obj-$(CONFIG_NET_DSA_MV88E6063) += mv88e6063.o
+ obj-$(CONFIG_NET_DSA_MV88E6XXX) += mv88e6xxx_drv.o
+ mv88e6xxx_drv-y += mv88e6xxx.o
+ ifdef CONFIG_NET_DSA_MV88E6123_61_65