summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-3.6/413-mtd-ar934x-nand-driver.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-10-28 19:52:02 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-10-28 19:52:02 +0000
commite4db63fd64b1716715ac7289dc6f1fc48593d4af (patch)
treec5493128b26209a31354c173a6c020f4cbf37ef6 /target/linux/ar71xx/patches-3.6/413-mtd-ar934x-nand-driver.patch
parent87186c5ed4681ba9830c072f4487e206147c973d (diff)
downloadmaster-31e0f0ae-e4db63fd64b1716715ac7289dc6f1fc48593d4af.tar.gz
master-31e0f0ae-e4db63fd64b1716715ac7289dc6f1fc48593d4af.tar.bz2
master-31e0f0ae-e4db63fd64b1716715ac7289dc6f1fc48593d4af.zip
ar71xx: add initial support for 3.6
The nand subtarget is not working yet. Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 33983
Diffstat (limited to 'target/linux/ar71xx/patches-3.6/413-mtd-ar934x-nand-driver.patch')
-rw-r--r--target/linux/ar71xx/patches-3.6/413-mtd-ar934x-nand-driver.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-3.6/413-mtd-ar934x-nand-driver.patch b/target/linux/ar71xx/patches-3.6/413-mtd-ar934x-nand-driver.patch
new file mode 100644
index 0000000000..ba9b511d27
--- /dev/null
+++ b/target/linux/ar71xx/patches-3.6/413-mtd-ar934x-nand-driver.patch
@@ -0,0 +1,21 @@
+--- a/drivers/mtd/nand/Kconfig
++++ b/drivers/mtd/nand/Kconfig
+@@ -615,4 +615,8 @@ config MTD_NAND_RB750
+ tristate "NAND flash driver for the RouterBoard 750"
+ depends on MTD_NAND && ATH79_MACH_RB750
+
++config MTD_NAND_AR934X
++ tristate "NAND flash driver for the Atheros AR934x SoCs"
++ depends on SOC_AR934X
++
+ endif # MTD_NAND
+--- a/drivers/mtd/nand/Makefile
++++ b/drivers/mtd/nand/Makefile
+@@ -11,6 +11,7 @@ obj-$(CONFIG_MTD_SM_COMMON) += sm_comm
+ obj-$(CONFIG_MTD_NAND_CAFE) += cafe_nand.o
+ obj-$(CONFIG_MTD_NAND_SPIA) += spia.o
+ obj-$(CONFIG_MTD_NAND_AMS_DELTA) += ams-delta.o
++obj-$(CONFIG_MTD_NAND_AR934X) += ar934x_nfc.o
+ obj-$(CONFIG_MTD_NAND_AUTCPU12) += autcpu12.o
+ obj-$(CONFIG_MTD_NAND_DENALI) += denali.o
+ obj-$(CONFIG_MTD_NAND_AU1550) += au1550nd.o