summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-3.18/602-MIPS-ath79-add-openwrt-stuff.patch
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-02-15 19:45:29 +0000
committerJohn Crispin <john@openwrt.org>2015-02-15 19:45:29 +0000
commit7e4b3de2493f024432935e283f5eeb2920957871 (patch)
tree10524efa8132ebe05e93a75a10ef3ca733edea0e /target/linux/ar71xx/patches-3.18/602-MIPS-ath79-add-openwrt-stuff.patch
parent9b1c7a9de4a2734b701660a9f3720e842626aea3 (diff)
downloadmaster-31e0f0ae-7e4b3de2493f024432935e283f5eeb2920957871.tar.gz
master-31e0f0ae-7e4b3de2493f024432935e283f5eeb2920957871.tar.bz2
master-31e0f0ae-7e4b3de2493f024432935e283f5eeb2920957871.zip
ar71xx: add v3.18 support
Signed-off-by: John Crispin <blogic@openwrt.org> SVN-Revision: 44456
Diffstat (limited to 'target/linux/ar71xx/patches-3.18/602-MIPS-ath79-add-openwrt-stuff.patch')
-rw-r--r--target/linux/ar71xx/patches-3.18/602-MIPS-ath79-add-openwrt-stuff.patch76
1 files changed, 76 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-3.18/602-MIPS-ath79-add-openwrt-stuff.patch b/target/linux/ar71xx/patches-3.18/602-MIPS-ath79-add-openwrt-stuff.patch
new file mode 100644
index 0000000000..a772d9b6e6
--- /dev/null
+++ b/target/linux/ar71xx/patches-3.18/602-MIPS-ath79-add-openwrt-stuff.patch
@@ -0,0 +1,76 @@
+--- a/arch/mips/ath79/Kconfig
++++ b/arch/mips/ath79/Kconfig
+@@ -98,6 +98,20 @@ config SOC_QCA955X
+ select PCI_AR724X if PCI
+ def_bool n
+
++config ATH79_DEV_M25P80
++ select ATH79_DEV_SPI
++ def_bool n
++
++config ATH79_DEV_AP9X_PCI
++ select ATH79_PCI_ATH9K_FIXUP
++ def_bool n
++
++config ATH79_DEV_DSA
++ def_bool n
++
++config ATH79_DEV_ETH
++ def_bool n
++
+ config PCI_AR724X
+ def_bool n
+
+@@ -107,6 +121,10 @@ config ATH79_DEV_GPIO_BUTTONS
+ config ATH79_DEV_LEDS_GPIO
+ def_bool n
+
++config ATH79_DEV_NFC
++ depends on (SOC_AR934X || SOC_QCA955X)
++ def_bool n
++
+ config ATH79_DEV_SPI
+ def_bool n
+
+@@ -117,4 +135,13 @@ config ATH79_DEV_WMAC
+ depends on (SOC_AR913X || SOC_AR933X || SOC_AR934X || SOC_QCA955X)
+ def_bool n
+
++config ATH79_NVRAM
++ def_bool n
++
++config ATH79_PCI_ATH9K_FIXUP
++ def_bool n
++
++config ATH79_ROUTERBOOT
++ def_bool n
++
+ endif
+--- a/arch/mips/ath79/Makefile
++++ b/arch/mips/ath79/Makefile
+@@ -17,13 +17,25 @@ obj-$(CONFIG_PCI) += pci.o
+ # Devices
+ #
+ obj-y += dev-common.o
++obj-$(CONFIG_ATH79_DEV_AP9X_PCI) += dev-ap9x-pci.o
++obj-$(CONFIG_ATH79_DEV_DSA) += dev-dsa.o
++obj-$(CONFIG_ATH79_DEV_ETH) += dev-eth.o
+ obj-$(CONFIG_ATH79_DEV_GPIO_BUTTONS) += dev-gpio-buttons.o
+ obj-$(CONFIG_ATH79_DEV_LEDS_GPIO) += dev-leds-gpio.o
++obj-$(CONFIG_ATH79_DEV_M25P80) += dev-m25p80.o
++obj-$(CONFIG_ATH79_DEV_NFC) += dev-nfc.o
+ obj-$(CONFIG_ATH79_DEV_SPI) += dev-spi.o
+ obj-$(CONFIG_ATH79_DEV_USB) += dev-usb.o
+ obj-$(CONFIG_ATH79_DEV_WMAC) += dev-wmac.o
+
+ #
++# Miscellaneous objects
++#
++obj-$(CONFIG_ATH79_NVRAM) += nvram.o
++obj-$(CONFIG_ATH79_PCI_ATH9K_FIXUP) += pci-ath9k-fixup.o
++obj-$(CONFIG_ATH79_ROUTERBOOT) += routerboot.o
++
++#
+ # Machines
+ #
+ obj-$(CONFIG_ATH79_MACH_AP121) += mach-ap121.o