summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-3.18/440-leds-wndr3700-usb-led-driver.patch
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-02-15 19:45:29 +0000
committerJohn Crispin <john@openwrt.org>2015-02-15 19:45:29 +0000
commit7e4b3de2493f024432935e283f5eeb2920957871 (patch)
tree10524efa8132ebe05e93a75a10ef3ca733edea0e /target/linux/ar71xx/patches-3.18/440-leds-wndr3700-usb-led-driver.patch
parent9b1c7a9de4a2734b701660a9f3720e842626aea3 (diff)
downloadmaster-31e0f0ae-7e4b3de2493f024432935e283f5eeb2920957871.tar.gz
master-31e0f0ae-7e4b3de2493f024432935e283f5eeb2920957871.tar.bz2
master-31e0f0ae-7e4b3de2493f024432935e283f5eeb2920957871.zip
ar71xx: add v3.18 support
Signed-off-by: John Crispin <blogic@openwrt.org> SVN-Revision: 44456
Diffstat (limited to 'target/linux/ar71xx/patches-3.18/440-leds-wndr3700-usb-led-driver.patch')
-rw-r--r--target/linux/ar71xx/patches-3.18/440-leds-wndr3700-usb-led-driver.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-3.18/440-leds-wndr3700-usb-led-driver.patch b/target/linux/ar71xx/patches-3.18/440-leds-wndr3700-usb-led-driver.patch
new file mode 100644
index 0000000000..6e4fe24d3a
--- /dev/null
+++ b/target/linux/ar71xx/patches-3.18/440-leds-wndr3700-usb-led-driver.patch
@@ -0,0 +1,26 @@
+--- a/drivers/leds/Kconfig
++++ b/drivers/leds/Kconfig
+@@ -505,6 +505,13 @@ config LEDS_VERSATILE
+ This option enabled support for the LEDs on the ARM Versatile
+ and RealView boards. Say Y to enabled these.
+
++config LEDS_WNDR3700_USB
++ tristate "NETGEAR WNDR3700 USB LED driver"
++ depends on LEDS_CLASS && ATH79_MACH_WNDR3700
++ help
++ This option enables support for the USB LED found on the
++ NETGEAR WNDR3700 board.
++
+ comment "LED Triggers"
+ source "drivers/leds/trigger/Kconfig"
+
+--- a/drivers/leds/Makefile
++++ b/drivers/leds/Makefile
+@@ -41,6 +41,7 @@ obj-$(CONFIG_LEDS_DA9052) += leds-da905
+ obj-$(CONFIG_LEDS_WM831X_STATUS) += leds-wm831x-status.o
+ obj-$(CONFIG_LEDS_WM8350) += leds-wm8350.o
+ obj-$(CONFIG_LEDS_PWM) += leds-pwm.o
++obj-${CONFIG_LEDS_WNDR3700_USB} += leds-wndr3700-usb.o
+ obj-$(CONFIG_LEDS_REGULATOR) += leds-regulator.o
+ obj-$(CONFIG_LEDS_INTEL_SS4200) += leds-ss4200.o
+ obj-$(CONFIG_LEDS_LT3593) += leds-lt3593.o