summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-3.18/433-spi-rb4xx-cpld-driver.patch
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-02-15 19:45:29 +0000
committerJohn Crispin <john@openwrt.org>2015-02-15 19:45:29 +0000
commit7e4b3de2493f024432935e283f5eeb2920957871 (patch)
tree10524efa8132ebe05e93a75a10ef3ca733edea0e /target/linux/ar71xx/patches-3.18/433-spi-rb4xx-cpld-driver.patch
parent9b1c7a9de4a2734b701660a9f3720e842626aea3 (diff)
downloadmaster-31e0f0ae-7e4b3de2493f024432935e283f5eeb2920957871.tar.gz
master-31e0f0ae-7e4b3de2493f024432935e283f5eeb2920957871.tar.bz2
master-31e0f0ae-7e4b3de2493f024432935e283f5eeb2920957871.zip
ar71xx: add v3.18 support
Signed-off-by: John Crispin <blogic@openwrt.org> SVN-Revision: 44456
Diffstat (limited to 'target/linux/ar71xx/patches-3.18/433-spi-rb4xx-cpld-driver.patch')
-rw-r--r--target/linux/ar71xx/patches-3.18/433-spi-rb4xx-cpld-driver.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-3.18/433-spi-rb4xx-cpld-driver.patch b/target/linux/ar71xx/patches-3.18/433-spi-rb4xx-cpld-driver.patch
new file mode 100644
index 0000000000..47f0c2421d
--- /dev/null
+++ b/target/linux/ar71xx/patches-3.18/433-spi-rb4xx-cpld-driver.patch
@@ -0,0 +1,26 @@
+--- a/drivers/spi/Kconfig
++++ b/drivers/spi/Kconfig
+@@ -647,6 +647,13 @@ config SPI_TLE62X0
+ sysfs interface, with each line presented as a kind of GPIO
+ exposing both switch control and diagnostic feedback.
+
++config SPI_RB4XX_CPLD
++ tristate "MikroTik RB4XX CPLD driver"
++ depends on ATH79_MACH_RB4XX
++ help
++ SPI driver for the Xilinx CPLD chip present on the
++ MikroTik RB4xx boards.
++
+ #
+ # Add new SPI protocol masters in alphabetical order above this line
+ #
+--- a/drivers/spi/Makefile
++++ b/drivers/spi/Makefile
+@@ -63,6 +63,7 @@ spi-pxa2xx-platform-$(CONFIG_SPI_PXA2XX_
+ obj-$(CONFIG_SPI_PXA2XX) += spi-pxa2xx-platform.o
+ obj-$(CONFIG_SPI_PXA2XX_PCI) += spi-pxa2xx-pci.o
+ obj-$(CONFIG_SPI_RB4XX) += spi-rb4xx.o
++obj-$(CONFIG_SPI_RB4XX_CPLD) += spi-rb4xx-cpld.o
+ obj-$(CONFIG_SPI_QUP) += spi-qup.o
+ obj-$(CONFIG_SPI_ROCKCHIP) += spi-rockchip.o
+ obj-$(CONFIG_SPI_RSPI) += spi-rspi.o