summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-3.18/432-spi-rb4xx-spi-driver.patch
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-02-15 19:45:29 +0000
committerJohn Crispin <john@openwrt.org>2015-02-15 19:45:29 +0000
commit7e4b3de2493f024432935e283f5eeb2920957871 (patch)
tree10524efa8132ebe05e93a75a10ef3ca733edea0e /target/linux/ar71xx/patches-3.18/432-spi-rb4xx-spi-driver.patch
parent9b1c7a9de4a2734b701660a9f3720e842626aea3 (diff)
downloadmaster-31e0f0ae-7e4b3de2493f024432935e283f5eeb2920957871.tar.gz
master-31e0f0ae-7e4b3de2493f024432935e283f5eeb2920957871.tar.bz2
master-31e0f0ae-7e4b3de2493f024432935e283f5eeb2920957871.zip
ar71xx: add v3.18 support
Signed-off-by: John Crispin <blogic@openwrt.org> SVN-Revision: 44456
Diffstat (limited to 'target/linux/ar71xx/patches-3.18/432-spi-rb4xx-spi-driver.patch')
-rw-r--r--target/linux/ar71xx/patches-3.18/432-spi-rb4xx-spi-driver.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-3.18/432-spi-rb4xx-spi-driver.patch b/target/linux/ar71xx/patches-3.18/432-spi-rb4xx-spi-driver.patch
new file mode 100644
index 0000000000..27159b3bb2
--- /dev/null
+++ b/target/linux/ar71xx/patches-3.18/432-spi-rb4xx-spi-driver.patch
@@ -0,0 +1,25 @@
+--- a/drivers/spi/Kconfig
++++ b/drivers/spi/Kconfig
+@@ -433,6 +433,12 @@ config SPI_QUP
+ This driver can also be built as a module. If so, the module
+ will be called spi_qup.
+
++config SPI_RB4XX
++ tristate "Mikrotik RB4XX SPI master"
++ depends on SPI_MASTER && ATH79_MACH_RB4XX
++ help
++ SPI controller driver for the Mikrotik RB4xx series boards.
++
+ config SPI_S3C24XX
+ tristate "Samsung S3C24XX series SPI"
+ depends on ARCH_S3C24XX
+--- a/drivers/spi/Makefile
++++ b/drivers/spi/Makefile
+@@ -62,6 +62,7 @@ spi-pxa2xx-platform-$(CONFIG_SPI_PXA2XX_
+ spi-pxa2xx-platform-$(CONFIG_SPI_PXA2XX_DMA) += spi-pxa2xx-dma.o
+ obj-$(CONFIG_SPI_PXA2XX) += spi-pxa2xx-platform.o
+ obj-$(CONFIG_SPI_PXA2XX_PCI) += spi-pxa2xx-pci.o
++obj-$(CONFIG_SPI_RB4XX) += spi-rb4xx.o
+ obj-$(CONFIG_SPI_QUP) += spi-qup.o
+ obj-$(CONFIG_SPI_ROCKCHIP) += spi-rockchip.o
+ obj-$(CONFIG_SPI_RSPI) += spi-rspi.o