summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-3.14
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2014-11-14 16:54:07 +0000
committerJohn Crispin <john@openwrt.org>2014-11-14 16:54:07 +0000
commit95544f33dd204abe78dac54d4ac62fc19a58b980 (patch)
tree949618511ae1d52f332cd489037df6c32b43ec0e /target/linux/ar71xx/patches-3.14
parent79475ee880e8200fe3e43c2fa48329692af30ba8 (diff)
downloadmaster-31e0f0ae-95544f33dd204abe78dac54d4ac62fc19a58b980.tar.gz
master-31e0f0ae-95544f33dd204abe78dac54d4ac62fc19a58b980.tar.bz2
master-31e0f0ae-95544f33dd204abe78dac54d4ac62fc19a58b980.zip
ar71xx: add kernel support for the OpenMesh MR900 board
Signed-off-by: Sven Eckelmann <sven@open-mesh.com> SVN-Revision: 43258
Diffstat (limited to 'target/linux/ar71xx/patches-3.14')
-rw-r--r--target/linux/ar71xx/patches-3.14/730-MIPS-ath79-add-mr900-support.patch39
1 files changed, 39 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-3.14/730-MIPS-ath79-add-mr900-support.patch b/target/linux/ar71xx/patches-3.14/730-MIPS-ath79-add-mr900-support.patch
new file mode 100644
index 0000000000..deb6e56aa9
--- /dev/null
+++ b/target/linux/ar71xx/patches-3.14/730-MIPS-ath79-add-mr900-support.patch
@@ -0,0 +1,39 @@
+--- a/arch/mips/ath79/Kconfig
++++ b/arch/mips/ath79/Kconfig
+@@ -654,6 +654,16 @@ config ATH79_MACH_CAP4200AG
+ select ATH79_DEV_M25P80
+ select ATH79_DEV_WMAC
+
++config ATH79_MACH_MR900
++ bool "OpenMesh MR900 board support"
++ select SOC_QCA955X
++ select ATH79_DEV_AP9X_PCI if PCI
++ select ATH79_DEV_ETH
++ select ATH79_DEV_GPIO_BUTTONS
++ select ATH79_DEV_LEDS_GPIO
++ select ATH79_DEV_M25P80
++ select ATH79_DEV_WMAC
++
+ config ATH79_MACH_EAP7660D
+ bool "Senao EAP7660D support"
+ select SOC_AR71XX
+--- a/arch/mips/ath79/Makefile
++++ b/arch/mips/ath79/Makefile
+@@ -74,6 +74,7 @@ obj-$(CONFIG_ATH79_MACH_JA76PF) += mach
+ obj-$(CONFIG_ATH79_MACH_JWAP003) += mach-jwap003.o
+ obj-$(CONFIG_ATH79_MACH_HORNET_UB) += mach-hornet-ub.o
+ obj-$(CONFIG_ATH79_MACH_MR600) += mach-mr600.o
++obj-$(CONFIG_ATH79_MACH_MR900) += mach-mr900.o
+ obj-$(CONFIG_ATH79_MACH_MYNET_N600) += mach-mynet-n600.o
+ obj-$(CONFIG_ATH79_MACH_MYNET_N750) += mach-mynet-n750.o
+ obj-$(CONFIG_ATH79_MACH_MYNET_REXT) += mach-mynet-rext.o
+--- a/arch/mips/ath79/machtypes.h
++++ b/arch/mips/ath79/machtypes.h
+@@ -65,6 +65,7 @@ enum ath79_mach_type {
+ ATH79_MACH_HORNET_UB, /* ALFA Networks Hornet-UB */
+ ATH79_MACH_MR600V2, /* OpenMesh MR600v2 */
+ ATH79_MACH_MR600, /* OpenMesh MR600 */
++ ATH79_MACH_MR900, /* OpenMesh MR900 */
+ ATH79_MACH_MYNET_N600, /* WD My Net N600 */
+ ATH79_MACH_MYNET_N750, /* WD My Net N750 */
+ ATH79_MACH_MYNET_REXT, /* WD My Net Wi-Fi Range Extender */