summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-3.14/718-MIPS-ath79-add-ESR1750-support.patch
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2015-02-07 20:53:16 +0000
committerLuka Perkov <luka@openwrt.org>2015-02-07 20:53:16 +0000
commitfcfbbfc3859723dbc27dcf211d0e12eef30f38f8 (patch)
tree6cd1577daa7bdad989f0eb693e393d3af74c084a /target/linux/ar71xx/patches-3.14/718-MIPS-ath79-add-ESR1750-support.patch
parent71f96048e6e19ba5b7b7972013b3136fd9a99090 (diff)
downloadmaster-31e0f0ae-fcfbbfc3859723dbc27dcf211d0e12eef30f38f8.tar.gz
master-31e0f0ae-fcfbbfc3859723dbc27dcf211d0e12eef30f38f8.tar.bz2
master-31e0f0ae-fcfbbfc3859723dbc27dcf211d0e12eef30f38f8.zip
ar71xx: merge board specific patches into one
Signed-off-by: Luka Perkov <luka@openwrt.org> SVN-Revision: 44309
Diffstat (limited to 'target/linux/ar71xx/patches-3.14/718-MIPS-ath79-add-ESR1750-support.patch')
-rw-r--r--target/linux/ar71xx/patches-3.14/718-MIPS-ath79-add-ESR1750-support.patch39
1 files changed, 0 insertions, 39 deletions
diff --git a/target/linux/ar71xx/patches-3.14/718-MIPS-ath79-add-ESR1750-support.patch b/target/linux/ar71xx/patches-3.14/718-MIPS-ath79-add-ESR1750-support.patch
deleted file mode 100644
index d47391ceb8..0000000000
--- a/target/linux/ar71xx/patches-3.14/718-MIPS-ath79-add-ESR1750-support.patch
+++ /dev/null
@@ -1,39 +0,0 @@
---- a/arch/mips/ath79/Kconfig
-+++ b/arch/mips/ath79/Kconfig
-@@ -177,6 +177,16 @@ config ATH79_MACH_AW_NR580
- select ATH79_DEV_LEDS_GPIO
- select ATH79_DEV_M25P80
-
-+config ATH79_MACH_ESR1750
-+ bool "EnGenius ESR1750 board support"
-+ select SOC_QCA955X
-+ select ATH79_DEV_ETH
-+ select ATH79_DEV_GPIO_BUTTONS
-+ select ATH79_DEV_LEDS_GPIO
-+ select ATH79_DEV_M25P80
-+ select ATH79_DEV_USB
-+ select ATH79_DEV_WMAC
-+
- config ATH79_MACH_WHR_HP_G300N
- bool "Buffalo WHR-HP-G300N board support"
- select SOC_AR724X
---- a/arch/mips/ath79/Makefile
-+++ b/arch/mips/ath79/Makefile
-@@ -65,6 +65,7 @@ obj-$(CONFIG_ATH79_MACH_EW_DORIN) += mac
- obj-$(CONFIG_ATH79_MACH_EAP7660D) += mach-eap7660d.o
- obj-$(CONFIG_ATH79_MACH_EL_M150) += mach-el-m150.o
- obj-$(CONFIG_ATH79_MACH_EL_MINI) += mach-el-mini.o
-+obj-$(CONFIG_ATH79_MACH_ESR1750) += mach-esr1750.o
- obj-$(CONFIG_ATH79_MACH_GL_INET) += mach-gl-inet.o
- obj-$(CONFIG_ATH79_MACH_GS_OOLITE) += mach-gs-oolite.o
- obj-$(CONFIG_ATH79_MACH_HIWIFI_HC6361) += mach-hiwifi-hc6361.o
---- a/arch/mips/ath79/machtypes.h
-+++ b/arch/mips/ath79/machtypes.h
-@@ -53,6 +53,7 @@ enum ath79_mach_type {
- ATH79_MACH_EAP7660D, /* Senao EAP7660D */
- ATH79_MACH_EL_M150, /* EasyLink EL-M150 */
- ATH79_MACH_EL_MINI, /* EasyLink EL-MINI */
-+ ATH79_MACH_ESR1750, /* EnGenius ESR1750 */
- ATH79_MACH_GL_INET, /* GL-CONNECT GL-INET */
- ATH79_MACH_GS_OOLITE, /* GS OOLITE V1.0 */
- ATH79_MACH_HIWIFI_HC6361, /* HiWiFi HC6361 */