summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-3.14/610-MIPS-ath79-openwrt-machines.patch
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-02-02 09:00:21 +0000
committerJohn Crispin <john@openwrt.org>2015-02-02 09:00:21 +0000
commitbc906ca59e9f437f5cb9543714d1b979ea82838e (patch)
tree2a36e8dfc3d14518f704163aa2657d83c8f5594e /target/linux/ar71xx/patches-3.14/610-MIPS-ath79-openwrt-machines.patch
parent119b90759b23cf082cbe0e21be82240660f25890 (diff)
downloadmaster-31e0f0ae-bc906ca59e9f437f5cb9543714d1b979ea82838e.tar.gz
master-31e0f0ae-bc906ca59e9f437f5cb9543714d1b979ea82838e.tar.bz2
master-31e0f0ae-bc906ca59e9f437f5cb9543714d1b979ea82838e.zip
added board support for compex wpj558
Signed-off-by: Christian Mehlis <christian@m3hlis.de> SVN-Revision: 44237
Diffstat (limited to 'target/linux/ar71xx/patches-3.14/610-MIPS-ath79-openwrt-machines.patch')
-rw-r--r--target/linux/ar71xx/patches-3.14/610-MIPS-ath79-openwrt-machines.patch25
1 files changed, 19 insertions, 6 deletions
diff --git a/target/linux/ar71xx/patches-3.14/610-MIPS-ath79-openwrt-machines.patch b/target/linux/ar71xx/patches-3.14/610-MIPS-ath79-openwrt-machines.patch
index b01c5de1ff..b100752f5b 100644
--- a/target/linux/ar71xx/patches-3.14/610-MIPS-ath79-openwrt-machines.patch
+++ b/target/linux/ar71xx/patches-3.14/610-MIPS-ath79-openwrt-machines.patch
@@ -1,6 +1,6 @@
--- a/arch/mips/ath79/machtypes.h
+++ b/arch/mips/ath79/machtypes.h
-@@ -16,22 +16,146 @@
+@@ -16,22 +16,147 @@
enum ath79_mach_type {
ATH79_MACH_GENERIC = 0,
@@ -136,6 +136,7 @@
+ ATH79_MACH_WNR612_V2, /* NETGEAR WNR612 v2 */
+ ATH79_MACH_WP543, /* Compex WP543 */
+ ATH79_MACH_WPE72, /* Compex WPE72 */
++ ATH79_MACH_WPJ558, /* Compex WPJ558 */
+ ATH79_MACH_WRT160NL, /* Linksys WRT160NL */
+ ATH79_MACH_WRT400N, /* Linksys WRT400N */
+ ATH79_MACH_WZR_HP_AG300H, /* Buffalo WZR-HP-AG300H */
@@ -211,7 +212,7 @@
config ATH79_MACH_AP121
bool "Atheros AP121 reference board"
select SOC_AR933X
-@@ -11,62 +66,743 @@ config ATH79_MACH_AP121
+@@ -11,62 +66,754 @@ config ATH79_MACH_AP121
select ATH79_DEV_M25P80
select ATH79_DEV_USB
select ATH79_DEV_WMAC
@@ -416,6 +417,17 @@
+ select ATH79_DEV_USB
+ select MYLOADER
+
++config ATH79_MACH_WPJ558
++ bool "Compex WPJ558 board support"
++ select SOC_QCA955X
++ select ATH79_DEV_ETH
++ select ATH79_DEV_GPIO_BUTTONS
++ select ATH79_DEV_LEDS_GPIO
++ select ATH79_DEV_M25P80
++ select ATH79_DEV_USB
++ select ATH79_DEV_WMAC
++ select MYLOADER
++
+config ATH79_MACH_DIR_505_A1
+ bool "D-Link DIR-505-A1 support"
+ select SOC_AR933X
@@ -983,7 +995,7 @@
config ATH79_MACH_UBNT_XM
bool "Ubiquiti Networks XM/UniFi boards"
-@@ -83,6 +819,65 @@ config ATH79_MACH_UBNT_XM
+@@ -83,6 +830,65 @@ config ATH79_MACH_UBNT_XM
Say 'Y' here if you want your kernel to support the
Ubiquiti Networks XM (rev 1.0) board.
@@ -1049,7 +1061,7 @@
endmenu
config SOC_AR71XX
-@@ -132,7 +927,10 @@ config ATH79_DEV_DSA
+@@ -132,7 +938,10 @@ config ATH79_DEV_DSA
config ATH79_DEV_ETH
def_bool n
@@ -1061,7 +1073,7 @@
def_bool n
config ATH79_DEV_GPIO_BUTTONS
-@@ -164,4 +962,7 @@ config ATH79_PCI_ATH9K_FIXUP
+@@ -164,4 +973,7 @@ config ATH79_PCI_ATH9K_FIXUP
config ATH79_ROUTERBOOT
def_bool n
@@ -1071,7 +1083,7 @@
endif
--- a/arch/mips/ath79/Makefile
+++ b/arch/mips/ath79/Makefile
-@@ -38,9 +38,91 @@ obj-$(CONFIG_ATH79_ROUTERBOOT) += route
+@@ -38,9 +49,92 @@ obj-$(CONFIG_ATH79_ROUTERBOOT) += route
#
# Machines
#
@@ -1155,6 +1167,7 @@
+obj-$(CONFIG_ATH79_MACH_WNR2200) += mach-wnr2200.o
+obj-$(CONFIG_ATH79_MACH_WP543) += mach-wp543.o
+obj-$(CONFIG_ATH79_MACH_WPE72) += mach-wpe72.o
++obj-$(CONFIG_ATH79_MACH_WPJ558) += mach-wpj558.o
+obj-$(CONFIG_ATH79_MACH_WRT160NL) += mach-wrt160nl.o
+obj-$(CONFIG_ATH79_MACH_WRT400N) += mach-wrt400n.o
+obj-$(CONFIG_ATH79_MACH_WZR_HP_G300NH) += mach-wzr-hp-g300nh.o