summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-3.14/404-mtd-cybertan-trx-parser.patch
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-03-11 15:56:15 +0000
committerJohn Crispin <john@openwrt.org>2015-03-11 15:56:15 +0000
commite5373f2761544b3a0bef395b7239dfb281bc8211 (patch)
treea6231c628ac3d1f7f0758dc7d08b917ef2f72a52 /target/linux/ar71xx/patches-3.14/404-mtd-cybertan-trx-parser.patch
parent9f16b370a0506f01aa5ec40190e995f371d9027a (diff)
downloadmaster-31e0f0ae-e5373f2761544b3a0bef395b7239dfb281bc8211.tar.gz
master-31e0f0ae-e5373f2761544b3a0bef395b7239dfb281bc8211.tar.bz2
master-31e0f0ae-e5373f2761544b3a0bef395b7239dfb281bc8211.zip
ar71xx: rename wrt160nl's trx partition parser
This patch renames the partition parser from wrt160nl to more generic cybertan. Signed-off-by: Christian Lamparter <chunkeey@googlemail.com> SVN-Revision: 44663
Diffstat (limited to 'target/linux/ar71xx/patches-3.14/404-mtd-cybertan-trx-parser.patch')
-rw-r--r--target/linux/ar71xx/patches-3.14/404-mtd-cybertan-trx-parser.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-3.14/404-mtd-cybertan-trx-parser.patch b/target/linux/ar71xx/patches-3.14/404-mtd-cybertan-trx-parser.patch
new file mode 100644
index 0000000000..7995abbb45
--- /dev/null
+++ b/target/linux/ar71xx/patches-3.14/404-mtd-cybertan-trx-parser.patch
@@ -0,0 +1,25 @@
+--- a/drivers/mtd/Kconfig
++++ b/drivers/mtd/Kconfig
+@@ -184,6 +184,12 @@ config MTD_BCM47XX_PARTS
+ This provides partitions parser for devices based on BCM47xx
+ boards.
+
++config MTD_CYBERTAN_PARTS
++ tristate "Cybertan partitioning support"
++ depends on ATH79
++ ---help---
++ Cybertan partitioning support
++
+ config MTD_MYLOADER_PARTS
+ tristate "MyLoader partition parsing"
+ depends on ADM5120 || ATHEROS_AR231X || ATHEROS_AR71XX || ATH79
+--- a/drivers/mtd/Makefile
++++ b/drivers/mtd/Makefile
+@@ -16,6 +16,7 @@ obj-$(CONFIG_MTD_AR7_PARTS) += ar7part.o
+ obj-$(CONFIG_MTD_BCM63XX_PARTS) += bcm63xxpart.o
+ obj-$(CONFIG_MTD_BCM47XX_PARTS) += bcm47xxpart.o
+ obj-$(CONFIG_MTD_MYLOADER_PARTS) += myloader.o
++obj-$(CONFIG_MTD_CYBERTAN_PARTS) += cybertan_part.o
+
+ # 'Users' - code which presents functionality to userspace.
+ obj-$(CONFIG_MTD_BLKDEVS) += mtd_blkdevs.o