summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-3.10
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-10-30 06:50:57 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-10-30 06:50:57 +0000
commitef8306cfd2235bf3d060ce5d67fbad69afed228b (patch)
treee006508beaccb849e40055a4f2601e4204a05656 /target/linux/ar71xx/patches-3.10
parentacd4ea62e746aee5b812415253f70cbface7402f (diff)
downloadmaster-31e0f0ae-ef8306cfd2235bf3d060ce5d67fbad69afed228b.tar.gz
master-31e0f0ae-ef8306cfd2235bf3d060ce5d67fbad69afed228b.tar.bz2
master-31e0f0ae-ef8306cfd2235bf3d060ce5d67fbad69afed228b.zip
ar71xx: add kernel support for BHU Networks BXU2000n-2 A1 board
BXU2000n-2 A1 is a BHU Networks WLAN board, use ar9341 chip. Patchwork: http://patchwork.openwrt.org/patch/4183/ Signed-off-by: Terry Yang <yangbo@bhunetworks.com> [juhosg: - rename and refresh kernel patch, - fix some checkpatch warnings and adjust whitespaces in mach-bhu-bxu2000n2-a.c] Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 38591
Diffstat (limited to 'target/linux/ar71xx/patches-3.10')
-rw-r--r--target/linux/ar71xx/patches-3.10/631-MIPS-ath79-add-BHU-BXU2000n2-A1-support.patch39
1 files changed, 39 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-3.10/631-MIPS-ath79-add-BHU-BXU2000n2-A1-support.patch b/target/linux/ar71xx/patches-3.10/631-MIPS-ath79-add-BHU-BXU2000n2-A1-support.patch
new file mode 100644
index 0000000000..8ebaa28805
--- /dev/null
+++ b/target/linux/ar71xx/patches-3.10/631-MIPS-ath79-add-BHU-BXU2000n2-A1-support.patch
@@ -0,0 +1,39 @@
+--- a/arch/mips/ath79/Kconfig
++++ b/arch/mips/ath79/Kconfig
+@@ -826,6 +826,16 @@ config ATH79_MACH_CARAMBOLA2
+ select ATH79_DEV_USB
+ select ATH79_DEV_WMAC
+
++config ATH79_MACH_BHU_BXU2000N2_A
++ bool "BHU BXU2000n-2 rev. A support"
++ select SOC_AR934X
++ select ATH79_DEV_ETH
++ select ATH79_DEV_GPIO_BUTTONS
++ select ATH79_DEV_LEDS_GPIO
++ select ATH79_DEV_M25P80
++ select ATH79_DEV_USB
++ select ATH79_DEV_WMAC
++
+ endmenu
+
+ config SOC_AR71XX
+--- a/arch/mips/ath79/Makefile
++++ b/arch/mips/ath79/Makefile
+@@ -51,6 +51,7 @@ obj-$(CONFIG_ATH79_MACH_AP83) += mach-a
+ obj-$(CONFIG_ATH79_MACH_AP96) += mach-ap96.o
+ obj-$(CONFIG_ATH79_MACH_ARCHER_C7) += mach-archer-c7.o
+ obj-$(CONFIG_ATH79_MACH_AW_NR580) += mach-aw-nr580.o
++obj-$(CONFIG_ATH79_MACH_BHU_BXU2000N2_A)+= mach-bhu-bxu2000n2-a.o
+ obj-$(CONFIG_ATH79_MACH_CAP4200AG) += mach-cap4200ag.o
+ obj-$(CONFIG_ATH79_MACH_DB120) += mach-db120.o
+ obj-$(CONFIG_ATH79_MACH_DIR_505_A1) += mach-dir-505-a1.o
+--- a/arch/mips/ath79/machtypes.h
++++ b/arch/mips/ath79/machtypes.h
+@@ -33,6 +33,7 @@ enum ath79_mach_type {
+ ATH79_MACH_AP96, /* Atheros AP96 */
+ ATH79_MACH_ARCHER_C7, /* TP-LINK Archer C7 board */
+ ATH79_MACH_AW_NR580, /* AzureWave AW-NR580 */
++ ATH79_MACH_BHU_BXU2000N2_A1, /* BHU BXU2000n-2 A1 */
+ ATH79_MACH_CAP4200AG, /* Senao CAP4200AG */
+ ATH79_MACH_CARAMBOLA2, /* 8devices Carambola2 */
+ ATH79_MACH_DB120, /* Atheros DB120 reference board */