summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-3.10
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-09-19 17:52:41 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-09-19 17:52:41 +0000
commite3e31835ae8df36e9b122b08f53476cfc7b6a929 (patch)
tree8fcdb67312d82ece1baf196a48c1287676205999 /target/linux/ar71xx/patches-3.10
parent5e23012c77b484bdbc1d72c3b652eb1beb93f090 (diff)
downloadmaster-31e0f0ae-e3e31835ae8df36e9b122b08f53476cfc7b6a929.tar.gz
master-31e0f0ae-e3e31835ae8df36e9b122b08f53476cfc7b6a929.tar.bz2
master-31e0f0ae-e3e31835ae8df36e9b122b08f53476cfc7b6a929.zip
ar71xx: add kernel support for TP-Link TL-MR13U
This patch adds support for TP-Link TL-MR13U router with built-in 10AH rechargeable battery. The patch is based on kamwanlai's patch: https://forum.openwrt.org/viewtopic.php?pid=206746#p206746 Updated to accommodate recent changes introduced with: ar71xx: remove fs_* variables from image/Makefile Signed-off-by: Oleg Titov <oleg.titov@gmail.com> Patchwork: http://patchwork.openwrt.org/patch/4063/ [juhosg: - refresh and rename rename 930-add-tl-mr13u-support.patch => 625-MIPS-ath79-add-tl-mr13u-support.patch] Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 38063
Diffstat (limited to 'target/linux/ar71xx/patches-3.10')
-rw-r--r--target/linux/ar71xx/patches-3.10/625-MIPS-ath79-add-tl-mr13u-support.patch39
1 files changed, 39 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-3.10/625-MIPS-ath79-add-tl-mr13u-support.patch b/target/linux/ar71xx/patches-3.10/625-MIPS-ath79-add-tl-mr13u-support.patch
new file mode 100644
index 0000000000..b960a6dd27
--- /dev/null
+++ b/target/linux/ar71xx/patches-3.10/625-MIPS-ath79-add-tl-mr13u-support.patch
@@ -0,0 +1,39 @@
+--- a/arch/mips/ath79/Kconfig
++++ b/arch/mips/ath79/Kconfig
+@@ -535,6 +535,16 @@ config ATH79_MACH_TL_MR11U
+ select ATH79_DEV_USB
+ select ATH79_DEV_WMAC
+
++config ATH79_MACH_TL_MR13U
++ bool "TP-LINK TL-MR13U support"
++ select SOC_AR933X
++ select ATH79_DEV_ETH
++ select ATH79_DEV_GPIO_BUTTONS
++ select ATH79_DEV_LEDS_GPIO
++ select ATH79_DEV_M25P80
++ select ATH79_DEV_USB
++ select ATH79_DEV_WMAC
++
+ config ATH79_MACH_TL_MR3020
+ bool "TP-LINK TL-MR3020 support"
+ select SOC_AR933X
+--- a/arch/mips/ath79/machtypes.h
++++ b/arch/mips/ath79/machtypes.h
+@@ -84,6 +84,7 @@ enum ath79_mach_type {
+ ATH79_MACH_TEW_712BR, /* TRENDnet TEW-712BR */
+ ATH79_MACH_TL_MR10U, /* TP-LINK TL-MR10U */
+ ATH79_MACH_TL_MR11U, /* TP-LINK TL-MR11U */
++ ATH79_MACH_TL_MR13U, /* TP-LINK TL-MR13U */
+ ATH79_MACH_TL_MR3020, /* TP-LINK TL-MR3020 */
+ ATH79_MACH_TL_MR3040, /* TP-LINK TL-MR3040 */
+ ATH79_MACH_TL_MR3220, /* TP-LINK TL-MR3220 */
+--- a/arch/mips/ath79/Makefile
++++ b/arch/mips/ath79/Makefile
+@@ -80,6 +80,7 @@ obj-$(CONFIG_ATH79_MACH_TEW_632BRP) += m
+ obj-$(CONFIG_ATH79_MACH_TEW_673GRU) += mach-tew-673gru.o
+ obj-$(CONFIG_ATH79_MACH_TEW_712BR) += mach-tew-712br.o
+ obj-$(CONFIG_ATH79_MACH_TL_MR11U) += mach-tl-mr11u.o
++obj-$(CONFIG_ATH79_MACH_TL_MR13U) += mach-tl-mr13u.o
+ obj-$(CONFIG_ATH79_MACH_TL_MR3020) += mach-tl-mr3020.o
+ obj-$(CONFIG_ATH79_MACH_TL_MR3X20) += mach-tl-mr3x20.o
+ obj-$(CONFIG_ATH79_MACH_TL_WA901ND) += mach-tl-wa901nd.o