summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-3.10
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-12-16 12:57:24 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-12-16 12:57:24 +0000
commit8461ffccc15a1728a9501ebd428cc60c6273d11f (patch)
tree4882904ab4a45a33ef2a1cb0dbd42e5bca14ee73 /target/linux/ar71xx/patches-3.10
parentd7a01844466c3103d3f93f3efbc0c5403746ca77 (diff)
downloadmaster-31e0f0ae-8461ffccc15a1728a9501ebd428cc60c6273d11f.tar.gz
master-31e0f0ae-8461ffccc15a1728a9501ebd428cc60c6273d11f.tar.bz2
master-31e0f0ae-8461ffccc15a1728a9501ebd428cc60c6273d11f.zip
ar71xx: add NAND driver for the Mikrotik RB91x boards
Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 39097
Diffstat (limited to 'target/linux/ar71xx/patches-3.10')
-rw-r--r--target/linux/ar71xx/patches-3.10/414-mtd-rb91x-nand-driver.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-3.10/414-mtd-rb91x-nand-driver.patch b/target/linux/ar71xx/patches-3.10/414-mtd-rb91x-nand-driver.patch
new file mode 100644
index 0000000000..85e6b0ab84
--- /dev/null
+++ b/target/linux/ar71xx/patches-3.10/414-mtd-rb91x-nand-driver.patch
@@ -0,0 +1,23 @@
+--- a/drivers/mtd/nand/Kconfig
++++ b/drivers/mtd/nand/Kconfig
+@@ -552,6 +552,10 @@ config MTD_NAND_RB750
+ tristate "NAND flash driver for the RouterBoard 750"
+ depends on MTD_NAND && ATH79_MACH_RB750
+
++config MTD_NAND_RB91X
++ tristate "NAND flash driver for the RouterBOARD 91x series"
++ depends on MTD_NAND && ATH79_MACH_RB91X
++
+ config MTD_NAND_AR934X
+ tristate "NAND flash driver for the Qualcomm Atheros AR934x/QCA955x SoCs"
+ depends on (SOC_AR934X || SOC_QCA955X)
+--- a/drivers/mtd/nand/Makefile
++++ b/drivers/mtd/nand/Makefile
+@@ -34,6 +34,7 @@ obj-$(CONFIG_MTD_NAND_TMIO) += tmio_nan
+ obj-$(CONFIG_MTD_NAND_PLATFORM) += plat_nand.o
+ obj-$(CONFIG_MTD_NAND_RB4XX) += rb4xx_nand.o
+ obj-$(CONFIG_MTD_NAND_RB750) += rb750_nand.o
++obj-$(CONFIG_MTD_NAND_RB91X) += rb91x_nand.o
+ obj-$(CONFIG_MTD_ALAUDA) += alauda.o
+ obj-$(CONFIG_MTD_NAND_PASEMI) += pasemi_nand.o
+ obj-$(CONFIG_MTD_NAND_ORION) += orion_nand.o