summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-3.10
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-09-19 16:56:48 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-09-19 16:56:48 +0000
commit49ed06e36f9f80e5e02860dafa5cdfb83a743954 (patch)
tree67f94e525c3cf689d3d943d5a6399445b52490ae /target/linux/ar71xx/patches-3.10
parent9d24525b1de402c5a400b5d4e01c90badd4673c8 (diff)
downloadmaster-31e0f0ae-49ed06e36f9f80e5e02860dafa5cdfb83a743954.tar.gz
master-31e0f0ae-49ed06e36f9f80e5e02860dafa5cdfb83a743954.tar.bz2
master-31e0f0ae-49ed06e36f9f80e5e02860dafa5cdfb83a743954.zip
ar71xx: add kernel support for Netgear WNR2200 wireless router
This patch adds OpenWRT support for the Netgear WNR2200 (N300) wireless router with USB. Technical details of this router can be found at http://www.netgear.com/home/products/wirelessrouters/work-and-play/WNR2200.aspx and http://wikidevi.com/wiki/Netgear_WNR2200 Signed-off-by: Aidan Kissane <aidankissane@googlemail.com> Signed-off-by: Dirk Neukirchen <dirkneukirchen@web.de> Patchwork: http://patchwork.openwrt.org/patch/4055/ [juhosg: - add commit message and SoB line from the original patch - remove dead code from mach-wnr2200.c - refresh 624-MIPS-ath79-WNR2200-support.patch] Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 38059
Diffstat (limited to 'target/linux/ar71xx/patches-3.10')
-rw-r--r--target/linux/ar71xx/patches-3.10/624-MIPS-ath79-WNR2200-support.patch39
1 files changed, 39 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-3.10/624-MIPS-ath79-WNR2200-support.patch b/target/linux/ar71xx/patches-3.10/624-MIPS-ath79-WNR2200-support.patch
new file mode 100644
index 0000000000..9f028acd47
--- /dev/null
+++ b/target/linux/ar71xx/patches-3.10/624-MIPS-ath79-WNR2200-support.patch
@@ -0,0 +1,39 @@
+--- a/arch/mips/ath79/machtypes.h
++++ b/arch/mips/ath79/machtypes.h
+@@ -128,6 +128,7 @@ enum ath79_mach_type {
+ ATH79_MACH_WNDR4300, /* NETGEAR WNDR4300 */
+ ATH79_MACH_WNR2000, /* NETGEAR WNR2000 */
+ ATH79_MACH_WNR2000_V3, /* NETGEAR WNR2000 v3 */
++ ATH79_MACH_WNR2200, /* NETGEAR WNR2200 */
+ ATH79_MACH_WNR612_V2, /* NETGEAR WNR612 v2 */
+ ATH79_MACH_WP543, /* Compex WP543 */
+ ATH79_MACH_WPE72, /* Compex WPE72 */
+--- a/arch/mips/ath79/Kconfig
++++ b/arch/mips/ath79/Kconfig
+@@ -437,6 +437,16 @@ config ATH79_MACH_WNR2000_V3
+ select ATH79_DEV_LEDS_GPIO
+ select ATH79_DEV_M25P80
+
++ config ATH79_MACH_WNR2200
++ bool "NETGEAR WNR2200 board support"
++ select SOC_AR724X
++ select ATH79_DEV_AP9X_PCI if PCI
++ select ATH79_DEV_ETH
++ select ATH79_DEV_GPIO_BUTTONS
++ select ATH79_DEV_LEDS_GPIO
++ select ATH79_DEV_M25P80
++ select ATH79_DEV_USB
++
+ config ATH79_MACH_OM2P
+ bool "OpenMesh OM2P board support"
+ select SOC_AR724X
+--- a/arch/mips/ath79/Makefile
++++ b/arch/mips/ath79/Makefile
+@@ -105,6 +105,7 @@ obj-$(CONFIG_ATH79_MACH_WNDR3700) += mac
+ obj-$(CONFIG_ATH79_MACH_WNDR4300) += mach-wndr4300.o
+ obj-$(CONFIG_ATH79_MACH_WNR2000) += mach-wnr2000.o
+ obj-$(CONFIG_ATH79_MACH_WNR2000_V3) += mach-wnr2000-v3.o
++obj-$(CONFIG_ATH79_MACH_WNR2200) += mach-wnr2200.o
+ obj-$(CONFIG_ATH79_MACH_WP543) += mach-wp543.o
+ obj-$(CONFIG_ATH79_MACH_WPE72) += mach-wpe72.o
+ obj-$(CONFIG_ATH79_MACH_WRT160NL) += mach-wrt160nl.o